Ask / Submit
1

Uber not loading [answered]

asked 2014-08-18 18:18:14 +0300

Olle Jolle gravatar image

updated 2014-08-18 18:20:12 +0300

I'm using Uber, the "private car + driver app". Would love to have Sailfish native (dream on...) but the only option is Android. I live in China, all Google services incl. the Play Store are banned here. So Uber support told me to download from http://www.wandoujia.com/apps/com.ubercab which I did.

It worked fine for a while, used it to get a ride, everything cool. Then, a few days later, when I wanted to launch the app again, it got stuck on the splash screen for an eternity (several minutes) and eventually failed with the error screen below.

I tried rebooting the phone, even removing (via long-tap on the app icon and then the little [x]) and re-installling the .apk file - no luck. How can I reset Uber so that it launches again?

Uber launch failure

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by VDVsx
close date 2014-09-19 15:12:39.855670

Comments

I haven't tried this app, but if I remember correctly, Android apps' data are removed during the following reboot after uninstalling the app. So have you tried uninstalling, rebooting and then installing again?

nodevel ( 2014-08-18 18:42:37 +0300 )edit

Can be also some weird connection issue, you can try also to open the app, disable wifi and mobile data if on, and the enable network again, while leaving the app always open in background.

VDVsx ( 2014-08-20 09:30:16 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-09-18 01:17:47 +0300

Olle Jolle gravatar image

Should not have been a connection issue as I tried several times on different networks, both mobile and WiFi, and after reboots.

But I "solved" it when I realized that WanDouJia had posted an update. Installed the update by side-loading the .apk from my computer and it worked again. So I'm good for now.

edit flag offensive delete publish link more

Comments

Does it still work for you? Because I experience the exact same thing as you described above with the most recent Uber version.

tomka ( 2015-04-12 19:08:28 +0300 )edit

same issue here

Neotopia ( 2015-04-18 12:49:55 +0300 )edit

Just a guess here, but I think Uber started depending on googel services. After this issue started I tried using an older android phone only for uber, but that also failed in pretty much the same way untill I installed google services on it. I'm not willing to experiment with google service on my jolla though, but I suspect it might help to solve this.

Edit: Yes, seems there's a permission for Google Play Services explained on the app's permissions page

kunev ( 2015-04-27 12:58:57 +0300 )edit

Question tools

Follow
1 follower

Stats

Asked: 2014-08-18 18:18:14 +0300

Seen: 3,206 times

Last updated: Aug 18 '14