We have moved to a new Sailfish OS Forum. Please start new discussions there.
6

[BUG] Clock time changes by itself

asked 2014-08-19 11:06:32 +0200

peinu gravatar image

I have had this incident 3 times within a week.

I find out that Clock time is off about 12 hours, the minutes are correct. Going to settings I find that the automatic time is set off. This might be related to setting the alarm time. Made me miss my wake up alarm once, luckily I woke up only half an hour late and it was not the time to catch a flight! Can't trust this bugger anymore on critical alarms though.

The other two times I noticed the wrong time during the day with no problem. Going to settings and setting the automatic time corrects the time immediately.

Software version 1.0.8.19, Tahkalampi

edit retag flag offensive close delete

Comments

1

I noticed the same issue. Until today, the clock would get behind with a few minutes every couple of weeks, however, today I was late because it was about 15 minutes behind when I woke up. I activated the automatic update for now, but I would prefer to have a working clock without this option enabled.

Drekkarian ( 2014-09-05 12:51:13 +0200 )edit

So far I've had two random clock jumps.

Once it ran 5 mins late, another time 30 mins. I have never used the "Automatic update" from the Time and date settings.

ploy ( 2015-04-06 03:49:33 +0200 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2014-09-05 13:21:47 +0200

stezz gravatar image

@Drekkarian I think that the reported issue is different because

that Clock time is off about 12 hours, the minutes are correct

An additional question would be if the Auto-update of the time fixes the problem permanently after that?

edit flag offensive delete publish link more

Comments

Thank you for your answer. Indeed, the issues might be different. I noticed the mention of hours, but I posted here as it seemed related.

Since I left the automatic update on, the clock seems to stay accurate. Without the option, I had to periodically adjust the time with a few minutes. Is there any debugging I can do to help more on this issue? I am wondering if it could be related in any way to periodic restarts I also have, as others reported. Maybe the internal clock fails from time to time? or doesn't update during crashes?

Drekkarian ( 2014-09-05 13:49:13 +0200 )edit

I don't know deeply the area so I have no idea about further debugging... Maybe @pekka-vuorela can shed some light.

stezz ( 2014-09-09 13:52:08 +0200 )edit

Ok. Thanks. Until now, keeping Automatic Update set, the clock stayed on time. So, the problem is only when it runs by itself.

Drekkarian ( 2014-09-09 14:19:32 +0200 )edit

Clock drift is something more or less common in electronic devices, that is why we have mechanisms to fix it. Though it should not be _that_ bad.

stezz ( 2014-09-11 11:50:00 +0200 )edit
0

answered 2015-01-05 02:22:05 +0200

ilievdh gravatar image

I have a similar issue with my 1.1.1.27 Sailfish OS! For a less than a day, my clock is jumping 1h and 30m behind my real time! My Timezone is Europe/Sofia and 'ntpd -gdq' from the root terminal can set the correct time back! If I can't use my phone as a simple organizer, then it's useless for me! Maybe some Android app is fucking the clock or the cellular provider (Mobiltel/Vodafone) is broadcasting a incorrect time. Please, make an option to disable a non native applications or cellular provider to be able to set the clock!

edit flag offensive delete publish link more

Comments

It is indeed possible that the cellular network does not support time information (NITZ, see [1]).

@ilievdh: could you provide answers to the questions below to help us find out what's going on in your device:

  • Do you have an active sim card in your Jolla?
  • Do you have an internet connection set up (either mobile networking or WLAN)?
  • Do you have automatic time update enabled?
  • Is your time zone displayed correctly in the Settings app?
  • What is the output to the terminal command "rpm -q timed-qt5 connman" ?
  • What is the output to the terminal command "cat .timed/settings.data" ?

[1] http://en.wikipedia.org/wiki/NITZ#Carriers_supporting_NITZ

PMG ( 2015-01-12 12:05:08 +0200 )edit

active sim - yes internet - both cellular data + wlan automatic time updated is off Timezone in Settings is correct "[root@Jolla ~]# rpm -q timed-qt5 connman timed-qt5-2.92-1.14.1.armv7hl connman-1.24+git48.1-1.5.1.armv7hl"

[root@Jolla ~]# cat .timed/settings.data cat: .timed/settings.data: No such file or directory [root@Jolla ~]# cat /home/nemo/.timed/settings.data cellular_zone = { value = "Europe/Sofia" }, format_24 = 1, local_cellular = 0, manual_offset = { value = 7200 }, manual_zone = { value = "Europe/Sofia" }, time_nitz = 0

I've added my timezone in /opt/alien/system/build.prop and on the next day there was a bigger offset on my clock from the real time. Then I've supposed that the timezone is calculated twice in the Alien Dalvik's VM. I've set "persist.sys.timezone=Etc/UTC" in /opt/alien/system/build.prop and since then I haven't have the issue with the clock anymore.

ilievdh ( 2015-01-14 03:08:01 +0200 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-08-19 11:06:32 +0200

Seen: 375 times

Last updated: Jan 05 '15