What's the best way to find the reason for tracker problems?

asked 2014-09-08 16:06:00 +0200

ossi1967 gravatar image

A friend of mine owns a Jolla phone, too. It's all nice and he even has other halves that I don't have, but there's one issue on his device that I never experienced: Tracker goes wild and sucks battery big time. Now I know tracker is meant to run every now and then in the background... But I'm afraid somethings wrong on this phone. It's not only the battery that suffers, I've also experienced one case in which I copied a file manually from /usr to ~/Pictures and it didn't show up in the Gallery (an empty space appeared instead). Looks like tracker, too, doesn't it?

Now before I apply my usual trial and error strategy next time I hold his device in my hands, it would be nice to gather some helpful input. Some of the facts:

  • As far as I have seen, it's usually tracker-extract that consumes between 50% and 100% of the CPU, especially after a re-start. Sometimes it's also tracker-store. We've seen tracker working a full day long without obvious reasons.
  • There's an 64GB SDXC card in the phone that has been re-formatted to FAT32 just like that; no further adjustments made to align block size and do all the magic that people recommend you to do. As a result (probably?), the card is now slower than it should be according to the manufacturer, but it still achieves a reasonable read speed. (Also, tracker waiting for I/O to finish shouldn't consume CPU, should it?)
  • As I said before, a copying a JPEG to ~/Pictures made the gallery behave strangely. First the image didn't show up (something like "Cannot show thumbnail"), then I was unable to delete this empty spot in the gallery by any means. Only a re-boot fixed it. (File was manually deleted by then, Gallery was back to normal)

My ideas so far:

  • Don't think, reset tracker. (What's best? Soft reset? Hard reset?) Risk is that this doesn't fix anything at all and tracker takes another 24 hours to rebuild its index.
  • Watch out for fishy entries in a log file. Which one? Simply journalctrl | grep -i tracker? Would that be it?
  • Check for correct configuration/status? Where/How? What's the expected output?
  • Still not sure about the SDXC card. Can the file system have any influence on tracker?

Any input? It would be easier on my own phone, I could try everything there... but on a phone that you don't have access to regularly, you should have a plan before you "fix" it. ;)

edit retag flag offensive close delete

Comments

1

Hi, I had a similar problem with .PLS files in Mediaplayer. Basically the problem was corrected by typing tracker-control -es into Terminal (no need for root). I realise that this may not be the answer you're looking for, but for me, it did solve similar problems you have listed. I have a 32GB SD card formatted as FAT32. Since typing in that code, Ive had no further problems, but as you ask, how best can we investigate the problem to solve it.

Edz ( 2014-09-08 17:22:55 +0200 )edit

I checked the sdcard - there are no *.pls files. Just jpg's and mp3's. Today I took five fotos again with my Jolla - @ about 06:30 a.m. and since then 'tracker-extract' is running heavily at +/- 70% of the CPU.

warmekueche ( 2014-09-09 11:43:42 +0200 )edit

@Markkyboy: It's not the exact answer I'm looking for, you're right, but knowing what others do (and what was successful) is still helpful of course. :)

ossi1967 ( 2014-09-10 10:47:10 +0200 )edit

Today I experienced, that "tracker-extract" started to work after a reboot of my Jolla. It did not start it's activities after I took some fotos (what I would have found more explicable...) but only after this reboot.

warmekueche ( 2014-09-11 09:20:39 +0200 )edit