Ask / Submit
7

[Bug] Can't send MMS when WiFi enabled [released]

asked 2014-09-21 12:31:45 +0200

eson gravatar image

updated 2016-08-17 11:09:33 +0200

jiit gravatar image

As topic says... I can't send mms if wifi is enabled. Never could. It keeps coming back with error message "could not send...". Sending mms with wifi disabled is no problem. My provider is Tre (Sweden), if that has anything to do with it. Phone is fully updated (SailfishOS 1.0.8.19), with no Android support installed.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by eson
close date 2017-08-24 16:34:59.521242

Comments

It could be an answer.

To send MMS, you must use DATA connection with a dedicated access parameter set. It can be used only when 3G DATA is "Active".

When wifi has the network focus, all TCP/IP trafic goes thru wifi. Unfortunately, your SIM id is not managed by wifi natively (maybe one day when EAP-SIM will be activated on the Jolla).

So your provider can't identify you when you send MMS via wifi. The unique available channel, for the moment, is DATA.

TNZ ( 2014-09-23 12:04:48 +0200 )edit
1

This is a real bug. Because Sailfish should be able to use the right connection. And the issue is also with MMS reception, this is really annoying

doktoil makresh ( 2014-09-23 12:41:19 +0200 )edit

@TNZ You're absolutely right, but as mentioned by @doktoil makresh, the system should be able to choose the right channel for MMS.

eson ( 2014-09-23 12:59:27 +0200 )edit
1

Could be conflicting IPv4 addresses in MMS and WLAN interfaces.

jr ( 2014-09-23 23:34:10 +0200 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2014-10-03 14:01:31 +0200

slava gravatar image

What do you have in Settings -> System ->Mobile network -> MMS access point -> Proxy address? If you have mmsproxy.tre.se please replace it with 172.16.53.11.

edit flag offensive delete publish link more

Comments

Nice try, but it didn't work. I'm unable to even change that setting in GUI. After "accepting" new setting, the proxy address automagicly goes back to mmsproxy.tre.se. Maybe if I try changing address, using terminal? Could you give instructions, please?

eson ( 2014-10-03 15:01:09 +0200 )edit

Ah, sorry that's another bug. MMS context changes don't get applied when the context is active. You need to cancel all the pending MMS transfers and wait 20 sec or so (or reboot the phone, that will surely cancel everything), then the MMS access point changes should actually get applied.

slava ( 2014-10-03 16:11:47 +0200 )edit
1

Ok, new info! I was able to change address when I deleted port number and left that blanc. Sending mms didn't work either way.

Edit: After some more testing, it seems to work with IP: 80.251.201.130 and port:8799 Thanks for pointing me in the right direction.

eson ( 2014-10-03 16:16:03 +0200 )edit
1

answered 2014-09-23 19:20:33 +0200

juiceme gravatar image

updated 2014-09-23 19:20:59 +0200

This must be operator dependent at least to some degree.

I just tested this (with Elisa/Finland SIMcard) and MMS'es come thru nicely while I am connected to a WLAN access point (and actually am looking at the output of "journalctl -f" at the same time via SSH, as proof to that I really am connected at the same time.

Both sending and receiving go immediately without any hitches :)

edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2014-09-21 12:31:45 +0200

Seen: 611 times

Last updated: Oct 03 '14