Ask / Submit
6

BUG: no internet when the phone is on 4G and a call is received/made

asked 2014-09-22 14:23:00 +0300

c.la gravatar image

updated 2014-10-05 17:11:56 +0300

[EDIT 2014-10-05: found the issue behind the bug, reporting the use case]

I just found out that mobile internet connection drops when Jolla receives a call. If anyone calls, the moment that Jolla plays the ringtone the internet connection drops.

My network settings are "prefer 4G". Every time I receive a call Jolla goes to 2G, there is already a bug filed for this on TJC: https://together.jolla.com/question/46718/phone-switch-from-4g-to-2g-when-calling/

I tried to set the network to "prefer 3G" and.. voila! The call is handled on 3G and I can browse the web just fine.

Jolla seems to have some trouble to estabilish a network connection on 2G because every morning when I turn the phone on it connects to 2G first and i get a bunch of "connection error" messages before the phone goes to 3G (and then to 4G), estabilishing a network connection

This same issue has been reported by user pata in this comment

Con Jolla please look into this?

edit retag flag offensive close delete

Comments

I will try to do it within one week (I have to find the nano to micro SIM adapter), although I remember doing it fine with the same carrier

c.la ( 2014-09-22 19:47:03 +0300 )edit

c.la: must be your operator, my data works while on a call that I made or received, albeit it downgraded from 4g to 3g. I suggest we close this question.

gabriel ( 2014-09-23 18:54:27 +0300 )edit
2

Worked for me too, forgot to mention. I second closing this. @gabriel FYI currently deployed commercial LTE doesn't support voice so that's why devices switch to 2G/3G during for voice calls.

tkenakka ( 2014-09-24 09:26:27 +0300 )edit

I probably missed a crucial point: I have noticed this behavior when the wlan hotspot (wifi tethering) is enabled on the phone. never tried with that off as it's on almost all the time Jolla is turned on.

Does the wifi hotspot change the behavior?

c.la ( 2014-09-26 14:34:57 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-09-22 15:05:33 +0300

tkenakka gravatar image

@c.la Could you try on the same location and same card some other phone, like your trusty E52? Some network operators do not allow simultaneous data during a voice call. Up to them if the limitation is based on location/time/subscription type.

edit flag offensive delete publish link more

Comments

I nailed the issue down, is related to the 4G -> 2G switch when receiving a phone call, and the slew of "connection error" I get when on 2G.

I'm editing the question to reflect this

c.la ( 2014-10-05 17:00:57 +0300 )edit

@c.la Thanks for the info. Would it be possible for you to do the same test using a some different commercial device (please mention which), but using the same SIM card and location? Without access to specific details I wouldn't rule out the option that this would be an issue on the service provider side. Previously I have run into issues where an operator hasn't implemented fully the 4G --> 2G handover.

tkenakka ( 2014-10-06 09:43:43 +0300 )edit
1

@tkenakka I don't have another 4G device to test it, I'll ask to a friend who has a 4G Nexus on the same carrier and on the same plan I have and let you know

c.la ( 2014-10-06 12:31:11 +0300 )edit

@tkenakka I tested with a Nexus 5 and the behavior is the same, even with a different sim card (prepaid as mine is). When on 4G the calls go on 2G, when on 3g calls stay on 3G.

Is there a way to force jolla to switch to 3G in such scenario? at least when tethering is happening.

thank you

c.la ( 2014-11-19 14:01:00 +0300 )edit

@c.la Unfortunately that's not possible on any device, and adjusting it wouldn't be a good idea. Current commercial 4G (LTE) does not support voice services. Hence:

  • Whenever there's an _outgoing_ operation not supported by 4G, device switches to 2G or 3G network to perform the operation. This is typically quite reliable.

  • Whenever there's an _incoming_ call, network instructs the device to switch to 2G or 3G and pages the device for incoming call when it registers there. There are various different details in the process, network may assign device to camp to specific cell or frequency and so on. Generally this is not always 100% reliable, either due to user mobility, network configurations or other reasons.

What you are experiencing may be because operator network explicitly assigns device to switch to 2G from 4G, or it may be that devices do not detect 3G fast enough, or other similar reason.

As a workaround you may set your device to "3G preferred" mode where it does not need to do a handover - unless 3G gets too weak.

tkenakka ( 2014-11-19 14:55:29 +0300 )edit
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2014-09-22 14:23:00 +0300

Seen: 1,546 times

Last updated: Oct 05 '14