Not picking up 3g network

asked 2014-10-01 12:12:52 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-10-01 12:12:52 +0200

prithiv gravatar image


My jolla picks up only 2g network it is not showing or using 3g network. i used the same sim in my other phone and 3g is working there. but with jolla, i am facing this issue. any fix or workaround

edit retag flag offensive close delete



Country and carrier?

simo ( 2014-10-01 12:16:00 +0200 )edit

india, vodafone

prithiv ( 2014-10-01 12:33:13 +0200 )edit

Your network (India, Vodafone) is supported and Jolla should pick it up automatic.

  1. Check phone Settings > System > Mobile Network > Network mode > Prefer 3G
  2. Check that you're in covarage area (some isp's offer a map on their sites)
  3. For further help, if you're close to the edge of an coverage area, contact your ISP for expanding, if you're clearly in a good covarage area, contact the seller to check your phone
simo ( 2014-10-01 14:01:30 +0200 )edit


Have a similar issue, with my carrier 3 in Hong Kong. We try the SIM on a Samsung, and you can switch from the LTE which is disable, the 3G and the 2G. On the jolla, it shows as the Mobile Data the LTE network whether I choose as the Network node Prefer 3G or 2G only.

After half an hour of trying the technicians at the 3 shop told me that the Jolla is using the 3G only for voice and only accept the LTE for data ....

Is that really the case ?

XinGeWen ( 2014-12-10 16:16:05 +0200 )edit

I have the same problem. I've been trying to check all posibilities including the APN settings, i found that the options for mobile networks are missing the possibility to define some advance informaction.

Name: OK, but it cant be changed, the modifications are not saved.


MCC: Not available

MNC: Not available

Am i the only one that's having this problem??

Barando ( 2014-12-11 01:07:22 +0200 )edit