Ask / Submit
4

reinstall default ambiences [answered]

asked 2014-10-08 11:57:12 +0300

I wrongly deleted some ambiences from Gallery instead of removing them from Ambience pane (left/right swipe). I also tried reinstalling this two packages

devel-su pkcon install jolla-gallery-ambience jolla-preload-ambiences

but I could not see original ambiences anymore. Is there a way to restore them (I do not want to download the images in my gallery)? I looked through TJO but didn't find any mention.

Thanks

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by magullo
close date 2015-01-06 14:55:30.342693

Comments

@magulio - Did you get this problem sorted out??

Regards,

Edz ( 2014-11-19 03:41:33 +0300 )edit

@Markkyboy no, I still have two or three missing "default" ambiances, I remember the sailing ship in particular. No way to make it reappear.

magullo ( 2014-11-19 11:23:54 +0300 )edit

I guess it is some problem with a configuration. I accidentally deleted a default ambience (via Gallery) too, but it still was in the /usr/share/ambience/ folder. Unfortunatly I could not make it reappear either, yet.

Ant ( 2014-11-20 21:20:04 +0300 )edit

Sorry for late reply @magullo & co;

Here's what I did to get all the preloaded ambiences back (which I purposely deleted some time ago).

I did this just now and it works for me on Uitukka 1.1.0.39;

In Terminal, (devel-su)

pkcon install jolla-preload-ambiences enter

then;

pkcon update enter - this one may take a while, it may not, let it do its thing, follow any prompts.

After you have closed Terminal, shut the phone OFF, not reboot, but OFF (I tried rebooting, but it didn't work, so to power off is best) - Power back on, go to Ambience in Gallery and the preloaded ambiences should be present, they are for me.

Regards,

Edz ( 2014-11-30 00:04:03 +0300 )edit

Thanks @Markkyboy, I have tried what you suggest but I am still missing Storm ambience. I will try digging in config files, since ambience is installed correctly in /usr/share/ambience.

magullo ( 2014-12-19 07:42:07 +0300 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2015-01-05 00:02:15 +0300

fanfu gravatar image

updated 2015-01-06 11:32:48 +0300

I also unintentionally deleted one ambience and wanted to restore it. Trying to reinstall the packages didn't work.

However, removing and installing again the packages worked! In terminal (devel-su):

pkcon remove jolla-gallery-ambience jolla-preload-ambiences

pkcon install jolla-gallery-ambience jolla-preload-ambiences

At this point, the gallery ambiences is empy. Also had to shutdown the phone.

shutdown -h now

After restarting the phone, the ambiences were back! Hope that it will work for you.

edit flag offensive delete publish link more

Comments

I think you could also try restarting just lipstick (the UI) instead of restarting the phone. (systemctl --user restart lipstick.service)

nthn ( 2015-01-06 14:22:41 +0300 )edit

@nthn restarting lipstick and reindexing gallery didn't work, only reboot made them appear.

magullo ( 2015-01-06 14:55:14 +0300 )edit

I see, thanks.

nthn ( 2015-01-06 14:58:37 +0300 )edit

Your don't need to reinstall ambience packages. To restore an ambience who is still present in /usr/share/ambience but removed from the Gallery app, you just have to delete your ambience config. Before removing files, you can keep a backup if you want and then, do as root with terminal in nemo home directory: rm .local/share/system/privileged/Ambienced/ambienced.sqlite*Someone shared this link here https://together.jolla.com/question/36946/how-to-list-custom-ambiences/#comment-36947, then reboot to refresh Gallery ambiences.

baptx ( 2015-02-01 15:38:10 +0300 )edit
0

answered 2014-10-09 15:22:04 +0300

Schturman gravatar image

Did you try reboot after reinstallation ? or run tjid command as root: systemctl-user restart ambienced.service

and you be able to see them in gallery.

edit flag offensive delete publish link more

Comments

I have but didn't work. It looks like some user prefernce overrides system ambiences. Have to dig through dconf.

magullo ( 2014-10-09 19:43:20 +0300 )edit

Question tools

Follow
7 followers

Stats

Asked: 2014-10-08 11:57:12 +0300

Seen: 734 times

Last updated: Jan 06 '15