Ask / Submit
12

Developer-mode should be possible without network connection

asked 2014-10-08 16:16:14 +0200

dsilveira gravatar image

updated 2014-10-08 19:17:59 +0200

There is no apparent reason why should we not be able to enable developer-mode without first enabling network connection. (Please note that I said enable, NOT install)

So I beg Jolla, please, change this behaviour, because I want to ssh to my jolla through USB, and don't want to keep my wifi on, since the longer it stays on the less stable it becomes, eventually requiring a reboot to work at all known problem.

edit retag flag offensive close delete

Comments

might be related to this, although that seems a more specific problem

dsilveira ( 2014-10-08 16:17:46 +0200 )edit

3 Answers

Sort by » oldest newest most voted
4

answered 2014-10-08 21:21:46 +0200

simo gravatar image

Developer mode needs internet connection and an active Jolla account, only in the first time it's enabled due to dependencies on the Jolla Store.

After it's once enabled, connection can be shut down and Jolla account can be removed - terminal on the phone, and ssh connection via USB, should be still available.

However, I might agree that this could be enabled even without the first connection - that would be even more Linux likee, and definitely unlike :)

edit flag offensive delete publish link more

Comments

2

It seems what I am describing is a bit alien to most people. I don't want developer mode permanently enabled, I want to keep it off, and only get it back on when I need to. I shouldn't have to re-install anything every time I enable developer mode, it should have at the very least a local cache of the required packages, and then take care of it, without requiring internet connection!

dsilveira ( 2014-10-13 04:46:37 +0200 )edit
1

Aaaaagghhh! I've turned off Dev mode trying to fix a network issue on my phone, as I now can't download the packages again to turn on Dev mode I've lost SSH and the Shell on my phone and can't work on it. Another upvote to have these packages saved to the phone when Dev mode has already been uploaded then turned off again.

timearp ( 2015-07-03 11:35:22 +0200 )edit
3

answered 2014-10-08 16:49:19 +0200

Philippe De Swert gravatar image

updated 2014-10-08 16:50:57 +0200

If you have installed developer mode, there should be an extra usb mode called developer mode. Which is totally independant from the wifi. So you do not need to turn wifi on at all.

The default usb network address is 192.168.2.15. Check your local network settings to be sure that somehow you do not have a network address conflict (for example if your router also gives out ip's in the 192.168.2.x range then you need to change the usb network address in the developer mode ui.)

edit flag offensive delete publish link more

Comments

At least on my Jolla, upon USB connection the developer-mode option is only presented if the developer-mode was already activated in settings (And that is the problem, since I can only activate it if I have a network connection)

dsilveira ( 2014-10-08 16:52:49 +0200 )edit

So basically you mean installing developer mode? You only need to do that once. It is kind of hard to do without network as it needs to download a few packages.

Philippe De Swert ( 2014-10-08 16:54:33 +0200 )edit

You think you're so smart, don't you. This happens everytime not just the first time I activate developer mode.

Now if that means that everytime you activate developer-mode it needs to install it, then Sailfish is getting worse every update.

dsilveira ( 2014-10-08 18:05:01 +0200 )edit

there is no address range conflict

dsilveira ( 2014-10-08 18:06:47 +0200 )edit
3

@dsilveira : There is no need to become abusive. Especially when people try to help you.

And no you only need to activate developer mode once in the settings and it stays active. That is how it is designed. So unless you deactivate it there is no reason why the USB option would disappear. If it does not work like that there is some weird problem. So you will have to explain exactly what is going wrong.

Philippe De Swert ( 2014-10-08 18:15:24 +0200 )edit
1

answered 2014-10-08 16:46:38 +0200

Luca gravatar image

hi, I can connect by ssh to my phone using usb without the need of wifi connection.

edit flag offensive delete publish link more

Comments

please expand a little bit about what you're doing:

Did you have developer-mode activated?

Did you have network connection, when you activated it?

dsilveira ( 2014-10-08 16:56:00 +0200 )edit

I keep developer mode activated and internet connections off ad always. I connect the usb cable to the pc and then execute ssh to connect: ssh nemo@192.168.2.15

Luca ( 2014-10-08 17:24:00 +0200 )edit

I'm talking about activating developer-mode without a network-connection in that moment,

please try to reproduce what I'm talking about, before answering

dsilveira ( 2014-10-08 18:08:50 +0200 )edit

you can't activate dev. mode without internet connection because it should install two packages: jolla-developer-mode and jolla-developer-mode-profile When you disable dev. mode jolla will uninstall both packages...

P.S. forgot about fingerterm package too.. Maybe also some other... Maybe you can just download this packages and install/uninstall manually, when you need/don't need them without internet connection.

Schturman ( 2014-10-08 20:24:05 +0200 )edit
1

Why would I uninstall Terminal after every use and reinstall it again when I want to use it? I don't get it!? So why not just simply let Developer mode activated and all is set?

J4ZZ ( 2014-10-09 00:00:32 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-10-08 16:16:14 +0200

Seen: 593 times

Last updated: Oct 08 '14