Ask / Submit
4

bug: no mobile data after disabling wlan [released]

asked 2014-10-09 17:50:20 +0300

late88 gravatar image

updated 2014-11-28 22:25:25 +0300

Steps to reproduce/leading to the problem:

  1. Make sure you have 4G AND WLAN on.
  2. While on wlan, start downloading any file (prefer big one, so you have time).
  3. Disable wlan in the middle of downloading.
  4. Phone is now unable to access internet with mobile connection.

Afterwards there are lots of "connection problem" pop-ups and Jolla can't access the internet. However, this never happens when you are on 2G or 3G (step 1).

To recover, you must manually switch to "2G only" or "prefer 3G" and after that the phone can access internet again with mobile connection.

Just FYI, my operator is Benemen and it uses Sonera network.

Edit: Can't reproduce after Uitukka update (1.1.0.39)

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by late88
close date 2014-11-28 22:25:46.640610

1 Answer

Sort by » oldest newest most voted
0

answered 2014-10-10 09:51:11 +0300

tigeli gravatar image

I tried to reproduce this on Sonera's network with Sonera's sim. The mobile data gets connected immediately after disconnectin wlan while on 4G/LTE.

However, question.. do you have roaming triangle on your Jolla when it's on 4G/LTE? See link

If yes, then the upcoming update will resolve issues with mobile data not connecting while roaming (virtual operators are roaming.. :))

edit flag offensive delete publish link more

Comments

I'm not sure if it matters but I was downloading with android app and this happens every time with no exceptions. And no, I don't have roaming triangle. Edit: my phone is in that state right now. Is there anything I can do to debug?

late88 ( 2014-10-10 11:50:15 +0300 )edit

Question tools

Follow
1 follower

Stats

Asked: 2014-10-09 17:50:20 +0300

Seen: 224 times

Last updated: Nov 28 '14