Ask / Submit
11

Caldav sync to owncloud with non-latin characters results in question marks being displayed [released]

asked 2014-10-23 15:46:10 +0300

karbonized gravatar image

updated 2014-12-18 18:18:10 +0300

chemist gravatar image

I have an owncloud server and I have setup a CalDAV account to sync calendars between Jolla and owncloud server. When creating events in calendar app using Greek characters in any field (e.g. summary, location) using a calendar hosted on owncloud, upon sync the events appear on owncloud web interface but instead of Greek characters I only see question marks.

Event as created on Jolla: Original event on Jolla

Event displayed on owncloud web interface after sync: Event as displayed on owncloud after sync

From apache logs I see the Jolla PUT-ting the ICS file on CalDAV server; when I manually get the ICS file, I see it actually contains question marks instead of the characters I input.

The issue is present since Sailfish version 1.0.8 and I can confirm it exists also in 1.0.9 and 1.1.0.38 (opt-in upgrade). If further input is required to investigate, please ask me. Perhaps this is related to this issue about caldav and umlauts? (that question does not mention viewing question marks instead of the actual character, which is why I started a new one).

Thanks!

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by VDVsx
close date 2014-12-18 17:17:07.187814

Comments

I have the same problem with japanese characters

razcampagne ( 2014-10-23 16:19:43 +0300 )edit

I've posted this as an issue on the GitHub page: https://github.com/nemomobile/buteo-sync-plugin-caldav/issues/38

nthn ( 2014-10-23 21:26:03 +0300 )edit

Same issue syncing with kolab. Although, if you create event on server, jolla will show it correctly. Non-ascii characters in ics are supposed to be html-encoded?

Fenuks ( 2014-10-24 06:41:28 +0300 )edit

Thanks for the report, bug report created internally, progress will be noted in the github issue above and here once released.

VDVsx ( 2014-10-28 09:21:29 +0300 )edit

last sync just filled my Greek calendar with question marks and there is no option to sync one-way; namely from server to jolla.

gmitsos ( 2014-10-29 17:05:05 +0300 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2014-12-18 17:16:49 +0300

VDVsx gravatar image

Fixed in Sailfish 1.1.1.26, Vaarainjärvi, account re-creation might be needed in some cases, if you still have issues please comment here.

edit flag offensive delete publish link more
0

answered 2014-11-05 13:08:51 +0300

nthn gravatar image

The issue has been fixed: https://github.com/nemomobile/buteo-sync-plugin-caldav/issues/38#issuecomment-61611205

edit flag offensive delete publish link more

Comments

Thanks a lot for this. As a matter of policy, should I mark this as an answer to my question or should I wait for it to be released on a subsequent update and mark it as answered then?

karbonized ( 2014-11-05 13:52:53 +0300 )edit
1

IMO is better to close it once the fix is available for the users, this way other users will not make similar report.

VDVsx ( 2014-11-05 14:24:49 +0300 )edit

Presumably, the patch will be integrated in a forthcoming release of the OS? Is there any way to patch the current one instead of waiting the official release?

gmitsos ( 2014-11-07 09:51:36 +0300 )edit

Question tools

Follow
6 followers

Stats

Asked: 2014-10-23 15:46:10 +0300

Seen: 5,873 times

Last updated: Dec 18 '14