Ask / Submit
8

caldav, carddav configuration and debugging (Uitukka)

asked 2014-11-11 21:45:27 +0300

mdosch gravatar image

updated 2014-11-11 21:50:43 +0300

I did the upgrade to Uitukka because I wanted to test caldav and carddav because syncevolution wasn't very reliable.

I configured my carddav and caldav account for my owncloud and everything seemed to work well. No error message usually means no problem. But if i try to synchronize nothing happens.

I did some changes at my Jolla and some at my ownclout to check if it works. But neither the changes from Jolla showed up in owncloud nor the changes from owncloud showed up at my Jolla allthough there was no error message.f

Is there some place where activities from carddav/caldav-accounts get logged at the Jolla?

My configurations:

ag-tool list-settings 22
default_credentials_username = mdosch
Jolla/segregated_credentials/Jolla = 24
CredentialsId = 24
enabled = true
name = mdosch contacts
        onlinesync-caldav
auth/method = password
server_address = https://mdosch.de
auth/mechanism = password
sync_profile_templates = ["caldav-sync"]
CredentialsId = 24
caldav-sync/profile_id = caldav-sync-22
enabled = false
        onlinesync-carddav
auth/method = password
server_address = https://mdosch.de
auth/mechanism = password
sync_profile_templates = carddav.Contacts
CredentialsId = 24
carddav.Contacts/profile_id = carddav.Contacts-22
enabled = true

ag-tool list-settings 23
default_credentials_username = mdosch
Jolla/segregated_credentials/Jolla = 25
CredentialsId = 25
enabled = true
name = mdosch cal
        onlinesync-caldav
CredentialsId = 25
calendar_colors = #ffffff
server_address = https://mdosch.de
enabled_calendars = /owncloud/remote.php/caldav/calendars/mdosch/defaultcalendar/
caldav-sync/profile_id = caldav-sync-23
auth/method = password
calendars = /owncloud/remote.php/caldav/calendars/mdosch/defaultcalendar/
calendar_display_names = Default calendar
enabled = true
auth/mechanism = password
sync_profile_templates = caldav-sync
        onlinesync-carddav
auth/method = password
server_address = https://mdosch.de
auth/mechanism = password
CredentialsId = 25
carddav.Contacts/profile_id = carddav.Contacts-23
enabled = false
sync_profile_templates = ["carddav.Contacts"]

Edit: Grml, Markdown for codeblocks doesn't work...

edit retag flag offensive close delete

1 Answer

Sort by » oldest newest most voted
2

answered 2014-11-11 21:57:08 +0300

Sailor gravatar image

You can get many tips here: https://together.jolla.com/question/60493/new-carddavcaldav-support-got-to-it-working-with-owncloud/

edit flag offensive delete publish link more

Comments

Thanks, so at least I got some informations but I don't really understand it. I added the account several times to be sure that there was no mistake in the password but according to journal I get http 401 (unauthorized): http://files.mdosch.de/2014-11/journalctl.txt

mdosch ( 2014-11-11 22:23:24 +0300 )edit

Well, as you can see in the post you need to adapt some things on your webserver to use caldav of owncloud on Jolla.

Sailor ( 2014-11-12 11:27:13 +0300 )edit
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2014-11-11 21:45:27 +0300

Seen: 945 times

Last updated: Nov 11 '14