We have moved to a new Sailfish OS Forum. Please start new discussions there.
6

ringtone picker can't find ogg files

asked 2014-11-17 02:50:26 +0200

tad gravatar image

updated 2019-07-21 22:46:39 +0200

nthn gravatar image

as the title says, I cannot pick ogg files as ringtone as the ringtone picker cannot find them when you choose "find from music files". The media app on the other hand recognizes ogg files without problems and you can find them searching within all titles.

Workaround: rename the ogg file to an mp3-file and suddenly the ringtone picker finds the file when searching for the name (and playback works flawlessly)

This bug still remains in Sailfish 3.1.0.

edit retag flag offensive close delete

Comments

1

I have exactly the same issue. But after renaming the file I still can't find it in ringtone picker.

Marzanna ( 2015-04-07 16:21:53 +0200 )edit

I have the same problem. It seems to be simply some misconfiguration for the file picker.

shmerl ( 2015-07-27 17:06:08 +0200 )edit
1

@Jk try to add tags (song name and artist) to your ringtone.

Marzanna ( 2017-12-20 20:03:59 +0200 )edit

Oops I accidentally removed my own comment. Well I tagged my ringtones and it worked. Many thanks for you Marzanna!

Jk ( 2017-12-21 00:11:30 +0200 )edit

works fine for me on Jolla1. I renamed an ogg file from jolla-ringtones/stereo folder to demo.ogg, copied it to /home/nemo/Music. I also added the demo.ogg to /usr/share/jolla-ringtones/stereo, including the entry to the stereo.index file.

I can now choose 'demo.ogg' via 'Select from music files' in Settings/Sounds and feedback and the file also appears in the immediate list of ringtones.

After adding your OGG file to jolla-ringtones, you must reboot your device or the new file will not appear as a pre-selectable ringtone.

Spam Hunter ( 2019-07-21 23:43:23 +0200 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2016-08-26 19:59:19 +0200

tom.i gravatar image

I found a solution for this on my Intex Aqua Fish. You probably just copy ogg files somewhere to:

/usr/share/sounds/intex-ringtones/stereo

I found that there is file stereo.index in upper directory:

[root@Sailfish intex-ringtones]# ls -l
total 8
drwxr-xr-x 2 root root 4096 Aug 26 18:35 stereo
-rw-r--r-- 1 root root  588 Jan  1  2000 stereo.index

You have to add that files to this stereo.index file for adding e.g. "jolla-ringtone.ogg" here:

{
    "translationCatalog" : "intex-ringtones",
    "files" : [
        { "displayName" : "intex-ringtones-dolce", "fileName" : "Dolce.ogg" },
        { "displayName" : "intex-ringtones-flottant_alert", "fileName" : "Flottant_alert.ogg" },
        { "displayName" : "intex-ringtones-presto_alert", "fileName" : "Presto_alert.ogg" },
       .....
        { "displayName" : "intex-ringtones-jolla-ringtone", "fileName" : "jolla-ringtone.ogg" }
    ]
}

Then, you can see newly added OGG files into ringtone picker. Hope it helps someone after such a long time.

edit flag offensive delete publish link more

Comments

I did all that but still the new ringtones does not appear!

petros ( 2016-10-04 19:24:58 +0200 )edit

I found that rebooting my device was necessary to make the newly added ringtone appear in the list of ringtones in Settings/Sounds and feedback.

Spam Hunter ( 2019-07-21 23:45:03 +0200 )edit

Tested this on 3.1.0.11 and XA2 which has two ogg files in /home/nemo/Music:
the ringtone picker could find the two songs.

jovirkku ( 2019-07-23 16:05:46 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-11-17 02:50:26 +0200

Seen: 472 times

Last updated: Jul 21 '19