We have moved to a new Sailfish OS Forum. Please start new discussions there.

how to change Jolla hostname? [answered]

asked 2013-12-30 02:43:19 +0300

qwazix gravatar image

I tried to change /etc/hostname and also ran hostname qwazixSbJ but the change does not persist across reboots. It takes, weirdly the hostname of my router. I also tried to give a static lease from the router with my desired hostname but it doesn't make a difference.

However I can ping the device via LAN with the router assigned hostname, but I'd like the phone to know it too.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by JSEHV
close date 2016-02-01 14:43:06.755637


It works for me

[nemo@jolla ~]$ hostname
[nemo@jolla ~]$ cat /etc/hostname 
[nemo@jolla ~]$ ls -l /etc/hostname 
-rw-r--r-- 1 root root 6 2013-12-25 18:06 /etc/hostname
[nemo@jolla ~]$ uptime
 02:00:57 up 1 day, 11:03,  2 users,  load average: 1.26, 1.07, 1.65
Tanghus ( 2013-12-30 03:02:48 +0300 )edit

yep /etc/hostname contents persist, but the actual hostname command returns the default one, not the one specified in /etc/hostname

qwazix ( 2013-12-30 12:44:52 +0300 )edit

i found that bluetooth host allow nickname

redge73 ( 2013-12-31 01:20:45 +0300 )edit

What are you talking about? The file /etc/hostname does not exists. Maybe the file you're referencing to is /etc/hosts?

dharman ( 2014-01-14 13:26:49 +0300 )edit

I've set hostname by creating /etc/hostname. After reboot it should be set.

[nemo@myjolla ~]$ hostname 
[nemo@myjolla ~]$ cat /etc/hostname 
EanderAlx ( 2014-01-14 19:30:56 +0300 )edit

3 Answers

Sort by » oldest newest most voted

answered 2014-01-09 17:42:20 +0300

Rolfa gravatar image

Get root with devel-su, then edit /etc/hostname. After reboot, your jPhone will have the new name.

edit flag offensive delete publish link more


works for me

cy8aer ( 2014-01-10 15:38:15 +0300 )edit

It's not called jPhone.

raimue ( 2014-01-13 11:18:41 +0300 )edit

Did you understand my joke? There is the iPhone (which I dislike) and there is the "jPhone" (which I like). Maybe one day the latter becomes more widespread and therefore more popular?

Rolfa ( 2014-01-24 14:52:21 +0300 )edit

Sailfish uses systemd, so I think the "official" way should be with a hostnamectl set-hostname yourhostname

Giskard ( 2016-11-15 21:10:12 +0300 )edit

... and I thought jPhone was my personal, genuine idea. Sigh.

Moo-Crumpus ( 2019-03-12 11:17:35 +0300 )edit

answered 2013-12-30 03:32:45 +0300

redge73 gravatar image

as well netbios name

edit flag offensive delete publish link more

answered 2013-12-30 15:05:02 +0300

penpen gravatar image

I haven't tested this myself but you could try to prevent connman (Connection Manager) to change the hostname. This should be possible by adding AllowHostnameUpdates=false to /etc/connman/main.conf configuration file.

edit flag offensive delete publish link more

Question tools



Asked: 2013-12-30 02:43:19 +0300

Seen: 928 times

Last updated: Jan 09 '14