Ask / Submit
6

sms from certain sender not receiving

asked 2014-11-19 23:53:51 +0300

heurtebise gravatar image

I am experiencing the following problem: sms from a certain sender are reproducible not showing up My city offers a subscription service for alerts on several topics. Since switching to Jolla I'm not receiving the messages anymore. Now I asked the sender to verify my account, I've even cleared and set up a new account and they claim the messages to be sent. My network operators technical support can confirm the messages to be delivered to my device, they get the successful submission acknowledge status reported back. Today I should have received four messages, not one shows up. How can I help to resolve this issue? I am currently on 1.0.8.21, but this issue occured on all versions since february.

edit retag flag offensive close delete

Comments

@heurtebise Would it be possible to ask from your provider what type of SMS is this one (e.g SMS class 0) ?

VDVsx ( 2014-11-20 10:52:58 +0300 )edit

FYI SMS Class 0 are sometimes known also as "Flash messages", which are displayed automatically on device screen without user needing to open them.

tkenakka ( 2014-11-20 11:04:43 +0300 )edit

These messages are "plain text with HTML for a link/URI" according to the sender. They are not of "Type 0", but the sender is not a regular phone number, not even a short/service number but a string with no visible number.

heurtebise ( 2014-11-20 15:38:20 +0300 )edit

@heurtebise - Could you let us know your mobile provider and the name of the service sending those SMSs ? Thx

VDVsx ( 2014-11-21 14:45:03 +0300 )edit

The provider is "Swisscom" and the sender string is "StadtZürich".

heurtebise ( 2014-11-23 19:03:43 +0300 )edit

3 Answers

Sort by » oldest newest most voted
4

answered 2015-02-04 01:23:39 +0300

heurtebise gravatar image

This bug has been confirmed by Jolla customer support and is now fixed in upstream, will be delivered in a next update.

edit flag offensive delete publish link more
0

answered 2015-01-30 13:52:31 +0300

PasiK gravatar image

Might be related to sender string and non-ACSII characters.

Tested to my own phone with different sender stings and if Scandic letters (åöä) is used, message is newer received.

edit flag offensive delete publish link more

Comments

I have absolutely no problems with sending or receiving messages with scandinavian letters though English setup.

lakutalo ( 2015-01-30 21:14:53 +0300 )edit

@lakutalo Hi, PasiK meant sender address and not the SMS message content.

I plain english: looks like there are problems receiving SMS if sender (like some service SMS Gateway) uses a long enough alphanumeric _originator_address_ with unicode characters.

tkenakka ( 2015-02-02 11:41:01 +0300 )edit

OK, you mean a special character in the sender address part of the sms. I now recall that I never got a message when I ordered mms settings as sms from my provider. They were just there when I looked for them in mms settings later. Seems to be related.

lakutalo ( 2015-02-02 12:15:11 +0300 )edit
0

answered 2015-01-30 22:45:46 +0300

PasiK gravatar image

It's not the message which causes this. It's the sender, if there is something else than numbers or US-ASCII, SMS is lost...

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2014-11-19 23:53:51 +0300

Seen: 251 times

Last updated: Feb 04 '15