Ask / Submit
3

need help: some android apps (aptoide) don't work. why? [released]

asked 2014-11-26 00:35:12 +0200

cemoi71 gravatar image

updated 2015-01-13 09:50:17 +0200

eric gravatar image

Hello sailors,

i want to use some android apps through aptoide. but most of them don't work. I have installed first the aptoide app from jolla store. Then run aptoide, and after i wanted to install sygic (is marked as sure). After installation, i try to open it, and i become a message "the application has stopped" and can do nothing else as to stop aptoide. it is the same with amazon-music, landrule.

Could someone help me and guide to search where the problem comes? The problem is that there are already themes about this. but i found no solution they of my problem (or was unclear for me).

little list of app which work:
- bubble blast 2
- BeloteAndr
- skype
- airdroid
- gps test plus
- osmand+

little list of app which don't work:
- sygic (crash immediately)
- navfree (all needed map are downloaded, display none and cannot catch position)
- map factor (have a lots of problem to download maps)
- landrule (crash immediately)
- amazon music (crash immediately)

i've tested a lots of gps apps and now one works more or less properly. Osmand+ with aptoide (through irishandroid website and not appstore).

Thank you all in advance for your help. I'll test soon here

best regards

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by cemoi71
close date 2015-09-09 12:37:35.470700

Comments

Witch version of the SailfishOS you use?

Apptoide is loosing stores very often in 1.1.0.39, did make reboot, but now suddently it's not reboot anymore... Some hidden upgrades from Jolla? You can try 1mobile Android store too, maybe those apps will work or try different version of the apps. If you want some good free navigation app, try Navfree

Makeclick ( 2014-11-28 20:36:31 +0200 )edit

Hi Makeclick, i have sailfish 1.0.8.21 aptoide 5.2.0.2. how did you get the 1.1.0.39? i try to new update, and nothing new comes...

cemoi71 ( 2014-11-28 21:52:02 +0200 )edit

hmm i've seen that the 1.1.0.39 is the hotfix of the 1.1.0.38 opt-in update, which is not done for the whole public. that why it not so obvious to update to this one..

cemoi71 ( 2014-11-28 23:36:55 +0200 )edit

Yep. that is why, but i think you should wait stable update 10.... whenever it coming.. 1.1.0.xx is unstable.

you can also try Nokian Here android versio. it should work in Jolla too.

Makeclick ( 2014-11-29 03:21:49 +0200 )edit

I think some apps could work, but it is prevented because the device is unknown, so one should be allowed to fake it.

pulsar ( 2014-11-29 21:02:14 +0200 )edit

5 Answers

Sort by » oldest newest most voted
2

answered 2014-11-28 17:30:48 +0200

gilou3000 gravatar image

Hello

AFAIK the most probable reason is that the non working apps uses google service. It may be possible to install google services on jolla but it is not easy nor legal. Maybe someone can precise this point...

Gilles

edit flag offensive delete publish link more

Comments

why not? i thought that android is on a kind of opensource implemented... make not really sense for me (maybe it's wrong what i think ...).

cemoi71 ( 2014-11-28 17:53:48 +0200 )edit
1

@cmeoi71: To access Google play and use it API's there is a whole set rules to follow, otherwise Google will sue you. One of them is to be on an official Google implemented android with all the Google "spyware". So it is something that Jolla cannot legally ship, and technically is not exactly right for you to do either.

Philippe De Swert ( 2014-12-15 17:04:47 +0200 )edit

@Philippe De Swert i've seen some infos aboiut it like that, but i've loose the focus on this. if you a a source (reference) with details in clear way point for point which describe what you've said. Could you please give it to me? will be nice. or better to say. give me please all that you have. :-)

cemoi71 ( 2014-12-15 17:22:42 +0200 )edit

@Philippe De Swert could you explain why it doesn't work with gps navigation and with some other app it works indeed. what is the differences, all are google one... what i currently need is a good gps navigation app which works with offline maps. Some people advise me with some apps, because it works by them. but on my phone none works. And i find no jolla native app... :-(

cemoi71 ( 2014-12-15 18:54:50 +0200 )edit

@cemoi71: some google play requirements: http://www.androidauthority.com/google-oem-licensing-345806/
http://www.androidauthority.com/google-play-mada-requirements-530840/

And basically apps that require those API's won't work because they are not there. Like a car will not drive without wheels.

Philippe De Swert ( 2014-12-18 15:14:17 +0200 )edit
0

answered 2014-11-28 17:02:37 +0200

cemoi71 gravatar image

Shortly i installed the airdroid app from aptoide, and it works. That the 1st one that works on my device. That why i have change a little bit my 1st request. Because it is not obvious why it didn't work, if the "app" is well know as sure to work.

Could someone help me to find out why some app don't work? please.

edit flag offensive delete publish link more
0

answered 2015-01-01 04:35:39 +0200

foss4ever gravatar image

updated 2015-01-01 04:39:01 +0200

Android apps that require Google Play are not supported in Jolla (the most probable reason for specific droid apps not working).

edit flag offensive delete publish link more

Comments

@jjaone i can feel what you mean but could you explain your mind a little bit deeper, that i understand more exactly what is needed? will be nice. thanks in advance.

cemoi71 ( 2015-01-09 10:47:43 +0200 )edit
0

answered 2015-01-01 13:33:48 +0200

idro gravatar image

Try to use Yandex store, download it from aptoide and use it to installa apps. I use yandex and Amazon app shop and all apps are qorking, included navfree, wave(gps navi) try!

edit flag offensive delete publish link more
0

answered 2015-09-09 12:37:20 +0200

cemoi71 gravatar image

all my android apps that i need work now with sfos 1.1.7.28 I can close the thread here

edit flag offensive delete publish link more

Question tools

Follow
1 follower

Stats

Asked: 2014-11-26 00:35:12 +0200

Seen: 8,674 times

Last updated: Sep 09 '15