We have moved to a new Sailfish OS Forum. Please start new discussions there.

Clipboard - copy paste broken / not getting updated at times

asked 2014-12-03 15:14:29 +0300

pellen gravatar image

updated 2015-11-11 19:38:24 +0300

objectifnul gravatar image

Ran into this possible bug in the message/sms app, or in clipboard-management in general: When I copy a message it does not replace the contents in the clipboard. I did successfully copy a message last week sometime, because that is what I still have in my clipboard after trying to copy, but despite many attempts since to copy other messages the old text is still in the clipboard.

I noticed a related old question, but it was not clear if it was identical because it did not have a lot of detail.

Would try to overwrite the clipboard from some other app, but embarrassingly I can not find any other place to copy to the clipboard. Or maybe something is broken that causes other apps to not even give me the option to copy? I managed to do a "clear clipboard" in the Browser (when editing an url) and after doing that the clipboard is empty and copying an old SMS does nothing at all (well, like it did before, but instead of leaving the old message in the clipboard now it leaves it empty).

Have not attempted to reboot phone.

Update @anandrkris - I have started facing the issue of clipboard not get updated (not exactly same steps as above but random) after upgrade to Bassd on thread posting date and my experience, am presuming this as a regression in Update 10.

Update - 2015-05-22:

Still persistent in the latest update (

  • Jolla Utilities does not have an effect
  • Clearing clipboard does not have an effect
  • Only rebooting the device or restarting lipstick.service (homescreen) solves the issue
    • If you have dev mode installed, just open terminal and copy something here.. After this you can copy again normally (without reboot or lipstick restart).

Update by @anandrkris - I have faced this once in latest update as well. Hope Jolla looks into this.

Update - 2015-10-28:

Present in the latest Early Access version (Saimaa).

The following tricks work to get the clipboard working again:

  • Rebooting the device
  • Restarting Home screen from Utilites (I would imagine restarting lipstick from CLI also does the trick).
edit retag flag offensive close delete



I could do "Copy to Clipboard" on a link in the Browser and that also silently failed (clipboard still empty, so no paste icon when editing text anywhere).

pellen ( 2014-12-03 15:17:37 +0300 )edit

Sorry, I think this is just another instance of https://together.jolla.com/question/24697/regression-copy-and-paste-broken/#post-id-27372 but I have no idea how I managed to reproduce it.

pellen ( 2014-12-03 15:20:08 +0300 )edit

Maybe you just did not correctly use the "copy" function. I for myself find it not very intuitive. Please have a look at the user guide for copy and paste.

Another app capable of using the clipboard is the notes app.

Yo ( 2014-12-03 15:24:40 +0300 )edit

The Notes app was my first attempt. Just like elsewhere when I select a region of text there I do not now get the clipboard icon to copy. The only places I found to copy text for testing this is to long-press an old sms or a link in the browser and then pick copy from the menu (but as mentioned neither of those two ways to copy actually modifies the clipboard now). Sounds very much like that old answer I linked to.

pellen ( 2014-12-03 15:39:14 +0300 )edit

In the old question it came out that rebooting helped. Did you try that? (Not that this is an acceptable solution...)

Yo ( 2014-12-03 16:07:55 +0300 )edit

7 Answers

Sort by » oldest newest most voted

answered 2015-07-01 23:52:54 +0300

Schturman gravatar image

I found a solution without reboot or lipstick restart...
Hope it temporarily and Jolla will fix it..
When clipboard is stuck and you can't copy new stuff, just open terminal and copy something here.. After this you can copy again normally.. ;)

edit flag offensive delete publish link more



This only applies for people with developer mode enabled, so not exactly a solution... ;)

raketti ( 2015-07-02 08:50:19 +0300 )edit

Yes I know, but it very quick solution instead reboot or lipstick restart ;) Hope Jolla will fix this problem soon...

Schturman ( 2015-07-02 09:42:19 +0300 )edit

True. True. I'm no programmer, but how hard is to implement a copy-pasta -function? Copy this here -> paste that there, if here is full, overwrite. But in the end, I'm just a simple mechanical engineer. ;)

raketti ( 2015-07-02 10:29:49 +0300 )edit

Maybe somebody can make a patch for patchmanager that opens a terminal session write some letters and copies this, like @schturman described. Maybe this can be done fully automatized without a real window even so we would have a very handy workaround till its finally fixed by Jolla

PatsJolla ( 2015-07-03 16:03:13 +0300 )edit

I already tried to find how to insert word into clipboard with CLI, but without result. Maybe someone here can help with this command ? I can create simple package for this with fix icon on the desktop..

Schturman ( 2015-07-03 16:24:30 +0300 )edit

answered 2015-03-11 13:08:12 +0300

NicePics13 gravatar image

I get the stuck clipboard phenomenon quite often. Like some app sets it to read only :^D

Before a simple keyboard restart (via the terminal) cleared it right up:

systemctl --user restart maliit-server.service

But now since the last Jolla Utilities update (with the "restart keyboard" option - which doesn't work) only a reboot clears a stuck clipboard :^(

Annoying that something like copy&paste is so error prone.

edit flag offensive delete publish link more

answered 2015-07-06 13:49:15 +0300

Schturman gravatar image

updated 2015-07-06 13:53:20 +0300

Finally solution for quick fix of clipboard is found (I hope).
Thanks to @alfmar for pbcopy (https://openrepos.net/content/alfmar/pbcopy), to @V10lator and @kimmoli for help on TJC (https://together.jolla.com/question/98061/question-terminal-command-for-insert-word-into-the-clipboard-answered/).
Here is a packge, just press on the icon and you will get notification about fix. Also you will see text "Clipboard is fixed!" in clipboard icon.
I can't get my clipboard to be stuck now and test it in real time, please test and report if it work for you.

P.S. @alfmar repo should be activated or pbcopy package installed befor you will install my package.

edit flag offensive delete publish link more



Nice, random rpm package in dropbox without any description/sources...thanks, but no thanks.

kimmoli ( 2015-07-06 13:54:05 +0300 )edit

In the common internet language: Seems legit.

raketti ( 2015-07-06 13:55:29 +0300 )edit

I can't get my clipboard to be stuck either (on 1.1.6).

Once I copied a text inside an Android app, and paste it using clipboard icon (instead of Android's own paste), then killed Android Support and I had a stuck clipboard. Then I restart Android and copy and paste several times with both Android's paste and keyboard clipboard icon, and it solved. After then, I can't get it stuck anymore.

AliN ( 2015-07-06 14:11:34 +0300 )edit

It's really hard to reproduce the bug. I had it last week and it got solved..somehow..without my influence, now it works again without a restart. a good method to check for the bug is in my opinion Haveclip with the desktop-client. There you can copy a link on your pc and it appears in the clipboard of the phone BUT will not get used when you paste. Haveclip can even show you the last 10 or so clipboard contents.

PatsJolla ( 2015-07-06 15:05:32 +0300 )edit

@kimmoli, it's just simple script that run "pbcopy" command. In the .spec file as Requires the pbcopy package from @alfmar (https://openrepos.net/content/alfmar/pbcopy).
BTW you know by yourself that you always can extract content from package without installation to see what it include ;)

Here is content of .spec file:

Name:          fixclipboard
Version:       0.2
Release:       1
Summary:       Fix Clipboard
Group:         System/Tools
Vendor:        Schturman
Distribution:  SailfisfOS
Packager: Schturman <schturman@hotmail.com>
URL:           www.dhrider.co.cc
Requires: pbcopy

License:       GPL

Auto-fix for stuck clipboard...
Thanks to @alfmar for pbcopy, to @V10lator and @kimmoli for help on TJC. 



if [ $1 = 1 ]; then
    // Do stuff specific for first install
echo "It's first time install"
 if [ ! -f /usr/share/lipstick/notificationcategories/x-nemo.simple.notifications.conf ]; then
  echo 'x-nemo-icon=icon-m-notifications' > /usr/share/lipstick/notificationcategories/x-nemo.simple.notifications.conf
if [ $1 = 2 ]; then
    // Do stuff specific to upgrades
   if [ ! -f /usr/share/lipstick/notificationcategories/x-nemo.simple.notifications.conf ]; then
    echo 'x-nemo-icon=icon-m-notifications' > /usr/share/lipstick/notificationcategories/x-nemo.simple.notifications.conf

if [ $1 = 0 ]; then
    // Do stuff specific to uninstalls
rm -rf /usr/share/openrepos-fixclipboard
if [ $1 = 1 ]; then
    // Do stuff specific to upgrades
echo "It's just upgrade"

* Wed Jan 25 2014 Builder <builder@...> 0.1
- First build.

Schturman ( 2015-07-06 15:43:10 +0300 )edit

answered 2015-02-05 10:31:06 +0300

sedric gravatar image

I've got this problem too, I don't experience it since a recent btrfs balance as describe in this thread.

Hope this may help.

edit flag offensive delete publish link more


Thanks...I don't think I am affected by this bug though...

anandrkris ( 2015-02-05 10:37:05 +0300 )edit

answered 2015-05-22 13:07:55 +0300

JoHe gravatar image

updated 2015-05-23 00:48:29 +0300

A workaround for this bug that appears occasionally: write a couple of (random) characters and after that an empty space (in the same new line) -> in most cases(?) that makes the clipboard icon to appear so you can paste.

edit flag offensive delete publish link more

answered 2016-05-08 18:55:46 +0300

spidernik84 gravatar image

I have noticed the same. What triggers it for me seems to be the action of stopping the Android support. I do it often since I only use it for Whatsapp. Starting the Android support again does not help: the clipboard remains in an inconsistent state.

Solution for me: open whatsapp (or any app that allows copy/pasting text), type something in a textbox, select it, copy it in the clipboard via the app itself. At that point the clipboard starts working again and it syncs properly with the Sailfish one. Hope this helps.

edit flag offensive delete publish link more

answered 2015-11-21 11:33:17 +0300

247 gravatar image

having this problem too sometimes...hope it get solved...

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools



Asked: 2014-12-03 15:14:29 +0300

Seen: 2,207 times

Last updated: May 08 '16