Ask / Submit
566

Jolla randomly shuts down

asked 2013-12-30 22:04:14 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2015-05-20 01:45:14 +0300

Neo gravatar image

Numerous users have an issue with the phone rebooting by itself. User testing has revealed that it most likely has something to do with the battery. If this is happening to you, there are two ways you can probably solve the problem. You can either:

  • take out the phone battery, and rub all contact areas on the battery and the phone with a regular eraser, then just put the battery back in.
  • take a small piece of paper and put it between the bottom of the battery and the phone, so it makes better contact.
  • put a bit of paper between the battery and the phone body (as seen here)

If neither of these solutions helps at all, please mention this and edit this post to include that information.

It would be nice to read an official statement on the issue, if this is something related to the manufacturing process or something else.

edit 06.04.2015 (MacManus): i noticed that my jolla reboots on weak network connections (can't reproduce in wlan). If i'm in an area with weak network, my jolla constantly reboots. If i didn't activate my sim, the phone didn't reboot. As soon as i activate sim and get mobile network connection, the jolla reboots.

Edit 20.05.2015: Anyone with this problem please see this answer, it seems that they finally have a clue about how to fix this issue.

edit retag flag offensive close delete

Comments

3

I'm experiencing this same problem starting today. I haven't installed any new updates / apps since the last SW update 2 days ago. Sometimes after the shut down the phone refuses to turn back on. Trying different things with the phone now to track the problem down.

EDIT: After the shut down happens, the phone turns back on on first try if I plug in the charger.

fAzu ( 2013-12-30 22:13:32 +0300 )edit
3

I have my Jolla phone turned on for 24/7 and it's also updated to this recent firmware and haven't ever seen such unintentional shut downs. None. Nothing even close to that. So definitely can't confirm this. There is a change you may have problems with hardware.

Simakuutio ( 2013-12-30 22:14:29 +0300 )edit
1

I've had 2 reboots so far, but both were before 1.0.2.5 update and while I was not actively using the device. I can't really say anything else about the cases, but I think I had nothing special running, just WiFi/3G and Settings or something. What apps and networks are you using when this happens?

Julle ( 2013-12-30 22:16:30 +0300 )edit
  1. Did you try hard reset for solve some issue ?
    1. if yes, try to run CSD tool on your phone for discover any abnormal hardware malfunctionality before return your product for hardware repair
    2. pully down, select phone, input code (i can't show the code) and follow instructions and we wait feedback you can find the code here http://jollafr.org/un-utilitaire-secret-pour-tester-toutes-les-fonctionnalites-de-votre-jolla/
redge73 ( 2013-12-30 23:03:06 +0300 )edit
7

Ok, so after removing my battery for a longer period (roughly 10 minutes) the problem vanished. Seems like a software glitch. I cannot recreate this behavior for now, but I'll monitor my workflow in case the problem reappears.

fAzu ( 2013-12-31 10:18:51 +0300 )edit

75 Answers

Sort by » oldest newest most voted
3

answered 2014-05-16 17:50:20 +0300

pycage gravatar image

updated 2014-06-19 10:55:42 +0300

For me the trick with the folded piece of paper at the bottom end of the battery (to push it more towards the connectors, even though it was sitting pretty tight already) did it for me.

Update 19 Jun 2014: The paper trick worked very well for update5 and I did not have a single shutdown. But since Update 7, I had one shutdown again so far, even with the paper in place.

edit flag offensive delete publish link more

Comments

1

The folded paper solved the problems for some weeks now (4-6) but the last days I had around 10 restarts in 2 days when traveling and using also GPS location and Android app OsmAnd and having bad 2G network connection. I'm not using GPS and switching it off normaly.

axaq ( 2014-06-04 03:31:10 +0300 )edit

I had the same problem whit update 7. I folded my paper once again and no problems for over a weak now. =)

vicsjo ( 2014-06-20 15:32:00 +0300 )edit

As they say the problem is measured with bad connection / voltage drop from the battery the connectors on the phone and the condition of the plates on the battery is of course a "cause" or "solution"

nidelius ( 2014-08-06 21:36:58 +0300 )edit
3

answered 2014-09-25 16:12:58 +0300

Leinad gravatar image

to me, it seems like this problem is caused by corrosion of the battery contacts: it was no problem in the beginning, but increased over time, the "paper trick" worked for a few weeks, but over time, i had to add more and more paper to avoid reboots / shutdowns and in the end, paper did not help anymore.

so in order to prevent corrosion, i sprayed some (very little) WD-40 on a Q-Tip and cleaned the battery contacts with it. this is about 6 weeks ago and i had no reboot ever since, even without paper under the battery. maybe i will have to repeat this once or twice a year, but i can live with that...

i'm no electrician or something like that, so i don't know, if this is a really good idea, i only know, it worked for me... maybe someone with more experience in electrical engineering can tell his / her opinion?

edit flag offensive delete publish link more
1

Thanks for your input. Could be that you are right. When I sent my phone to Jolla, they said that they would have "cleaned the battery contacts". Furthermore they put a piece of plastic in the battery holder which pushes the battery up. For about 3months I had no reboots anymore. Once I had them again (and weird battery level drops) I additionally put a paper strip in there - no reboots anymore (for now).

So my observation confirms what you wrote above.

molan ( 2014-09-25 17:39:51 +0300 )edit
3

answered 2015-04-08 08:26:13 +0300

Matulski gravatar image

Lately the phone has become unreliable. Basically as soon as the battery status reaches 50% or below the phone constantly shutsdown/restarts while browsing, being in the pocket next to the bed. I got it a few times into a state of rebooting and after entering the pin code it would shutdown again immediatley. Repeating that a few times it eventually starts up and shows that the battery has dropped a huge amount of percentage from what it last displayed. I cleaned the battery contacts and also added tape at the bottom of the battery to get a tighter fit. Does not make any difference. CSD-Tool shows that the battery health is good. Running the latest public OS release. I have a feeling it might have to do with usage of mobile data connection. I managed to crash the phone by shutting down the modem it was connected too or walking out of the WLAN signal range.

edit flag offensive delete publish link more
2

answered 2014-01-27 17:25:51 +0300

Xowap gravatar image

Same issue again.

Automatic updates are on.

Device shuts down with no reason at all, either in my pocket, either when I use it.

When it starts shutting down, it does it every few minutes, until I pull out the battery and put it back. Then it works OK for a few days again.

edit flag offensive delete publish link more

Comments

Maybe the phone thinks the battery is depleted and you can only remedy from it by pulling the battery or connecting the charger. I haven't tried connecting the charger yet, but it would be interesting to see if that can take it out of the reboot loop the same way as pulling the battery does.

pycage ( 2014-01-27 19:38:57 +0300 )edit
3

That's it. Every other cause is too random. I'm pretty sure it's a power drain problem. The phone draws too much power in this specific moment and the battery is not able to deliver this power even if it's not empty or nearly empty.

SagaciousT ( 2014-01-27 19:49:04 +0300 )edit

This could explain why I never saw it happen while battery was still above 95%.

pycage ( 2014-01-27 20:06:34 +0300 )edit

I always connected the charger since for the first two times it had shut down during idle somewhere for hours, and I thought that simply something happened to drain all of the battery. When plugged in, it revived itself and then I noticed the battery had more than enough (50-70%).

Mirv ( 2014-01-29 12:30:39 +0300 )edit

To add to the data points, for me it has always been wifi off, 3G data on, because that's how I've the setup 90% of the time. Today's shut down when actively browsing happened when I had also Bluetooth on. The first two times (or so) were at home, and this one in a cafe.

Mirv ( 2014-01-29 12:32:18 +0300 )edit
2

answered 2014-02-22 14:40:18 +0300

CLR64 gravatar image

If Jolla fixed the bug why didn't we get an update here or did I miss it? My phone is totally unusable since a some weeks. I often get many reboots/shut downs in a row. Already contacted care - no response yet.

Many wrote it seems to have something to do with time information and I guess this can highly be true because I often get the plug-in-cable symbol before it shuts down.

It could be helpful if you guys post which provider you have. I'm at vodafone germany. Unluckily vodafone doesn't use date/time updates over the net. Because of this I had problems with many phones. I never had the correct time over more then a week on them. Could this be the reason now for those big Jolla problems?

edit flag offensive delete publish link more

Comments

I don't see why you posted this as an answer. In Norway, my N900 was constantly off by 2 minutes on some providers. I learned that it was because of a misinterpretation of the protocol. Don't know any more details.

martinrusler ( 2014-02-22 14:52:26 +0300 )edit

This is definitely no time problem. It's a power management problem.I also have Vodafone Germany and no problems anymore.

SagaciousT ( 2014-02-22 15:12:41 +0300 )edit

@SagaciousT So what update or fix have you got, that we don't? Did the problem solve itself?

martinrusler ( 2014-02-22 15:26:01 +0300 )edit
2

@SagaciousT

Quoting pycage:

My assumption is that some cell towers give invalid time information which confuses timed so much that it triggers some panic reaction (maybe [I'm just making this up, but it sounds plausible] something like "oh! phone ran for 300 years, battery must be empty, shut down quick!"). 3G cell towers seem to be better in this way, so we mostly only see this in conjunction with a 2G connection.

Then it would be a timing issue leading to a power management one.

CLR64 ( 2014-02-22 15:51:49 +0300 )edit

Just wanted to chip in, that after many reboots and PIN inputs I notice that the time is off before it autocorrects.I'm not sure this happens every time, but it's quite consistent.

kultsinuppeli ( 2014-04-05 11:05:08 +0300 )edit
2

answered 2014-03-25 18:59:29 +0300

vicsjo gravatar image

I have still reboot and shutdown problems after update 1.0.4.20, but now also hot temperature warnings. Battery level still suddenly drops to 4% and connection problems. To removing battery 10 minutes, only helps for a few hours. The problems often occurs when cell network are overloaded or in low cell reception areas and battery level 45%-75%

edit flag offensive delete publish link more

Comments

Same here, your post is a good resumé. I didn't have that problem for 2 month, but then it started end of February. 1.0.4.20 didn't fix anything or made it even worse (hot battery and battery level drops to 4%). I experience the issue contantly on my home network, but tested and can confirm that it doesn't work on at least 5 other, foreign networks in 3 different countries. Good to have a Nokia N9 as backup...

molan ( 2014-03-29 00:53:52 +0300 )edit

Started happening to me last night, been running the 1.0.4.20 since it came out and no problems.

Last night it happened for the first time, when I played some Clash of Clans on the android environment. Screen just went black and the it didn't respond to power button either..

Plugged in the charger, and the phone started after first showing the "Charge the battery" screen for a few seconds. When the phone started I had 47% of battery, and I was confused... left it in the charger still..

Later, I unplugged the phone and opened Android Facebook, and it shutdown again. Restarted the phone, and it shutdown almost immediately again. Started the phone again, and killed the Android (with the Kill Droid app) - phone stayed online.

Started Clash of Clans and the android, phone died again.

Plugged in the charger, and the phone did not shutdown anymore.

So, like some poeple said earlier: for me it seems to be battery level/temperature/power drain related with android environment in the mix (maybe it uses "more" power to run?)

I've almost only used the phone over the android, so it's not a new thing for me, just the shutdowns only started last night.

It did not shutdown with the charger plugged in.

Juuba ( 2014-04-03 07:50:09 +0300 )edit
2

answered 2014-04-24 03:42:12 +0300

MasterOfMemory gravatar image

I also had the problem of my Jolla repeatedly shutting itself down. Sometimes it got caught in a Boot-Loop, sometimes it went dead and I head to take out the battery. I am experiencing this bug at least since the fourth update. Most often when on low battery (<30%) it randomly rebooted. However, things got worse with the last update (1.0.5.16). Since then I had three different problems:

  1. From even high battery (~80%) it suddenly dropped to 4% warned me about my battery being low, dropping further to 2% warned about shutting down and finally shutting down, all happening withing less than one minute. When I managed to get the Jolla back up, it showed a somehow heavily reduced battery (~60-70%) but at least worked again.
  2. Sometimes I only recognized the Jolla rebooted, because of all apps suddenly being closed. This happened without any heavy work in progress, normal idle only. This may somehow be linked to steffenl connection problems, since I think this problem occured less often with 3G and WLAN disabled.
  3. When currently working with the phone (i.e. surfing or composing a mail) the screen went black and the "Jolla"-Logo splash screen came back up. This might not count as full reboot, because the phone was not completely shut down before. In my eyes this cannot be linked to any 3G/WLAN connection problem. Arguing with a full RAM I restored for example the browser to just resume browsing, where I had just been interrupted, it turned black again, without any other app opened.

However disabling the NFC-Chip surpressed the described problems for me. I do not know why but it does.

Hopefully this reaches someone and helps

edit flag offensive delete publish link more
2

answered 2014-05-17 15:44:45 +0300

Mariusmssj gravatar image

These random shutdowns and reboots are getting very annoying. My Jolla is becoming less and less reliable.

edit flag offensive delete publish link more

Comments

1

Have you really tried the paper under the battery solution? This solved it for me entirely. My uptime is only reset by the monthly updates since.

zlatko ( 2014-05-17 16:13:37 +0300 )edit

I haven't had any random shutdowns or reboots since using the folded paper to force a stronger battery connection.

As zlatko asked: Have you tried this?

This was mentioned earlier in this very same discussion: https://together.jolla.com/question/7144/jolla-randomly-shuts-down-10516/?answer=37046#post-id-37046

caa ( 2014-05-17 18:35:14 +0300 )edit
1

I'm also frustrated by the random shutdowns. It's all very well inserting paper for the battery, but the point is that I never had these random shutdowns until the last system update.

Something has been introduced by the update, and now my once reliable Jolla now can be a very frustrating phone!

zamorph ( 2014-05-17 23:07:07 +0300 )edit
2

answered 2014-05-19 13:12:12 +0300

egnat69 gravatar image

the important thing: the folded paper really solved it...

i've been experiencing the shutdown bug now and then, but 10 days ago it acutally got worse, hit me 3-4 times a day... i neglected the paper-trick due to the fact, that i thought no phone would have this issues after the old days of nokia... although, i realized that it had to be something with the battery connection... all the symptoms pointed in the direction of a very short loss of power as the source for the shutdown and/or reboot...

i just gave it a shot, folded a small paper, put it in and - perfect... no issues since...

i also had the feeling that the shutdowns were related to some sort of task but it really seems like it all was coincidence...

edit flag offensive delete publish link more
2

answered 2014-06-19 11:45:31 +0300

SagaciousT gravatar image

updated 2014-06-19 11:48:04 +0300

The paper trick ist technical homeopathy. It only helps until the next shutdown. I have no problems as long as I keep the battery on a level above 40%. The shutdowns occur with high temporary power drain and low battery level. The release notes of the latest release indicate the same:

  • Fixed shutdowns because of invalid overheating reports
  • Fixed two kernel null pointer errors that cause device to reboot
  • Device stability improved by making it less sensitive to sudden power consumption peaks

However, Sailfish 1.0.7.16 has still problems regarding this issue. But I'm confident since the guys know where the bug hides.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
114 followers

Stats

Asked: 2013-12-30 22:04:14 +0300

Seen: 56,965 times

Last updated: Oct 12 '18