Ask / Submit
6

Bug Unable to attach files in Mail (permission issue?)

asked 2014-12-18 06:10:08 +0300

updated 2015-02-02 10:16:09 +0300

Hi, I downloaded a pdf file from internet and wanted to share it to my work mail but unfortunately can't attach it as I am unable to find it under Documents! The only files displayed are *.vcf files from Documents folder. I even moved the pdf file from Downloads to Documents, does not help. It is very crucial to be able to share files. Also, we need a proper file picker to be able to attach files as needed.

https://together.jolla.com/question/321/file-picker-needed/

Update: After reading this, found out that one workaaround is that its available after you open the document. I checked in context menu and found only delete! :-(

Update 2: One of the pdf file shows up for selection. Another one moved from Downloads does not show up. So, looks like a permission issue as pointed out by others. Although, am unclear on how it works as I changed them all to rwxrwxrwx

edit retag flag offensive close delete

Comments

1

Just tried this with Uitukka (1.1.0.39) - No problems, found the.pdf in Documents, attached it and sent it. No problems at all.

Edz ( 2014-12-18 12:35:57 +0300 )edit

My Sailfish Version is 1.0.8.21 (Tahkalamapi). I will check this again on Update 10 once released.

anandrkris ( 2014-12-18 13:08:39 +0300 )edit

It seems that there is a discrepancy between that what's shown in the Documentsapplication and the content picker (https://together.jolla.com/question/63817/show-downloads-in-content-picker/). The latter strictly shows under Documents what's in ~/Documents while the app takes the downloads into account too.

Moving the file from the downloads folder to documents made the document in question to show up in the content picker. May be because I moved the document to /tmp first and then to the documents folder and I closed and re-opened the mail application.

lechris ( 2014-12-18 15:43:47 +0300 )edit

In 1.1.1.27 no documents (.pfd or other extensions) can't be attached to email cause the picker does not show them sometimes even if moved from Downloads to Documents. This is clearly a bug in.Jolla and manual CLI noving of files and changing of permissions shouldn't be required to nake files shown in Documents app visible to be added as attachments to emails.

foss4ever ( 2015-01-05 15:32:59 +0300 )edit
1

@jjaone I can confirm the behaviour that a PDF moved into ~/Documents does not show up in the content picker while the mail app is open. Closing and re-opening the application makes this PDF in the Documents section of the content picker with 1.1.1.27.

lechris ( 2015-01-05 16:46:17 +0300 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2014-12-18 09:32:46 +0300

gerrymatha gravatar image

I also had this problem with attaching various files downloaded using email or internet. The core problem with the issues seems to be around the file permissons. When a file is downloaded it has only permission to read in local format for some reason. The workaround I used to get the file to show was: Open terminal

devel-su
*root password*
cd /home/nemo/Documents/ (or wherever file is located)
chmod 777 file123.pdf (whatever file name is called)

This should change the permissons of the file to read/write access and you should be able to send it from then. It however does open read write access to anyone so if you plan on using SSH be careful when using this command. While not ideal it does work.

edit flag offensive delete publish link more

Comments

Thanks, will give it a try.

anandrkris ( 2014-12-18 10:49:13 +0300 )edit

had exactly the same problem, and solve it like you said.

gilou3000 ( 2014-12-18 13:19:25 +0300 )edit
1

answered 2015-01-05 15:48:15 +0300

foss4ever gravatar image

As this Downloads and Documents files handling in Jolla Email and other apps is clearly a bug and annoying issue, which should be fixed by Jolla, there is a very simple workaround to make the files in Downloads folder to become visible to "file picker" and to enable them to added as attachments for emails. You only need to make a symlink in Documents folder to Downloads folder with this command in Terminal as normal user:

cd Documents; ln -s ../Downloads

No need to move files or change any file permissions, but right after giving that command all the contents in Downloads becomes visible to be added as email attachments (Email app needs to be restarted).

Works for me in 1.1.1.27 with no side-effects elsewhere ;)

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2014-12-18 06:10:08 +0300

Seen: 453 times

Last updated: Feb 02 '15