Ask / Submit
37

How to synchronize contacts with an ownCloud account using CardDAV?

asked 2014-12-23 23:17:47 +0300

remjg gravatar image

updated 2015-06-22 18:09:43 +0300

damourti gravatar image

I have just received my Jolla phone with Sailfish OS update 10 (Vaarainjärvi). In the settings, it is made possible to configure CardDAV and CalDAV synchronization.

I have an ownCloud account provided by a french association called Zaclys, and I managed to set up CalDAV after many tries (see a tutorial I have written here in french). Basically, I put the CardDAV link in Server address field and I left the Calendar path field empty while only checking CalDAV.

Unfortunately, same method doesn't seem to work for CardDAV sync (the account is active but contacts don't synchronize). My CardDAV link is :

https://webcloud7.zaclys.com/remote.php/carddav/addressbooks/6812/contacts.

How to synchronize contacts with an ownCloud account using CardDAV?


Here is what I can see looking at the output of journalctl | grep carddav:

déc. 23 22:42:40 Jolla carddav-client[6478]: [W] CardDav::addressbookUrlsResponse:358 - void CardDav::addressbookUrlsResponse() error: 203 ( 404 ) 
déc. 23 22:42:40 Jolla carddav-client[6478]: [C] CardDavClient::syncFinished:137 - CardDAV sync failed: 401 ""
edit retag flag offensive close delete

Comments

I forgot to say that I have looked at many topics like question 60493, but I'm even more confused after.

remjg ( 2014-12-23 23:20:21 +0300 )edit

@remjg I added the "7" in the address and now it worked for me on Zaclys with the solution (with syncevolution from Openrepos) from asys3 described here: https://together.jolla.com/question/880/summary-of-owncloud-integration/?comment=77688#comment-77688

damourti ( 2015-01-26 00:31:13 +0300 )edit
1

Ok, I think that we now have a nice description here since upgrade 1.1.4.29 : https://together.jolla.com/question/60493/new-carddavcaldav-support-got-to-it-working-with-owncloud/?answer=89849#post-id-89849@remjg shall we close this thread?

damourti ( 2015-05-05 12:03:56 +0300 )edit
1

Definitely ! thanks for the link, just created 2 account and everything is working smoothly now on my owncloud and Jolla !! :D /me happy ^^

clovis86 ( 2015-05-05 12:33:07 +0300 )edit

I feel the same :D Finally!

damourti ( 2015-05-05 12:42:02 +0300 )edit

2 Answers

Sort by » oldest newest most voted
8

answered 2014-12-26 22:47:20 +0300

anyc gravatar image

I wrote a patch (see https://together.jolla.com/question/60493/new-carddavcaldav-support-got-to-it-working-with-owncloud/?answer=72672#post-id-72672) but only the first sync works so far.

edit flag offensive delete publish link more

Comments

1

So what is the issue with the official support so far ? Why according to you it doesn't work ?

remjg ( 2014-12-26 23:10:34 +0300 )edit

Official carddav sync does not sync owncloud contacts. Has been like this since the carddav feature was released.

Edit: sorry, tired. It gives wrong path I think, and one cannot get past it by just assigning the full path to the server field in account settings.

Manatus ( 2014-12-27 00:24:45 +0300 )edit
2

Sorry to hear that syncing cannot work. I hope a solution will be found soon, it is quite an essential feature for a phone.

remjg ( 2014-12-27 00:59:52 +0300 )edit
2

As far as I know, the problem is that owncloud requires that carddav requests contain a path (e.g., to enable synchronization of multiple calendars). I assume that the officially supported types of servers don't require such a path (maybe they only use one calender) and the server name alone is sufficient.

In the thread I linked, someone posted a workaround by modifying the server to rewrite the requests on the server side. My patch fixes the client on the jolla in a way that it at least enables an initial synchronization so you get your current contacts. Maybe this path is required in other parts of the code as well but I didn't had the time yet to investigate this further.

anyc ( 2014-12-27 01:10:59 +0300 )edit
0

answered 2015-05-04 10:50:12 +0300

clovis86 gravatar image

updated 2015-05-04 10:50:29 +0300

Does anybody have any news on this sync issue after initial one please ?

edit flag offensive delete publish link more

Comments

1

With the latest update, just use: https://webcloud7.zaclys.com/ as your server host url (or whatever your host url is, do not include any path fragment).

The patch which was provided by anyc was not the correct solution. The correct fix for the issue was integrated into the repository and released with the latest update.

There are still some issues which the latest release did not include fixes for (eg, self-signed SSL certificates, and avatar support) however so long as your service supports either path discovery or well-known endpoint redirection, and has a valid SSL certificate, you should be able to sync correctly.

chris.adams ( 2015-05-05 04:03:35 +0300 )edit
1

Yes @clovis86 it works fine for me, at least with Zaclys hosted webcloud! Use the explanation here: https://together.jolla.com/question/60493/new-carddavcaldav-support-got-to-it-working-with-owncloud/?answer=89849#post-id-89849 The server address is the one written by @chris.adams just above. (the '7' is important!)

damourti ( 2015-05-05 11:57:46 +0300 )edit

Cross topic : informations on behaviour of pictures with owncloud using caldav : "Manatus test on pictures and contacts"

clovis86 ( 2015-06-09 10:07:37 +0300 )edit
Login/Signup to Answer

Question tools

Follow
19 followers

Stats

Asked: 2014-12-23 23:17:47 +0300

Seen: 3,508 times

Last updated: May 04 '15