Ask / Submit
35

icons for wifi and mobile data alternating

asked 2015-01-03 05:08:14 +0200

moosiqpipl gravatar image

updated 2016-08-17 11:04:25 +0200

jiit gravatar image

Just noticed the home screen icons for wifi and mobile data continously alternating - as if the device can not decide whether to use wifi or the mobile data connection. However, wifi is connected and seems to be the active connection. This behaviour exists after returning the device from airplane mode.

I'm not sure if this turns out as a serious issue, but at least it's annoying.

edit retag flag offensive close delete

Comments

6

Same for me. It happens several times now (without activating flight mode). In that situation the device has two IPs assigned, one from the WLan and one from the mobile network. However WLan connecitivity is used. This started to happen after installing update 10. It was no problem in update 9.

alex25 ( 2015-01-03 07:25:52 +0200 )edit
1

same happens with my device :-( but after disable wifi and mobile data and than enable both, it works in normal order - but a few hours later, the same problem returns...

peter-berlin ( 2015-01-03 09:35:32 +0200 )edit

Yeah, me too. Happens out of the blue.

I have two routers at home with different SSIDs and, IIRC, switching from one to the other fixes it too.

pichlo ( 2015-01-03 10:04:11 +0200 )edit
1

it also happens to me. not a big problem, but annoying. thank you

salkos73 ( 2015-01-03 12:12:10 +0200 )edit

same here, usually wlan runs 1-2 hours and then sometime it will be unstable (sitting 3 meters) besides the router. Switching WLAN off/on and will be ok for some time.

woody ( 2015-01-03 22:17:33 +0200 )edit

2 Answers

Sort by » oldest newest most voted
17

answered 2015-01-03 12:22:02 +0200

tigeli gravatar image

When wlan and mobile data icons are alternating they are both active but wlan has the default route, it is nothing serious.

Why this happens? There is a slight chance of both getting connected at the "same time" eg. wlan is scanning available networks (not connected) and autoconnect for mobile data kicks in. However just before mobile data gets connected wlan-network is found and connected.

If mobile data networks gets connected while device is connected to wlan the device does not disconnect from it automatically by device's connection manager (eg. it could break agps). When it happens otherway around meaning the device connects to wlan while being connected to mobile data... the mobile data connection will be disconnected.

edit flag offensive delete publish link more

Comments

18

And before someone asks.. we will work on this. :)

tigeli ( 2015-01-03 12:23:57 +0200 )edit

Great! (Because I also saw this happening today for the first time)

zappAtom ( 2015-01-05 22:36:45 +0200 )edit
1

answered 2015-01-04 00:21:53 +0200

bilgy_no1 gravatar image

updated 2015-01-04 00:34:39 +0200

This seems to be related to the general post about the connections manager:

https://together.jolla.com/question/64892/bug-the-most-urgent-problem-connections-manager/

It's good to see tigeli's answer above and that they're working on it. I must say things seem to have improved with update 10 and more improvements should be forthcoming with update 11.

Although I haven't experienced the issue described here exactly, I have had occasions where the WiFi indicator showed an exclamation mark, but the Settings said Connected to WiFi at the same time.

edit flag offensive delete publish link more

Comments

Yes, this also happens from time to time. Although the wifi setting indicate an established connection there is no connection at all. Disabling and re-enabling the wifi in settings fixes this. Until the next occurrence of the phenomenon :-/

moosiqpipl ( 2015-01-21 19:55:53 +0200 )edit
Login/Signup to Answer

Question tools

Follow
7 followers

Stats

Asked: 2015-01-03 05:08:14 +0200

Seen: 544 times

Last updated: Jan 04 '15