We have moved to a new Sailfish OS Forum. Please start new discussions there.

How do I choose a server for XMPP? [answered]

asked 2013-12-31 11:25:50 +0300

ausgeregelt gravatar image

updated 2013-12-31 12:02:32 +0300

Low gravatar image


Is there any chance to specify the server for the XMPP-Chat? I am using the Fastmail chat servers and would be happy to use them on my Jolla, too.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by ausgeregelt
close date 2014-01-03 15:13:05.742027

2 Answers

Sort by » oldest newest most voted

answered 2013-12-31 11:55:05 +0300

Low gravatar image

updated 2013-12-31 11:56:39 +0300

If you just give your username as user@example.com it is using example.com as server. For me I also had to disable ssl certificate checks via commandline:

mc-tool list

to get the account number XX in the accounts database of Sailfish, and then disable the check by

mc-tool update gabble/jabber/jabber_XX bool:ignore-ssl-errors=true

Someone said that this will be implemented in UI in the future, but don't quote me on that;) The full options can be found in cvp's TMO thread on Jolla XMPP with own server, note however that for me and some others it was not necessary to set the server via commandline, just as I wrote above giving the username with server already worked.

edit flag offensive delete publish link more


To be precise, the actual server name is determined from the domain's DNS SRV record for XMPP protocol. So for well configured XMPP services there should not be a reason to specify the exact server.

strnous ( 2013-12-31 12:17:12 +0300 )edit

yes not really. we're talking about two things... the server/service that the account is at, and the actual server handling the connection. I was referring to the first, and don't really see a need to specify the later.

Low ( 2013-12-31 12:32:25 +0300 )edit

I am not sure if I understand correctly. I think my connection problems stem from the fact that the connection server of Fastmail is: "chat.messagingengine.com" but the username I have to provide is: "username@sent.com". How would I have to find out the server/service and how would I have to add it?emphasized text

ausgeregelt ( 2013-12-31 14:06:15 +0300 )edit

If you are on linux check the SRV record with

nslookup -querytype=SRV _xmpp-client._tcp.sent.com

If the response shows the server name chat.messagingengine.com (which it does according to my own test), then there should be no need to specify the jabber server. The connection problems are then most probably related to something else (certificate problems or so).

strnous ( 2013-12-31 14:38:36 +0300 )edit

Indeed. xxx@sent.com is working "out of the box" once the ssl errors are ignored:

mc-tool update gabble/jabber/jabber_XX bool:ignore-ssl-errors=true

like mentioned above.

Thank you very much!

ausgeregelt ( 2013-12-31 18:24:24 +0300 )edit

answered 2014-01-03 13:36:25 +0300

ossi1967 gravatar image

Just in case anyone else really needs to enter the server manually and the DNS records don't provide the info, do the following: With the info obtained by mc-tool list (as described above), enter:

mc-tool update gabble/jabber/jabber_XX string:server=chat.messagingengine.com

(or whatever the required server name is)

edit flag offensive delete publish link more

Question tools



Asked: 2013-12-31 11:25:50 +0300

Seen: 978 times

Last updated: Jan 03 '14