Ask / Submit
70

[feature request] Disable unlock-sound

asked 2015-01-05 08:38:18 +0300

Stefanix gravatar image

updated 2015-01-05 12:16:24 +0300

Disable the unlock-sound (sound after entering the unlock code) without disabling other system sounds. I find this sound absolutely unnecessary. It alerts my environment every time I unlock my device. The user has full attention to the device at this moment, an acoustical feedback is not necessary. Disabling all system sounds is no solution, as low battery alert and others are useful.

edit retag flag offensive close delete

Comments

3

Yes, disable sound. And enable vibration instead.

MikaN ( 2015-01-05 08:50:51 +0300 )edit
10

@MikaN, I don't see the point for having vibration feedback either. But, as with many things, allowing the user to choose between nothing/haptic/audible would be the optimal solution.

Okw ( 2015-01-05 12:52:00 +0300 )edit
3

Please if this feature request is not accepted, provide at least instructions on how to disable. Then someone could add it in the patch manager. For me this is not just unnecessary but really annoying.

saturn ( 2015-01-05 18:13:45 +0300 )edit
3

I would like to see this made a configuration option. Quite often I disable sounds before unlocking and then enable them again after unlocking, but this is not a solution in the long run.

FrederikF ( 2015-01-05 23:32:31 +0300 )edit

Bump because two very bad answers.

This feature could be implemented in a non-destructive, reversible way without messing in config files or replacing files.

RoestVrijStaal ( 2016-07-18 00:05:58 +0300 )edit

5 Answers

Sort by » oldest newest most voted
11

answered 2015-01-12 01:21:53 +0300

Vilkz gravatar image

Replacing "unlock_device.wav" in "/usr/share/sounds/jolla-ambient/stereo/" with an empty .wav should work

edit flag offensive delete publish link more

Comments

In my case, a reboot was necessary afterwards. Guess there might be some kind of caching.

But thanks for this hint!

ralooyar ( 2018-01-08 21:43:30 +0300 )edit
10

answered 2015-04-05 21:44:08 +0300

lakutalo gravatar image

updated 2015-04-05 21:45:19 +0300

In fact the configuration of feedback from the unlock event can be found in /usr/share/ngfd/events.d/unlock_device.ini.

At the time, editing files from the non-graphical feedback daemon is the only way to fine-tune sounds and vibration behaviour of the phone. A GUI for configuring ngfdwould come in handy (requested here: https://together.jolla.com/question/83453/gui-for-configuring-non-graphical-feedback/), as there is not much documentation to be found either.

edit flag offensive delete publish link more

Comments

Should one simply delete/rename that .ini file or should it be edited to erase/comment out some of the lines? If the latter, which lines are relevant for muting the unlock sound?

fawick ( 2015-08-26 12:20:08 +0300 )edit
5

I replaced the line

canberra.filename = unlock_device

with:

canberra.filename = nothing

This works for me. I have not observed any unwanted side-effects, but I am not sure, whether this is the correct way.

luna-is-here ( 2017-01-23 12:27:16 +0300 )edit

As there is no option there is no correct way either. ;) Thanks for posting!

lakutalo ( 2017-01-23 12:33:31 +0300 )edit

changing the config file as you mentioned didn't work for my Xperia. Replacing the wav file with empty file did the trick! (after reboot)

krisko ( 2017-12-30 21:02:35 +0300 )edit
2

commenting the entire line also works on my Xperia X (dual SIM) with no side effects

AAK ( 2018-03-06 23:13:25 +0300 )edit
9

answered 2017-03-24 20:47:51 +0300

Tomáš Moravec gravatar image

This would be nice in 2017 :)

edit flag offensive delete publish link more
7

answered 2018-06-08 12:22:09 +0300

potski gravatar image

Hi! I think we just got this in Mouhijoki. Vibration but no sound. This is great!

edit flag offensive delete publish link more

Comments

1

Came accross the unlock vibration on my Jolla 1 not until SOS 2.2.0.29. To me this sould be optional, like it's said before. Making this "hard-coded" is not a good solution (from a UI perspective, besides the mentioned ini-file editing).

@Stefanix: You might want to update your initial request accordingly (in case you agree).

zackbuffo ( 2018-06-08 13:45:28 +0300 )edit
1

I don't want the vibration. Any way to turn it off?

hetas ( 2018-06-09 11:07:15 +0300 )edit

@hetas - Settings/Sounds and feedback/Feedback/Touch screen vibration on/off

or

Settings/Sounds and feedback/Vibration Always/Only when silent/Only when sounds on/Never

Edz ( 2018-06-09 13:24:07 +0300 )edit
2

Turning off vibration completely does work but I do want the vibration when someones calling or I get a message. I don't want vibration when unlocking but since Mouhijoki there seems to be no way of turning it off. I don't have touch screen vibration on.

Well it's not a big deal, I just have to get used to it.

hetas ( 2018-06-09 18:43:47 +0300 )edit
2

answered 2018-06-22 13:21:12 +0300

donni106 gravatar image

Same for me as @hetas! It is completely confusing and unusual that there is now a vibration after unlocking the device. Please consider an optional setting for that.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
11 followers

Stats

Asked: 2015-01-05 08:38:18 +0300

Seen: 1,246 times

Last updated: Jun 22