The body of an email draft is cleared

asked 2015-01-06 19:50:22 +0200

halo gravatar image

updated 2015-12-15 09:23:16 +0200 gravatar image

The email client seems to clear the body of a draft created with some other email client when opening the draft.

Steps to reproduce the issue:

  1. Create a draft with Thunderbird (or any other email client, I assume)
    • Subject: “foo”
    • Body: “bar”
  2. Open Jolla email client
  3. Open the Drafts folder
  4. Open the newly created draft
    Expected results:
    • Subject is “foo”
    • Body is “bar”
    Actual results:
    • Subject is “foo”
    • Body is empty (the editor shows the grayed-out hint “Write message...”)

After editing the same draft again with some other email client, the behavior changes: now the Jolla email client does not clear the body of the draft anymore but shows the contents as expected:

(Continuing from the previous step)

  1. Go back to the Draft folder in the Jolla email client
  2. Edit the draft with Thunderbird
    • Change the body to “bar”
    • Save the draft
  3. Update the drafts folder on Jolla
  4. Open the updated draft
    Expected and actual results:
    • Subject is “foo”
    • Body is “bar”

If the draft is originally created using the Jolla email client itself and opened after that, everything works as expected.

Jolla SW:
Email account type: General email (Only one account exists)
Server: IMAP
Connection: SSL
Draft folder name: “Drafts”
Other email client: Mozilla Thunderbird 31.3.0 up-to-date from the Ubuntu 14.04 repository

Couldn't find any other related posts but this:, which doesn't seem to be related as far as I see, and should already be fixed / released anyway.

EDIT 2015-12-15 by this topic will be discussed on Dec, 17th Jolla Community meeting. If you plan to attend please edit the post and add your name in the list of substitutes in case I can't show up (50% chance atm)

edit retag flag offensive close delete


It happened to me too about 6 months ago, but forgot to report it.

I needed to send a long email so I wrote the most part from a pc and then saved it as draft. Once I had the missing pieces, I could not load the draft text and had to rewrite everything on a touch keyboard :(

I confirm it happens ( 2015-01-07 11:38:29 +0200 )edit

This happened to me today and I was pretty unhappy about the data loss. I'm using Sailfish OS 1.1.728.

brainwane ( 2015-09-23 20:49:49 +0200 )edit

I have just upgraded to Sailfish OS Eineheminlampi and this problem is still happening.

brainwane ( 2015-09-24 23:50:21 +0200 )edit