Ask / Submit
3

Askbot Bug: Tag Search doesn't work for multiple tags [answered]

asked 2013-12-31 21:21:32 +0300

Milhouse gravatar image

updated 2014-01-23 12:50:09 +0300

foss4ever gravatar image

The tag search works fine if you search for a single tag, eg. google, but if you enter two or more tags, eg. google bug (ie. the tags on this question), then the Tag search button does nothing when it is clicked.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by Milhouse
close date 2014-01-23 12:38:05.616557

Comments

Are you using this functionality extract from help page: "search by tags - enter [tag: sometag] or #sometag" or directly the URL?

TeHeR ( 2014-01-03 16:49:47 +0300 )edit

I'm talking about the "Tag search" input box below the "Featured Tags" in the right most column of the main question-list page.

Milhouse ( 2014-01-03 16:59:42 +0300 )edit

Re-opened cause still valid "bug?" as it does not work in Tags-section search-box..

foss4ever ( 2014-01-23 10:39:42 +0300 )edit

@jjaone: It's pretty clear that the two search methods are working in fundamentally differently ways - the main Tag search box (on the landing page) works with multiple tags via a server-based search, while the link you referenced is matching-as-you-type (javascript? xmlhttp?) and obviously works only with a single tag. I don't think you can expect the second method to work well for multiple tags, although if it can be made to work for multiple tabs (space as a tag delimiter?) then that would be nice, but I doubt most people will bother with that method and just use the standard "multi-tag" server-based search.

Milhouse ( 2014-01-23 10:40:02 +0300 )edit

I would also suggest re-closing this question and opening a separate question as it's really a different Tag search method - this original question has been answered, and closed, and was discussing only the Tag search where you submit a search when the button is clicked. The Tag search you are discussing does not involve a submit/click - it's a different search mechanism entirely, and may even be "by design".

Milhouse ( 2014-01-23 10:42:57 +0300 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2014-01-01 13:15:38 +0300

ziller gravatar image

Looks like the tag search function tries to incorrectly get the URL:

https://together.jolla.com/questions/scope:unanswered/sort:activity-desc/tags:google%2Cbug/page:1/

,which results in 404 Not Found, when it should in fact get the URL:

https://together.jolla.com/questions/scope:unanswered/sort:activity-desc/tags:google,bug/page:1/

A quick workaround: you'll see that after entering multiple tags in the search box, the page URL in your browser actually changes to the correct one, so just refresh the page and both tags are searched for.

edit flag offensive delete publish link more

Comments

Refreshing the page does not fix this issue, search with multiple tags still does not return any results..

foss4ever ( 2014-01-23 12:22:39 +0300 )edit

My answer was a workaround for the tag-search in sidebar, so redundant now that the issue has been fixed. It doesn't apply for the tag-page.

ziller ( 2014-01-23 12:27:55 +0300 )edit

No the seach with multiple tags has not been fixed in Together (only partially), and as it wasn't clear that this Q applied only to that, so the topic has been reopened to address the whole multiple tag search functionality (which it said in the title of the question origanally anyways). The new question is here: https://together.jolla.com/question/18865/bug-search-by-multiple-bugs-doesnt-work-in-together/

foss4ever ( 2014-01-23 12:33:15 +0300 )edit
0

answered 2014-01-03 17:13:22 +0300

Milhouse gravatar image

updated 2014-01-23 12:58:50 +0300

foss4ever gravatar image

It looks like the multiple tag search is fixed - it's now working as expected (thanks Jolla!)

Edit: it's only fixed in the side-bar "Tags search", but not in Tags-section search-box which topic is adressed here: https://together.jolla.com/question/18865/bug-search-by-multiple-bugs-doesnt-work-in-together/

edit flag offensive delete publish link more

Question tools

Follow
1 follower

Stats

Asked: 2013-12-31 21:21:32 +0300

Seen: 27,512 times

Last updated: Jan 23 '14