Disable Proximity Sensor

asked 2015-01-30 19:22:51 +0300

aegis gravatar image

updated 2015-01-30 20:01:05 +0300

As a consequence of the proximity sensor / "pocket dialling" problem fixed in Update 10, mentioned here it is now impossible to unlock my Jolla when it is inside a waterproof case (A Veho SAEM S6).

The case covers the power key, so that can't be used. The clear plastic front seems to block the proximity sensor even though it is see through. Possibly the sensitivity could be tweaked???

I've managed to disable the proximity sensor with mcetool. I think it should be a setting in the settings UI however.

For anyone else, you need to ssh into your jolla.

...enter your password...
pkcon update
pkcon install mce-tools
mcetool --set-ps-mode=disabled

to enable it again so that you don't accidentally pocket dial when it's out of the case, use

mcetool --set-ps-mode=enabled

The Jolla just fits in the veho case btw. I haven't tested how waterproof it is yet.

edit retag flag offensive close delete


Hej, I am using a Krussel SEaLABox XL with my Jolla. Everything is just fine. LVPVS out.

LVPVS ( 2015-01-30 20:01:37 +0300 )edit

Have you noticed any issues with disabled proximity sensor? After I tried to disable the sensors with mcetool --set-ps-mode=disabled my phone calls during conversation were constantly putting on hold. So I had to enable ps-mode back.

By the way, neither pkcon nor mcetool --set-ps-mode= require root access, so running devel-su beforehand in your recipe is useless.

Self-Perfection ( 2015-01-31 15:50:04 +0300 )edit