Ask / Submit
7

[BUG] email app can't handle large emails [released]

asked 2014-01-01 14:57:33 +0300

hardcodes.de gravatar image

updated 2014-12-18 18:32:33 +0300

chemist gravatar image

Hi there,

after playing around I found out that my first assumption was not correct, so I change his posting to attract more users (and ore important: more Jolla guys) to this error.

The email app has problems with large mails[x], those can be pure ASCII mails.

  • tap, hold, select delete in the inbox: remorse timer runs and an error message appears: email does not respond, continue or abort
  • tap and open in inbox: mail does not show up and an error message appears: email does not respond, continue or abort
  • tap and open in inbox, select delete from the pulley menu before the error message shows up. Back to inbox, remorse timer runs and an error message appears: email does not respond, continue or abort

[x] Whatever large means, I don't know where the threshold is.


Still present after update to 1.0.7.16


Originally posted as BUG: email does not respond Hi there, you need at least 2 unread email to reproduce this. Tap and read the first email. Select delete from pulley menu. While the countdown runs to abort deletion tap on the 2nd unread email and also immediately select delete from pulley menu. Error message appears: email does not respond, continue or abort If I delete mails from the overview with long tap and delete from the context menu, it works just fine.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by VDVsx
close date 2014-12-18 17:22:33.549152

Comments

I tried to reproduce both from the main screen (where all the new emails appear) and from the inbox and it didn't happen. Maybe you are having a race condition with something else? The mailbox I used is a self hosted IMAP4 one.

gabriel ( 2014-01-01 15:55:18 +0300 )edit

Mine is configured as IMAP4 as well. It's a Google account, if that matters (configured as email not as Google). But maybe there is a race condition if there are some timing problems with the mail server?

hardcodes.de ( 2014-01-01 18:23:31 +0300 )edit

Yeap, same here - google mail configured as IMAP4 in addition to my other accounts, just tried your bug and can't reproduce.

gabriel ( 2014-01-01 18:27:04 +0300 )edit

Damn, those are hard to track down.

hardcodes.de ( 2014-01-01 18:28:36 +0300 )edit

I've also not been able to reproduce this one.

steph ( 2014-01-01 19:33:47 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-12-18 17:22:22 +0300

VDVsx gravatar image

Fixed in 1.1.1.26, Vaarainjärvi, if you still have issues please comment here.

edit flag offensive delete publish link more

Question tools

Follow
4 followers

Stats

Asked: 2014-01-01 14:57:33 +0300

Seen: 240 times

Last updated: Dec 18 '14