Ask / Submit
4

xmpp with self-signed cert is not working

asked 2015-02-16 15:26:05 +0300

virgi26 gravatar image

Hello. I'm trying to connect to my xmpp server which provides self-signed cert. I've added server's and ca's certificates to /etc/pki/tls/certsaccording to answer in here https://together.jolla.com/question/2949/where-can-i-add-a-system-ca-certificate/ but i can't connect.

If i check "ignore ssl error" then it's working just fine.

That answer is old, maybe certstore moved to some other location?

edit retag flag offensive close delete

1 Answer

Sort by » oldest newest most voted
6

answered 2015-02-17 13:04:21 +0300

tigeli gravatar image

Currently only /etc/pki/tls/certs/ca-bundle.crt is read with telepathy-gabble, if we try to read all the certificates under /etc/pki/tls/certs it will lead in a situation telelepathy-gabble to consume all the memory available. In the future this problem will be solved by centralized certificate storage, but until then you can use a workaround mentioned at http://lunarius.fe80.eu/blog/category/jolla.html.

# mkdir -p /home/nemo/.config/telepathy/certs/
# cp /home/nemo/Downloads/jabber-ca_or_cert.crt /home/nemo/.config/telepathy/certs/

jabber-ca-or_cert.crt being your self-signed certificate.

edit flag offensive delete publish link more

Comments

great! that helped! thank you!

virgi26 ( 2015-02-17 13:16:52 +0300 )edit

Would this work with dukgo.com also? I couldn't get it to work.

Wizah ( 2015-05-12 14:10:41 +0300 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2015-02-16 15:26:05 +0300

Seen: 437 times

Last updated: Feb 17 '15