ActiveSync doesn't go past OPTIONS /Microsoft-Server-ActiveSync

asked 2015-02-18 11:47:19 +0300

jbruggem gravatar image

Hi,

I'm trying to set up an exchange account on my Jolla. On the Jolla, it tells me "Problem with checking credentials". On my server (using z-push / groupoffice ), I get a single line of log in the requests log:

OPTIONS /Microsoft-Server-ActiveSync HTTP/1.1" 301 4743 "-" "Jolla-AS

Anybody has a clue how I can debug this further?

edit retag flag offensive close delete

Comments

@jbruggem - you can collect the logs in the phone side.

in:

/home/nemo/.config/Nokia/activesync.conf

Enable file log and add a path for the log, like for example:

   [FileLog]
   Enabled=1
   Path=/home/nemo/Documents/as.log

Then restart device or restart as-daemon:

systemctl --user stop as-daemon
systemctl --user start as-daemon

Configure the account, wait until the sync is finished, examine the file to see if you want to remove some data, your email address, calendar entries names and folder names can be presented there, send me the logs to mail-logs at jolla dot com. After that turn file log off again by setting "enabled" to 0.Thanks a lot!

VDVsx ( 2015-02-20 09:18:30 +0300 )edit

Thanks! I'll do that ASAP

jbruggem ( 2015-02-20 11:27:07 +0300 )edit

@VDVsx I'm having trouble actually restarting the as-daemon... I'm getting:

[nemo@Jolla Nokia]$ systemctl --user start as-daemon
A dependency job for as-daemon.service failed. See 'journalctl -xn' for details.

then:

[nemo@Jolla Nokia]$ journalctl -xn
No journal files were found.

This is after the latest update (11).

jbruggem ( 2015-03-03 14:33:32 +0300 )edit