We have moved to a new Sailfish OS Forum. Please start new discussions there.
1

[Bug] Automatic Connection Switching in Yliaavanlampi 1.1.2.15 Early Access [answered]

asked 2015-02-19 19:59:28 +0300

Sailor gravatar image

updated 2015-02-19 20:11:34 +0300

Hi,

after update to Yliaavanlampi it looks like the phone does not switch data connection automatically anymore. First I get outside of my home and it didn't establish a 4G connection. I had to turn off all connections and enable them again it worked afterwards. Now I returned home and it does not switch to wifi it stays on 3G.

I see the following messages in the log:

    Feb 19 18:57:11 Jolla kernel: wlan: [4348:E :HDD] hdd_conf_hostarpoffload: 
Feb 19 18:57:11 Jolla kernel: wlan: [4348:E :SME] pmcSetHostOffload: 2507: Ignoring the indication as we are not connected
Feb 19 18:57:11 Jolla kernel: wlan: [4348:E :HDD] hdd_conf_hostarpoffload: Failure to disable host offload feature

Ok, it looks like it tried it a few times to associate and failed and never tried again. It might be due to bad signal in the garage.

Feb 19 17:58:08 Jolla kernel: wlan: connected to 10:6f:3f:26:41:a4
Feb 19 17:58:13 Jolla kernel: wlan: [509:E :TL ] Region Increase Worse RSSI
Feb 19 17:58:13 Jolla kernel: wlan: [509:E :TL ] Trigger Event 1, region index 0
Feb 19 17:58:13 Jolla kernel: wlan: [509:E :TL ]  ----> CRegion 1, hRSSI -92, Alpha 5
Feb 19 17:58:13 Jolla kernel: wlan: [507:E :TL ]  ----> CRegion 0, hRSSI -92, Alpha 5
Feb 19 17:58:13 Jolla kernel: wlan: [507:E :TL ]  ----> CRegion 1, hRSSI -92, Alpha 5
Feb 19 17:58:14 Jolla kernel: wlan: [507:E :SME] csrNeighborRoamPrepareScanProfileFilter: 947: Filtering for SSID PersonalSSID from scan results.. SSID Length = 14
Feb 19 17:58:14 Jolla kernel: wlan: [507:E :SME] csrNeighborRoamProcessScanResults: 1069: Scan result: BSSID 10:6f:3f:26:41:a4 (Rssi 91)
Feb 19 17:58:14 Jolla kernel: wlan: [507:E :SME] csrNeighborRoamProcessScanComplete: 1517: No candidate found after scanning in state 3..
Feb 19 17:58:14 Jolla kernel: wlan: [507:E :SME] csrNeighborRoamHandleEmptyScanResult: 1363: Registering DOWN event neighbor lookup callback with TL for RSSI = -79
Feb 19 17:58:14 Jolla kernel: wlan: [507:E :TL ]  ----> CRegion 2, hRSSI -92, Alpha 5
Feb 19 17:58:14 Jolla kernel: wlan: [507:E :TL ]  ----> CRegion 1, hRSSI -92, Alpha 5
Feb 19 17:58:14 Jolla kernel: wlan: [507:E :TL ]  ----> CRegion 1, hRSSI -92, Alpha 5
Feb 19 17:58:14 Jolla kernel: wlan: [507:E :SME] csrNeighborRoamPrepareScanProfileFilter: 947: Filtering for SSID PersonalSSID from scan results.. SSID Length = 14
Feb 19 17:58:14 Jolla kernel: wlan: [507:E :SME] csrNeighborRoamProcessScanResults: 1069: Scan result: BSSID 10:6f:3f:26:41:a4 (Rssi 90)
Feb 19 17:58:14 Jolla kernel: wlan: [507:E :SME] csrNeighborRoamProcessScanComplete: 1517: No candidate found after scanning in state 3..
Feb 19 17:58:14 Jolla kernel: wlan: [507:E :SME] csrNeighborRoamPrepareScanProfileFilter: 947: Filtering for SSID PersonalSSID from scan results.. SSID Length = 14
Feb 19 17:58:14 Jolla kernel: wlan: [507:E :SME] csrNeighborRoamProcessScanResults: 1069: Scan result: BSSID 10:6f:3f:26:41:a4 (Rssi 89)
Feb 19 17:58:14 Jolla kernel: wlan: [507:E :SME] csrNeighborRoamProcessScanComplete: 1517: No candidate found after scanning in state 3..
Feb 19 17:58:16 Jolla kernel: wlan: [507:E :SME] sme_QosPmcDeviceStateUpdateInd: 7172: nothing to process in PMC state 6
Feb 19 17:58:16 Jolla kernel: wlan: [507:E :TL ]  ----> CRegion 1, hRSSI -85, Alpha 5
Feb 19 17:58:18 Jolla kernel: wlan: [909:E :SME] csrRoamIssueDisassociateCmd: 6197:   reason = 0
Feb 19 17:58:18 Jolla kernel: wlan: [507:E :SME] csrNeighborRoamIndicateDisconnect: 3033: Disconnect indication on session 0 in state 2 (sub-state 12)
Feb 19 17:58:18 Jolla kernel: wlan: [507:E :TL ]  ----> CRegion 0, hRSSI -85, Alpha 5
Feb 19 17:58:18 Jolla kernel: wlan: [507:E :PE ] limSendDisassocCnf: 3798: FT Preauth Session (eebe0000,0) Cleanup
Feb 19 17:58:18 Jolla kernel: wlan: disconnected
Feb 19 17:58:18 Jolla kernel: wlan: [507:E :SME] csrNeighborRoamIndicateDisconnect: 3033: Disconnect indication on session 0 in state 1 (sub-state 0)
edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by Sailor
close date 2015-02-25 15:48:36.428424

Comments

I would need connman-logs (install connman-tracing) to see what's going on, please send output of "journalctl -b" to tigeli@jolla.com after installing the connman-tracing and reproducing the problem.

The logs which you already pasted have nothing weird on it but the RSSI is is really bad.. :)

tigeli ( 2015-02-19 21:09:26 +0300 )edit

Yep, it was in the garage. The SSID is visible their but the signal is baaaaad ;). I send you the logs as soon as I have them :).

Sailor ( 2015-02-19 21:12:18 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2015-02-25 15:48:21 +0300

Sailor gravatar image

The issue never happend again and I am not able to reproduce so I close it.

edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2015-02-19 19:59:28 +0300

Seen: 434 times

Last updated: Feb 25 '15