Ask / Submit
1

Change font doesn't work [answered]

asked 2015-02-19 21:50:23 +0300

heubergen gravatar image

updated 2015-02-19 21:51:16 +0300

I try to change my fonts under 1.1.2.15 with this how-to from here. I've copy the .ttf file to /usr/share/fonts and change my local.conf is many ways but nothing will work. Here my reduced conf-file (I've also try it with just change the name):

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
  <alias>
    <family>Sail Sans Pro Light</family>
    <prefer>
      <family>Fira Sans</family>
    </prefer>
  </alias>
  <alias>
    <family>Sail Sans Pro ExtraLight</family>
    <prefer>
      <family>Fira Sans</family>
    </prefer>
  </alias>
</fontconfig>

Try also:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
  <alias>
    <family>Sail Sans Pro Light</family>
    <prefer>
      <family>Fira Sans</family>
      <family>Roboto Light</family>
      <family>WenQuanYi Zen Hei</family>
    </prefer>
    <default><family>Sail Sans Pro Light</family></default>
  </alias>
  <alias>
    <family>Sail Sans Pro ExtraLight</family>
    <prefer>
      <family>Fira Sans</family>
      <family>Roboto Thin</family>
      <family>WenQuanYi Zen Hei</family>
    </prefer>
    <default><family>Sail Sans Pro ExtraLight</family></default>
  </alias>
</fontconfig>

Can anyone help me? Or say me what I'm doing wrong?

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by heubergen
close date 2015-02-19 22:23:36.435611

1 Answer

Sort by » oldest newest most voted
0

answered 2015-02-19 22:00:36 +0300

ssahla gravatar image

updated 2015-02-19 22:05:48 +0300

Are you trying to change the whole system font (use Fira Sans instead of Sail Sans), or just the font used for characters that are missing from Sail Sans?

The instructions you're using are for the latter case. Sail Sans will still be used, and the other fonts are only used when the appropriate character can't be found in Sail Sans.

Maybe you knew this, but just in case... :)

To replace Sail Sans altogether, you can try the hint in the first comment:

I even figured out how to change my whole system font: after adding my new font I just had to delete the default Sail Sans folder.

... or maybe renaming it might be wiser, if that does the trick.

edit flag offensive delete publish link more

Comments

thank you, I knew that the how-to ist not for the default font but I saw not the comment.

heubergen ( 2015-02-19 22:23:27 +0300 )edit

Question tools

Follow
1 follower

Stats

Asked: 2015-02-19 21:50:23 +0300

Seen: 343 times

Last updated: Feb 19 '15