Can not make calls, 'show My caller id' section greyed out

asked 2015-02-24 10:01:08 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2015-02-24 18:18:21 +0300

Spam Hunter gravatar image

Once I selected "NO" as the preference to "Show my caller Id' option in phone settings and since then the whole section is greyed out and now I am unable to make any calls. I am sure that my outgoing calls were disabled by selecting "No" to "Show my caller id" option as the problem started immediately after that.

I would like to ask if there is anything I can do to reset only 'Phone/call' setting than resetting entire phone? All I wish is to be able to make calls again.

Sailfish OS- 1.1.1.27 (Vaarainjarvi)

image description

edit retag flag offensive close delete

Comments

Hi Srirang,

EDIT: I'm also using the same OS version as you. to test, I played with the settings in mine, but I had no problems, i can still make calls no matter which option I choose.

So, my advice would be to open terminal and input this; pkcon install voicecall-ui-jolla - I'm not sure if this will solve your problem, although I feel it will, but also, it can do no harm to try.

Regards,

Spam Hunter ( 2015-02-24 15:34:02 +0300 )edit

Bad luck :( Its showing “Fatal error-failed to.obtain authentication”.

Erroe image- http://share.pho.to/8uVaF/19/original

Thanks anyways for your support Markyboy :)

Srirang ( 2015-02-24 20:19:37 +0300 )edit

try devel-su then the command.

Spam Hunter ( 2015-02-24 20:32:15 +0300 )edit

Hello! I did so, but its showing no improvement. The section is still greyed out and i hear two beeps immediately after making the call and it ends (same as before).

Here is the image with Devel-su command......

http://s7.postimg.org/4664duwm3/20150225002759.jpg

Thanks!

Srirang ( 2015-02-24 21:32:39 +0300 )edit

Did you reboot after?......I'm not sure what else to suggest. A total reset seems a little extreme, but maybe the way ahead, then if you still have the same problem after a full reset, then I would contact Jolla. Sorry I couldn't help, maybe someone with more experience here on TJC can help you, I really only know the basics, which so far have got me out of many tight spots with Jolla. Best of luck :)

Regards

Spam Hunter ( 2015-02-24 22:51:39 +0300 )edit