Ask / Submit
46

Bug: bluetooth icon still showing on lockscreen after switching off bluetooth

asked 2014-01-01 23:27:21 +0300

Neo gravatar image

updated 2014-12-02 14:05:52 +0300

After switching off bluetooth, the bluetooth icon on the lockscreen was still showing (left from the clock). It happened to me the first time, altough I use bluetooth frequently.

Has anyone had the same experience?

Switching on and off didn't resolve the problem. Rebooting did solve the problem.

EDIT 26.3.14. After update 1.0.4.20 the issue still persists.

EDIT 11.6.14. Happened again yesterday. So the issue is still there after update 1.0.7.16.

EDIT 12.08.14 Still present in 1.0.8.19

EDIT 26.09.14 This happening also when I turn on Jolla, bluetooth Icon persist without activation of this one and I can't use bluetooth transfer/receiver, I have to reboot for solve this issue because I can't turn off bluetooth

EDIT 2.12.14 Happened again today. Last I was using bluetooth was in the car. Maybe people who are experiencing the same issue could comment on what was their last use of bluetooth when it happened?

edit retag flag offensive close delete

Comments

3

i can confirm this bug... i have paired the phone to my car for call during the driver, and reached home, switched off the Bluetooth, the bluetooth icon on the lockscreen was still showing.

pizzulicchio ( 2014-01-03 00:21:38 +0300 )edit
1

@Neo@pizzulicchio To confirm there is a real bug, please confirm you didn't make the same mistake as I did (see my answer)

simo ( 2014-01-03 03:30:45 +0300 )edit
2

I confirm that I didn't make that mistake.

Neo ( 2014-01-03 03:39:30 +0300 )edit
2

Same for me, I didn't make that mistake.

pizzulicchio ( 2014-01-03 11:53:42 +0300 )edit

Good to hear from both, I hope this will get some activity to be notified by devs. Shouldn't be a difficult bug.

simo ( 2014-01-03 11:58:14 +0300 )edit

4 Answers

Sort by » oldest newest most voted
2

answered 2014-03-02 00:27:36 +0300

zlatko gravatar image

Happened to me as well. I was able to get back to normal with restarting Bluetooth: systemctl restart bluetooth.service

edit flag offensive delete publish link more
1

answered 2014-01-03 03:29:09 +0300

simo gravatar image

updated 2014-01-03 11:59:19 +0300

Check that you have the real switch in place to turn it off - I noticed that I had the bluetooth icon from the system settings menu there, and that doesn't turn off the bluetooth when pressed. To change to the right switch:

  • Settings -> System Settings -> HOLD on Bluetooth row -> remove from favourites
  • Settings -> System settings -> Bluetooth -> HOLD on bluetooth (just the text) -> add to favourites

To avoid this, I'd suggest adding small frames to the menu icons and leave the switch icon without frames.

edit flag offensive delete publish link more

Comments

thx. solved the problem for me. edit: sometimes this work sometimes it doesn't. sorry i was over enthusiastic.

Matthias ( 2014-06-02 02:12:57 +0300 )edit
0

answered 2014-01-24 14:36:30 +0300

Xurb gravatar image

I got the same issue the other day. I've turn it off and on the icon disappear and re-work as before I mean when it's activate I got the Icon when It's not I don't have the Icon.

edit flag offensive delete publish link more

Comments

Please convert your answer to comment as this is no proper answer. Thanks.

Neo ( 2014-03-01 23:54:41 +0300 )edit
0

answered 2014-06-17 09:46:12 +0300

mvdm gravatar image

updated 2014-09-26 10:13:01 +0300

I have sometimes the same problem icon stay active and blutooth is off, a restart did not solve the problem,

I use now Quick BT on/off from openrepos works very well and no problem from now.

I'm not specialist but maybe a jolla specialist can see how it's working thanks @Shturman !

Edit : Still the problem appears :-(, so this did'nt solved it sorry

edit flag offensive delete publish link more

Comments

I can confirm the problem still persists even with the latest update. and yeah the only way to resolve it is to restart the Bluetooth service.

droll ( 2014-09-26 10:48:36 +0300 )edit
1

same here... But restart bluetooth.service only hide this icon from the lockscreen. but if you start bt again you will see this white icon (activated) again without connect to the other device. Only reboot clean it...

Schturman ( 2014-09-26 12:05:34 +0300 )edit

thanks shturman hope solved in next update ?

mvdm ( 2014-09-26 12:19:04 +0300 )edit
Login/Signup to Answer

Question tools

Follow
7 followers

Stats

Asked: 2014-01-01 23:27:21 +0300

Seen: 1,212 times

Last updated: Dec 02 '14