Ask / Submit
60

[Implemented in 1.0.7.16] Nokia HERE - Unit System in maps? [released]

asked 2013-12-25 01:15:44 +0300

petros gravatar image

updated 2014-06-10 14:43:57 +0300

Neo gravatar image

I have my jolla in English but I am used to count distances in Km but maps show me distances in yards! Any way to change it?

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by Neo
close date 2014-06-10 14:16:43.200218

Comments

1

www.youtube.com/watch?v=4ruB94yz-7w @3:10

The march update will fix this.

ApB ( 2014-03-09 18:23:03 +0300 )edit
3

The 'Settings → Apps → Maps → Distance units Based on location / Metric / Imperial' seen in the video linked above obviously didn't make it to the 1.0.4.20 update, and I understand that it's deeply buried together with all the other should-have-been-separated-instead-of-bundled-but-we-realised-this-too-late region settings, but I hope it's being worked on, and not forgotten ... ?

phle ( 2014-03-22 19:29:51 +0300 )edit
1

After Paarlampi still no way to change distance units. Is it there any chance to see it implemented?

magullo ( 2014-04-16 14:17:18 +0300 )edit

2 Answers

Sort by » oldest newest most voted
32

answered 2013-12-25 01:19:06 +0300

Aard gravatar image

This is related to a design flaw currently tying region settings to the language used. We are working on fixing that.

See http://www.jollatides.com/2013/12/16/how-to-tweak-jolla-system-locale/ for a workaround for now.

edit flag offensive delete publish link more

Comments

2

Good question, and I was just about to reply with link to my Jolla locale tweaking howto (@Aard was quicker) that provides us a way to play with language / localization settings, that aren't yet featured in Jolla System Settings. Hopefully we get them soon, and apps that respect LC-env variables ;)

foss4ever ( 2013-12-25 04:37:24 +0300 )edit
2

True, for instance logging with ssh should follow the LC_(variable) settings imported from the client.

simosagi ( 2013-12-25 09:52:50 +0300 )edit

Workaround works, but I'm getting infomessages at ssh login now:
NOTICE: Env value ignored LC_MEASUREMENT=de_AT.UTF-8
address settings not working as expected, still get "$number $streetname" with de_AT

kelvan ( 2014-01-09 17:51:34 +0300 )edit

@kelvan Yes I provided that workaround in JollaTides and.if you read the comments.there and my reply to this bash login shell warnings you'll see that it is nothing to worry about. Glad to be of help ;)

foss4ever ( 2014-01-09 22:42:41 +0300 )edit

@Aard Could.you also.give us answer to this.question: https://together.jolla.com/question/931/enable-more-refined-locale-settings-that-are-respected-by-system-and-3rd-party-apps/ where this locale setting problem has been more properly addressed. Thanks ;)

foss4ever ( 2014-01-09 23:15:13 +0300 )edit
5

answered 2014-06-10 14:14:36 +0300

Neo gravatar image

Solved in update 1.0.7.16

Settings > Apps > Maps > Distance units

edit flag offensive delete publish link more

Comments

Maps not enabled in Settings > Apps on my phone.

axaq ( 2014-06-13 02:29:27 +0300 )edit

Did you update the Maps app lately?

Neo ( 2014-06-13 02:33:14 +0300 )edit

Updated to 1.0.7.16. some days ago and device restarted. Just checked My Apps in Jolla Store App. No updates available. After the check I restarted Settings again and now I got Settings > Apps > Maps. Will check Settings later if it disapears again ...

axaq ( 2014-06-13 02:43:45 +0300 )edit

Question tools

Follow
6 followers

Stats

Asked: 2013-12-25 01:15:44 +0300

Seen: 1,560 times

Last updated: Jun 10 '14