We have moved to a new Sailfish OS Forum. Please start new discussions there.

Flight mode is not enforced after reboot

asked 2014-01-01 23:51:50 +0300

Naranek gravatar image

updated 2014-01-02 13:37:35 +0300

llornkcor gravatar image

Steps to reproduce: 1. Enter flight mode 2. Shut down phone 3. Start phone Flight mode symbol is still in the status area, but the phone can receive calls and seems to connect to a wireless network.

This is bad, because you are supposed to put the phone in flight mode before the flight and turn it off for the take off. If the phone doesn't stay in flight mode, you can't turn it off in the airplane.

Software version is

edit retag flag offensive close delete


Can't reproduce. At step 3, the phone doesn't show the flight mode symbol.

Neo ( 2014-01-02 00:00:52 +0300 )edit

Confirmed here. On reboot the phone initially shows flightmode but a few seconds after the wireless enables itself as does the cellular network.

steph ( 2014-01-02 00:01:11 +0300 )edit

Neo: I had that happen as well on another try. The result is the same, as you suddenly have all your radios on in a plane.

Naranek ( 2014-01-02 00:19:40 +0300 )edit

Flight mode should stay as flight mode. Although I understand that the designer probably thought, it is a good idea not to hazzle people when they switch on their phone and do not have any connections: You may output a warning message, but do not switch on any radios automatically!

jgr ( 2014-01-02 04:47:54 +0300 )edit

How did you shutoff the phone? power button or pulling the battery?

llornkcor ( 2014-01-02 13:36:51 +0300 )edit

1 Answer

Sort by » oldest newest most voted

answered 2014-01-25 03:53:11 +0300

llornkcor gravatar image

There is a bug entry for this, and will be fixed in a future update.

I can confirm that flight mode works as it should when android support is not installed.

edit flag offensive delete publish link more


Just tested this with my phone and switched to Flight mode, rebooted.(power off/on from button) and phone started with Flight node on. And didn't try to open any connections. Not even when I started the browser. Everything works as expected. And I have the Android support installed. So seems that it is not related to that at all.

foss4ever ( 2014-01-25 09:42:26 +0300 )edit
Login/Signup to Answer

Question tools



Asked: 2014-01-01 23:51:50 +0300

Seen: 554 times

Last updated: Jan 25 '14