SMTP with self signed certificate and CardDAV with owncloud not working

asked 2015-03-03 15:52:19 +0300

grossmaggul gravatar image

updated 2015-03-03 15:59:21 +0300

raketti gravatar image

I tried to setup both of these from the topic but I can't get it to work. SMTP always says that there's something wrong with login, is there a log on the Jolla where I can look what is going wrong or should I look in the smtp server? It's a pity that in newer SailFish versions it isn't possible to edit SMTP server settings after setting it up and saved. Same with CardDAV/CalDAV accounts, once created there is no possibility to edit it again. So we come to cardDAV on an owncloud server, it does not work, I put the servername and the path in the right place, but there's no synchronisation. Tried various server/path slash variations, no luck. AFAIR this doesn't work in former SailFish OS version, too, when will this be fixed or am I doing something wrong?

I use version 1.1.2.16

edit retag flag offensive close delete

Comments

1

CardDav works with owncloud and self-signed certificates. I am not sure what version of the buteo-sync is in the latest version of Sailfish, but with update 10 I had to do the following: - go to the github, download the latest buteo carddav, compile and install it - copy my self-signed certificate to the phone in the certificates directory (and create the symlink) And that's it.

I don't know about the SMTP problem you have.

dioog ( 2015-03-03 16:35:18 +0300 )edit

O.K., thank you, I will try this.

grossmaggul ( 2015-03-05 11:35:42 +0300 )edit

We apparently fixed support for self-signed certificates in CalDAV (via the ignore_ssl_errors account setting) but did not fix it in CardDAV. This issue will be resolved shortly: https://github.com/nemomobile/buteo-sync-plugin-carddav/pull/12

chris.adams ( 2015-03-06 05:44:08 +0300 )edit

The problem I have with CardDAV is not the self-signed certificate. It just don't synchronize with my CardDAV owncloud account. The self-signed certificate problem is with SMTP.

grossmaggul ( 2015-03-06 10:59:22 +0300 )edit

@grossmaggul - this is a known issue and apparently the fixes regarding ownCloud CardDav sync didn't make it to the latest U11, I'm trying to help as much as I can with my limited knowledge of Jolla to solve this issue. If you can, please send logs to @chris.adams as stated in this post..

And as a side note, if you do, RateLimitInterval in /etc/systemd/journald.conf should to be increased to 60 seconds, to get proper logs.

raketti ( 2015-03-06 11:03:03 +0300 )edit