Ask / Submit
6

ownCloud CardDav sync under 1.1.2 [duplicate]

asked 2015-03-03 18:56:43 +0200

Groucho gravatar image

updated 2015-04-27 11:44:02 +0200

eric gravatar image

Hello,

over the recent weeks some comments made me believe CardDav would work with the new update. I've tried all kind of settings, but did not succeed. Could anybody sync Contacts with Owncloud under 1.1.2?

edit retag flag offensive reopen delete

The question has been closed for the following reason "duplicate question" by Groucho
close date 2015-03-06 18:34:51.025882

Comments

1

I'll report as soon as I've finished with my account setup and sync. EDIT: Nope. CardDav won't sync either way. I find it funny that in return, Google Contacts work flawlessly.

raketti ( 2015-03-03 19:11:43 +0200 )edit

Can you give details? Not all of the fixes for CardDAV support made it into the most recent update, unfortunately, however some did. Depending on your setup, you should have made some progress.

Can you try: 1) Create an account with ONLY CardDAV enabled (ie, disable CalDAV) 2) ssh into your device and do:

$ systemctl --user stop msyncd
$ killall msyncd
$ MSYNCD_LOGGING_LEVEL=8 devel-su -p msyncd

3) log into the device via ssh again, different terminal, and run:

$ journalctl -af | grep carddav

4) trigger sync via settings|accounts|longpress-sync in context menu

5) send the logs to chris dot adams at jolla dot com

Any information you can provide would be useful.

Thanks, Chris Adams.

chris.adams ( 2015-03-04 06:20:36 +0200 )edit

@chris.adams - I do have the developer mode set, but I don't know if I can devel-su anything, because I haven't set up a password. However I can ssh to my Jolla. So, do I need to take some extra steps or is it sufficient that I only have the developer mode and ssh active? If not, the I can get those logs for you this evening, say 8 PM (+2 GMT). EDIT: Steps 1 and 2 I think went as expected, step 3 says:

$ journalctl -af | grep carddav
No journal files were found.

I sent the log files, hopefully they are of some use. :)

raketti ( 2015-03-04 08:38:14 +0200 )edit

Urgh, sorry - the third one needs devel-su also:

$ devel-su journalctl -af | grep carddav

And actually, it seems like that's the one which will contain the interesting information.

chris.adams ( 2015-03-05 03:27:29 +0200 )edit

@chris.adams - no problem, to be honest as a linux user, should have figured that out by myself. I'll get the second log later this evening. Thanks for the support! :)

raketti ( 2015-03-05 09:34:45 +0200 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2015-03-06 17:04:51 +0200

Yo gravatar image

I was able to send some logs to jolla and got a respond:

The error from userInformationResponse is 6, which is QNetworkReply::SslHandshakeFailedError. It looks like we don't correctly ignore SSL errors in some cases, as we should according to the flag setting.

And also:

I will fix this one, thanks very much for your help.

So it seems this (or my) particular problem is with self-signed certificates and sailfish OS not respecting the flag to ignore SSL errors.

edit flag offensive delete publish link more

Comments

To work around this, get a free valid certificate from http://www.startssl.com/. You will spend some time to get it right. Find a good guide on the net, and follow instructions for your distro. I think you will not spend more time than what you would debugging errors due to self-signed certs. Best wishes.

martinrusler ( 2015-03-06 17:55:17 +0200 )edit

Yeah, the same thing I thought about. I don't wont to send them a mail or something like that, just hope they will see the issue.

heubergen ( 2015-03-06 18:00:05 +0200 )edit

For me this is not a solution as I'm not using a self signet sertificate, I have my ownCloud set up on a "rented" server. Is there some permission issues that could prevent the sync from working?

raketti ( 2015-03-06 18:00:40 +0200 )edit

@martinrusler If I do have a "valid" certificate or not is not the question. If the UI gives the option to "ignore SSL errors" then it should do that. BTW: My certificate is valid, it's just not trusted by Jolla (NOT an error). I for my part could very easily say if this certificate was trustworthy if its fingerprint was presented to me before saying "yes, this is it". But this is another point...

@heubergen I sent the email to jolla because they asked for more information.

Yo ( 2015-03-06 20:25:56 +0200 )edit

@raketti Did you try the steps described here? Do you also get

Jolla carddav-client[10443]: [W] CardDav::userInformationResponse:307 - void CardDav::userInformationResponse() error: 6 ( 0 )

when running devel-su journalctl -af | grep carddav?

If not you should probably send your output to chris as well.

Yo ( 2015-03-06 20:31:38 +0200 )edit
0

answered 2015-03-03 20:36:35 +0200

Groucho gravatar image

Sorry, Not a duplicate. I understand the intention of 1.1.2 was to improve carddav.the"duplicate"was before 1.1.2. Thus the ongoing unanswered questions stays: does cardiac work with o'clock under 1.1.2?

edit flag offensive delete publish link more

Comments

I have the regular early access to the newer update so I could test it some days before and it doesn't work under 1.1.2.

heubergen ( 2015-03-03 20:38:31 +0200 )edit

This is still a duplicate, because the issue hasn't been resolved and the CardDav question is open and tagged with the latest update. There's no use in opening yet another topic.

raketti ( 2015-03-03 20:52:50 +0200 )edit

Since it's confirmed (by heubergen) that it's not working under 1.1.2 the issue is still open and thus I'd agree with the duplicate. Still wondering about some statements that it would be addressed with this update.

Groucho ( 2015-03-03 20:56:37 +0200 )edit

@Groucho - I also commented that the CardDav doesn't work (to the OP). Should have maybe stated that I too am using the early access updates. It's stated in the release notes that CalDav and CardDav are in experimental stage. So they are still working with the issue. My suggestion is to follow the post @heubergenlinked and close this one.

raketti ( 2015-03-03 21:00:27 +0200 )edit
1

CalDAV and CardDAV has been in "experimental stage" in Sailfish since before version 1.0. It's about time they make some serious effort to make this work with ownCloud. I would think that would be well invested time, given the audience (us).

martinrusler ( 2015-03-03 23:43:41 +0200 )edit
0

answered 2015-03-03 20:24:50 +0200

heubergen gravatar image

updated 2015-03-03 20:26:00 +0200

Duplicate of https://together.jolla.com/question/83820/carddav-doesnt-work/

You could make to work it with the SyncEvolution App (found here, how to here)

edit flag offensive delete publish link more

Question tools

Follow
6 followers

Stats

Asked: 2015-03-03 18:56:43 +0200

Seen: 1,027 times

Last updated: Mar 06 '15