Ask / Submit
100

Bug: Google account logout notifications keep re-appearing

asked 2013-12-25 02:05:18 +0200

Kondou gravatar image

updated 2014-02-11 21:47:50 +0200

foss4ever gravatar image

Sometimes a google account you have, logs itself out after some time.

I had a good test around and could specify my problem:

When I try to use my google account for gtalk it logs itself immediatly out, when I try to go online, resulting in me having to log in/authorize again.

If I'm not using gtalk everything just works fine with this account.

I also tried another google account, with which I'm only using gmail. There gtalk worked just fine (though it wasn't really usefull …).

I had a look at the systemlog, and when trying to log in to gtalk, thus the account logging itself out, it spat out this:

Dec 28 06:32:31 localhost dbus-daemon[939]: Activating service name='org.freedesktop.Telepathy.ConnectionManager.gabble'
Dec 28 06:32:31 localhost dbus-daemon[939]: Successfully activated service 'org.freedesktop.Telepathy.ConnectionManager.gabble'
Dec 28 06:32:36 localhost dbus-daemon[939]: Activating service name='com.google.code.AccountsSSO.SingleSignOn'
Dec 28 06:32:36 localhost signond[20155]: signondaemon.cpp 360 init Failed to SUID root. Secure storage will not be available.
Dec 28 06:32:36 localhost dbus-daemon[939]: Successfully activated service 'com.google.code.AccountsSSO.SingleSignOn'
Dec 28 06:32:36 localhost dbus-daemon[939]: SailfishKeyProvider_ini_read: reached end of file
Dec 28 06:32:36 localhost dbus-daemon[939]: SailfishKeyProvider_ini_read: reached end of file
Dec 28 06:32:37 localhost contactsd[1228]: [W] Tp::Debug::invokeDebugCallback:149 - tp-qt 0.9.3 WARN: Nested PendingReady for true failed with "org.freedesktop.Telepathy.Error.AuthenticationFailed" : "WOCKY_AUTH_ERROR_FAILURE (#6): Authentication failed: not-authorized"  
Dec 28 06:32:37 localhost contactsd[1228]: [W] Tp::Debug::invokeDebugCallback:149 - tp-qt 0.9.3 WARN: Building connection "/org/freedesktop/Telepathy/Connection/gabble/jabber/gmail_2ecom_2f9e86d18e_5f0x11aa058" failed with "org.freedesktop.Telepathy.Error.AuthenticationFailed" - "WOCKY_AUTH_ERROR_FAILURE (#6): Authentication failed: not-authorized"  
Dec 28 06:32:37 localhost contactsd[1228]: [W] Tp::Debug::invokeDebugCallback:149 - tp-qt 0.9.3 WARN: StatefulDBusProxy::uniqueNameFrom(): Failed to get unique name of "org.freedesktop.Telepathy.Connection.gabble.jabber.gmail_2ecom_2f9e86d18e_5f0x11aa058"  
Dec 28 06:32:37 localhost contactsd[1228]: [W] Tp::Debug::invokeDebugCallback:149 - tp-qt 0.9.3 WARN:   error: "org.freedesktop.DBus.Error.NameHasNoOwner" message: "Could not get owner of name 'org.freedesktop.Telepathy.Connection.gabble.jabber.gmail_2ec
edit retag flag offensive close delete

Comments

6

The "Not logged in" / log in again / works for some time / "Not logged in" / etc. happens to me, too, and I'm using a Google account with GMail. It's really annoying as to log back in you need to re-type your credentials every time!

donaggio ( 2013-12-27 12:58:51 +0200 )edit
6

Confirming the "Not logged in" and need to re-authenticate problem with the Google account, and still present in 1.0.2.5. I've logged it with care@jolla.com but the case is not yet assigned to anyone (as indeed none of my cases are), which is disappointing.

Milhouse ( 2013-12-28 18:34:04 +0200 )edit
1

Google.account logout happens also in other cases than when usng gtalk. Today I just left my phone unused with mail app on in WiFi connection state, and after 5 houts when I returned to my phone there was a notification that Google acc is not in use.In Settings > Accs > Google it said that the acv is not signed in, and I had to type my credentials as describef by @Milhouse. Now, could the question of this bug-report be changed to nore general one so that this behavioir (outside gtalk usage would fit in)? How about ”[Bug] Google account automatically or erroneously logs out”

foss4ever ( 2013-12-29 13:22:23 +0200 )edit

re-tag: added synccause it has been confirmed to be one (the only one maybe?) of the services in Google acc setup that causes these re-appearing notifications and partial/false sign-outs.

foss4ever ( 2014-02-11 21:51:48 +0200 )edit

I don't have anything except gtalk/IM activated and I'm still being logged-out.

Kondou ( 2014-02-11 21:56:30 +0200 )edit

13 Answers

Sort by » oldest newest most voted
25

answered 2013-12-29 13:40:13 +0200

stezz gravatar image

updated 2013-12-29 13:40:30 +0200

Thank you @Kondou, this is a known bug that has been under investigation since roughly 3 months. Pretty difficult to spot and debug, let me tell you :D

We have a possible fix available in testing that we were not yet confident to include in this release. If everything goes fine we will release it in the next update.

@Milhouse rest assured that we are working on the issue.

edit flag offensive delete publish link more

Comments

I wish it was that difficult to spot for me, as this happens every time I try to use gtalk x)

Good to know you're on this!

Kondou ( 2013-12-29 13:43:23 +0200 )edit

I see you are in germany... was there a different domain for google servers?

stezz ( 2013-12-29 13:47:41 +0200 )edit

Different domain?

Google's german domain is google.de, but I'm not using a @gmail.de adress for logging into google, but my own domain's email.

Kondou ( 2013-12-29 13:51:54 +0200 )edit

Excellent thanks. It happens several times a day for me - in fact I've stopped re-authenticating now as email continues to work and that's the most important thing, the rest I can live without (for now).

Milhouse ( 2013-12-29 15:30:08 +0200 )edit
1

@Milhouse in the bug we are working on both Gtalk and Email remain functional even though the account is reported as not authenticated. Starting to suspect this is a different flavor of the same bug.

stezz ( 2013-12-29 15:43:22 +0200 )edit
8

answered 2013-12-29 18:23:11 +0200

stezz gravatar image

Ok so we have a probable fix for @Milhouse problem. We need to test @Kondou problem.

edit flag offensive delete publish link more

Comments

Happy to be a beta beta tester! :)

Milhouse ( 2013-12-30 00:57:53 +0200 )edit

I'm happy that Jolla is tring to solve this problem. As someone who don't have Facebook and whose XMPP account doesn't work on Jolla (different problem with unknown certificate), I don't have any other mean of communicating via Internet than Google Chat.

garretraziel ( 2013-12-30 14:23:32 +0200 )edit
1

Just wanted to update that the fix will be included in the next OS release to be rolled out pretty soon.

stezz ( 2014-01-29 21:41:19 +0200 )edit
1

FYI: Google acc logout notifications still apoear in 1.0.3.8 and the account status in Settings > Accounts is signed out.. so the bug has not been resolved even if so stated in Release.Notes of.1.0.3.8.

foss4ever ( 2014-02-02 21:30:46 +0200 )edit

Drat, replied to the wrong answer... @stezz, the "probable fix" doesn't appear to have worked, I'm still getting signed out and needing to re-authenticate with 1.0.3.8. No big deal as email still seems to work, which is the main thing.

Milhouse ( 2014-02-03 20:51:46 +0200 )edit
3

answered 2014-06-17 17:10:32 +0200

I still have that problem in Saapunki.

edit flag offensive delete publish link more

Comments

I had the same issue in Saapunki, too. Once so far.

pycage ( 2014-06-17 20:58:25 +0200 )edit

Same for me. Before Saapunki it wasn't so often, now it happens at least twice a day.

abbra ( 2014-06-25 10:11:52 +0200 )edit
2

still suffering from the bug using Tahkalampi :( but not very often hopefully (like once every two/three weeks or so) I am not using Messaging so not related to that: I 'only' sync calendars (3), mails and contacts, using two-way sync, and with a personalized & automatic sync too... And only one google account (plus Jolla account and one de-activated XMPP).

pat_o ( 2014-09-09 11:48:00 +0200 )edit
1

I can confirm this bug is still present on Tahkalampi. Seeing with gTalk activated and deactivated.

Béné ( 2014-12-13 15:10:33 +0200 )edit
2

answered 2014-02-03 01:57:57 +0200

chris.adams gravatar image

updated 2014-02-03 06:09:03 +0200

This should be fixed in the latest update - if the problem continues, please let us know.

/edit: that is, the "gtalk causes apparent logout" issue, should be fixed, with the latest update. The "different domain" issue is probably a different, unrelated one - if that problem persists, please let us know.

edit flag offensive delete publish link more

Comments

What is update3 and is this answer official confirmation that the erroneous notifications of Google acc logouts are to be fixed? As commented above the issue is still present in 1.0.3.8.

foss4ever ( 2014-02-03 04:19:19 +0200 )edit

jjaone: can you give more information about your particular case? 1.0.3.8 is the update I was referring to. Are you using a normal @gmail.com account, or do you have your own domain (via Google Business etc)? Which services do you have enabled? Does email sync still work? Does gtalk still work?

chris.adams ( 2014-02-03 06:10:42 +0200 )edit
2

I have s normal.gmail.com.acc, and have Google acc, Twitter, FB, and Jolla accs setup. The issue has been the same from before 1.0.2.5 tjat once or twice a day the Google acc logout notification is displayed and when going to Settings >.Accounts >.Google it says 'Not signed in'. All the time email sync works, and I can send and receive emails. Havet used GTalk at all, so this has nothing to do with that. Notification can be cleared but then it soon appears again. Same happens if I sign-on to Google then also the notification appears again after some hours (and quite random times). Still present in 1.0.3.8 just as described. This is IMO the original issue report here and has been confiirmed by many.. (see e.g. the first comment by @donaggio).

foss4ever ( 2014-02-03 07:20:26 +0200 )edit

Maybe it's too early to say, but it does seem to be solved for me: since the update I haven't experienced any disconnection from my Google accounts (one "regular" and one from Google Apps with my company domain). Let's see.

donaggio ( 2014-02-03 11:49:29 +0200 )edit
3

But with just one regular Google acc it has happened to me already several times in two day. Should I now post a new question with this exact description cause seems that all the other variants of this bug have been resolved?

foss4ever ( 2014-02-03 13:51:40 +0200 )edit
2

answered 2014-02-12 03:08:21 +0200

chris.adams gravatar image

The next update should include a change which makes the Google data sync adapter less zealous in assuming that authentication errors are due to oauth2 token problems (as they can, for example, be due to captive portals, or perhaps even clock drift if NTP isn't doing its thing properly). This should minimise the warnings emitted.

Regarding the transfers entries - it's possible that email synchronization is being listed there. Email synchronization is done separately to calendar/contacts sync.

I hope the next update will resolve this issue adequately, but I'll definitely keep a close eye on this thread ;-) Thanks for your help tracking these things down, both of you - greatly appreciated.

edit flag offensive delete publish link more
2

answered 2014-04-16 18:22:11 +0200

Larswad gravatar image

updated 2014-04-16 18:54:59 +0200

I still have the problem in Paarlampi (freshly installed from factory reset yesterday, but with restored accounts), here is my system log:

EDIT, IMPORTANT UPDATE: I don't know if I should feel stupid or not, but I was using google and google plus with an own email address (never created a gmail address before, never wanted to). So I did now create a google mail account which became my primary google mail address and after that the authentication works. So it is an important thing to be aware of: The email address being authenticated to with google has to be a REAL gmail address, nothing else. Don't know if this was the only issue, but now things work. Maybe only real gmail addresses can be associated with online status and stuff...probably so.

Apr 16 17:17:40 Jolla dbus-daemon[972]: Activating service name='org.freedesktop.Telepathy.ConnectionManager.gabble'
Apr 16 17:17:40 Jolla dbus-daemon[972]: Successfully activated service 'org.freedesktop.Telepathy.ConnectionManager.gabble'
Apr 16 17:17:41 Jolla ofonod[879]: voice registration status is 1
Apr 16 17:17:41 Jolla ofonod[879]: voice registration status is 1
Apr 16 17:17:43 Jolla dbus-daemon[972]: Activating service name='com.google.code.AccountsSSO.SingleSignOn'
Apr 16 17:17:43 Jolla signond[1681]: signondaemon.cpp 360 init Failed to SUID root. Secure storage will not be available.
Apr 16 17:17:43 Jolla dbus-daemon[972]: Successfully activated service 'com.google.code.AccountsSSO.SingleSignOn'
Apr 16 17:17:43 Jolla dbus-daemon[972]: SailfishKeyProvider_ini_read: reached end of file
Apr 16 17:17:43 Jolla dbus-daemon[972]: SailfishKeyProvider_ini_read: reached end of file
Apr 16 17:17:43 Jolla contactsd[1271]: [W] Tp::Debug::invokeDebugCallback:149 - tp-qt 0.9.3 WARN: Nested PendingReady for true failed with "org.freedesktop.Telepathy.Error.AuthenticationFailed" : "WOCKY_AUTH_ERROR_FAILURE (#6): Authenticat...d: not-authorized"
Apr 16 17:17:43 Jolla contactsd[1271]: [W] Tp::Debug::invokeDebugCallback:149 - tp-qt 0.9.3 WARN: Building connection "/org/freedesktop/Telepathy/Connection/gabble/jabber/gmail_2ecom_2fJolla_5f0x1f19058" failed with "org.freedesktop.Telepa...d: not-authorized"
Apr 16 17:17:43 Jolla invoker[1316]: QDBusConnection: name 'org.freedesktop.Telepathy.Connection.gabble.jabber.gmail_2ecom_2fJolla_5f0x1f19058' had owner ':1.549' but we thought it was ''
Apr 16 17:17:43 Jolla contactsd[1271]: [W] Tp::Debug::invokeDebugCallback:149 - tp-qt 0.9.3 WARN: Nested PendingReady for true failed with "org.freedesktop.DBus.Error.NameHasNoOwner" : "Could not get owner of name 'org.freedesktop.Telepath...58': no such name"
Apr 16 17:17:43 Jolla contactsd[1271]: [W] Tp::Debug::invokeDebugCallback:149 - tp-qt 0.9.3 WARN: Building connection "/org/freedesktop/Telepathy/Connection/gabble/jabber/gmail_2ecom_2fJolla_5f0x1f19058" failed with "org.freedesktop.DBus.E...58': no such name"
Apr 16 17:17:43 Jolla jolla-signon-ui[1264]: [D] Accounts::Account::Private::account_store_cb:551 - account.cpp: 551 account_store_cb Saved accunt ID: 7
Apr 16 17:17:43 Jolla jolla-signon-ui[1264]: [W] AccountChangeListenerWorker::accountSynced:183 - "jolla-signon-ui: CredentialsNeedUpdate now true.  From: telepathy-sasl-signon.  Notification currently exists: true"
Apr 16 17:17:43 Jolla jolla-signon-ui[1264]: [W] QCoreApplication::postEvent:1218 - QCoreApplication::postEvent: Unexpected null receiver
Apr 16 17:17:48 Jolla dbus-daemon[972]: tp-glib-Message: Exiting
edit flag offensive delete publish link more

Comments

I still do as well, there has been no statement about this being fixed though. Thought about creating a google-account that one can reproduce this with for jolla-testers.

Kondou ( 2014-04-16 18:55:26 +0200 )edit

Did you have the same account, like me, a google account that was not a real gmail address, but associated with a mail address external to google? If that's the case, I guess its the problem.

Larswad ( 2014-04-16 19:13:34 +0200 )edit

Yup, I do. But weren't we on this earlier before?

Kondou ( 2014-04-16 19:20:52 +0200 )edit
2

answered 2015-01-10 15:56:02 +0200

rihmeld gravatar image

The same issue is still valid for Vaarainjärvi (1.1.1.27). I have two Gmail account. One uses 2 step verification and is Google business account another one is my personal account without 2 step verification. Still getting the "Not signed in" message under accounts - 20150109235614.jpg

edit flag offensive delete publish link more

Comments

Yes I can confirm issue still exists in 1.1.1.27 google account keeps asking for reauthentication about daily. Also it seems to create an additional calendar in calendars at some reauths, not all. So using google calendar as your default calendar is impossible as you never know which google calendar you should add your entries to.

pmakkone ( 2015-01-26 10:21:10 +0200 )edit

Just adding my two cents, I also have this issue in 1.1.1.27. However, I can't replicate duplicate calendars issue mentioned above. My Google account doesn't use 2 step verification.

chipmonk ( 2015-01-28 10:40:14 +0200 )edit
1

Same "not signed in" issue even in Yliaavanlampi 1.1.2.16. Totally random. The odd thing is that syncing still works since I keep receiving emails and calendar entries sync fine both ways.

spidernik84 ( 2015-03-02 22:02:32 +0200 )edit

Yes, in this bug, the flag is usually raised in a case where a software component mistakes a network error (eg, when wifi drops out or something) during sync, as an authentication error from Google. We have investigated some cases where we have error handling and improved them to make sure we deal with network errors correctly, however I can't guarantee that we've found and fixed all of them yet.

Note that while the network error will result in that one single sync failing, subsequent syncs will continue to work correctly, which explains the behaviour you're seeing.

With luck the recent fixes will resolve this issue for you (should be released in the upcoming update), but we will continue to investigate this issue as more information becomes available.

Cheers, Chris.

chris.adams ( 2015-03-11 03:43:45 +0200 )edit
2

answered 2015-03-09 11:36:06 +0200

rburkhanov gravatar image

updated 2015-03-09 11:44:53 +0200

Making this an answer just to bring the question back to the discussion. Does this problem is going ever to be solved? It's more then a year now since we were told the bugfix is coming. I'm using now update 1.1.2.16 and the problem is still here. Have to reenter Google password 3 times a day in average. Does it has any priority status? Does it has any status at all? The latest official comment on it seems to be of February 2014 - which is not very promising to me.

edit flag offensive delete publish link more

Comments

Effort has been spent recently to try to resolve this issue again. Improved logging was added to various components to try to narrow down the specific circumstances under which the "logged out" flag gets erroneously raised. Also, a bug was fixed in the periodic signon component, where previously it compared error values against an older, deprecated error set (see https://github.com/nemomobile/buteo-sync-plugins-social/commit/47efc63beb2d2c9d95d4e707ef08a0c83a682f77 for that fix), which may fix the issue in some cases.

In general, this one has proven tricky to resolve simply because it's not easily reproducible. People who hit the bug often have identical setups to people who have never seen the bug at all. It's a byzantine bug with no simple solution, but more likely the bug results from complex interactions between a variety of software components which, in some usage patterns, results in the erroneous behaviour.

Rest assured that we're doing what we can to follow up on this one, as more information becomes available.

Cheers, Chris.

chris.adams ( 2015-03-11 03:39:54 +0200 )edit

@chris.adams Thanks for the info! That's better then nothing. Would be waiting for any solution.

rburkhanov ( 2015-03-11 09:17:00 +0200 )edit
2

answered 2016-03-12 14:15:54 +0200

palikao gravatar image

updated 2016-03-12 14:24:53 +0200

The problem still -often- occurs with 2.0.0.10 release.. What about 2.0.1.7 EA?

edit flag offensive delete publish link more

Comments

Can you provide details of your account - do you use two-factor authentication, or single-step oauth2? What services do you have enabled? What usage patterns seem to trigger the event (e.g., due to oauth2 access token delegation semantics, tokens will be expired by the server after some period of time, so if your device is offline for multiple days in a row, then this signout behaviour is expected and unavoidable, without using long-expiry (so called "offline") keys)?

Can you provide journal / logs from the device? devel-su journalctl -b | grep CredentialsNeedUpdate should give some useful information for me to track down what is raising the notification, at least.

chris.adams ( 2016-03-16 05:23:29 +0200 )edit
1

answered 2015-04-20 16:15:29 +0200

evo3de gravatar image

Are there some news or updates by the Google Auth problem?

This is annoying

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
13 followers

Stats

Asked: 2013-12-25 02:05:18 +0200

Seen: 3,081 times

Last updated: May 31 '16