We have moved to a new Sailfish OS Forum. Please start new discussions there.
0

Email (IMAP) access to Apple iCloud not working after Yliaavanlampi upgrade [1.1.2.16] [answered]

asked 2015-03-04 23:27:25 +0300

CB gravatar image

updated 2015-03-05 11:08:29 +0300

Apple Cloud email account (IMAP) working fine before upgrade to Yliaavanlampi, now refuses to connect, reporting "Unable to Sign On".

I have deleted account, deleted email app, re-installed email add and created account from scratch, reports "Problem with authentication" when trying to connect to account.

I have two Jolla handsets, the other remains on 1.1.1.27 Vaarainjarvi and continues to connect to the same Apple Cloud email account with no problems.

I can see that a similar issue has been raised and closed ( https://together.jolla.com/question/84739/email-imap-access-to-apple-icloud-not-working-under-112/ ) but there is nothing in the closure that helps - I have tried all varieties of account domain name (@mac.com, @me.com, @icloud.com). Suspect the issue may be a consequence of this Yliaavanlampi change: https://together.jolla.com/question/4336/email-cannot-log-in-to-macos-imap-server/ .

Anyone have any ideas or guidance here. Am happy to help with debugging

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by VDVsx
close date 2015-03-05 08:49:37.594862

Comments

1

Its not a Bug, its a feature since Apple is crap ;)

NuklearFart ( 2015-03-05 00:20:05 +0300 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2015-03-05 08:01:55 +0300

appelgriebsch gravatar image

It works fine on my Jolla phone w/ latest SailfishOS. But I have just set up the mail account AFTER upgrading the OS.

something strange I noticed:

  • for IMAP server you have to state your username w/o the domain extension (e.g. myuser instead of myuser@icloud.com), use SSL on default port (993)
  • for SMTP you have to state the complete username w/ domain extension, also change enc. to STARTTLS and port to 587

if you use two-factor authentication with your Apple ID you also need to create a application-specific password

edit flag offensive delete publish link more

Comments

Yup that's correct, just like in Apple help pages: https://support.apple.com/en-us/HT202304@CB

VDVsx ( 2015-03-05 08:49:00 +0300 )edit

As of v.2.0.0.10 (Saimaa), this is still the correct guide in how to setup an iCloud Mail account.

Lykourgos ( 2015-12-08 01:05:17 +0300 )edit

Does not work on my Jolla running latest Jolla update.

annikki ( 2018-04-02 10:49:35 +0300 )edit

Got the "Problem with authentication" error with my mac.com account today, running 3.0.0.8. Realized that there's an mix-up in the way Sailfish fills out the credentials, it goes with the full email used for incoming and just the username for outgoing, when in fact this should be reversed, as above. When I switched it to just the username for IMAP and the full email address for SMTP, the account was added successfully. Port settings were pre-filled correctly by the OS.

Mike B ( 2018-11-11 22:03:27 +0300 )edit

Question tools

Follow
3 followers

Stats

Asked: 2015-03-04 23:27:25 +0300

Seen: 526 times

Last updated: Mar 05 '15