Ask / Submit
14

Option to keep connections alive in idle state

asked 2015-03-06 03:05:48 +0300

HtheB gravatar image

updated 2016-08-17 11:01:49 +0300

jiit gravatar image

I have notice that the Wireless connection dies when the phone is in idle state. This shouldn't be happening. Especially with apps that need constant connection (like the upcoming Whatsup). I see this as a bug.

I haven't tested it on other connections yet, like Mobile Data and Bluetooth. Please add an option to let us choose which connections should stay on in the background while the phone is in idle state.

edit retag flag offensive close delete

Comments

I guess the problem is you do with your phone. I have mail, weather, tweeter - perfectly updated.

Victorious ( 2015-03-06 03:22:30 +0300 )edit

Same here.

fishegg ( 2015-03-07 11:43:01 +0300 )edit

A setting to circumvent a bug is even less an option. Your whatsapp clone is probably the problem and not the system.

chemist ( 2015-03-09 10:41:21 +0300 )edit
1

Maybe this is the reason, why push mail is still not working? Mitakuluu had an option/fix to keep connection alive ...

Do you have ipv6 in germany (vdsl/telekom)? Here the ip range changes all 20 minutes. (Samsung S3 loose connection)

torti17 ( 2015-03-09 13:14:44 +0300 )edit

Without trying to blame approaches or take sides, although I appreciate the battery saving with the deep sleep behaviour I think that it kind of misses the point if the result is to take all applications "offline". I don't like this behaviour if I won't be getting notifications for e-mails, chat messages etc. The side effect of this is the user to have to wake the phone every now and then to "trigger" all the applications to go back online and check for events etc.

cquence ( 2015-03-09 17:40:03 +0300 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2015-03-09 09:14:32 +0300

Holger gravatar image

I would not call closing of connections a bug, but a feature. In the light of several possible privacy issues, it's fine when I can be sure that phone is not connecting to anything in the area, when I don't want it to. So there should be a possibility to have the current setting. As the subject says: adding an option to keep connection alive would be fine. But please make it configurable.

edit flag offensive delete publish link more
1

answered 2015-03-10 00:48:24 +0300

tigeli gravatar image

Does this happen with all the wlan networks or just a one particular one? As I can assure that SFOS is not doing the disconnecting by itself and it should stay connected all the time.

edit flag offensive delete publish link more

Comments

Thanks for clarifying that the OS does not kill network connections in the deep sleep state.

cquence ( 2015-03-10 13:02:11 +0300 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2015-03-06 03:05:48 +0300

Seen: 314 times

Last updated: Mar 10 '15