Alarm clock: Setting alarm not in line with UI

asked 2014-01-02 12:06:51 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-07-22 11:08:34 +0200

jiit gravatar image

When setting/changing an alarm time, the [Accept] (German: [Annehmen]) button appears in the upper right corner until I actually start to set the time -- and then disappears making place for the indication of the time set in digital form.


  • Move the digital time to the center of the clock, so that the [Accept] button does not disappear (even better: appears only after the time has been changed).
  • Place the [Accept] button in front of the digital time (and make it appearing only after the time has been changed).

The digital time should show "–:–" until the alarm time has been changed. (In the rare case you want to set it to 00:00 or 12:00 you have to move either indicator (hour or minute) once and move it back to start position).

edit retag flag offensive close delete



Agree! The clock should have numbers in each hand so that you could read the time as hh:mm directly from the clock. I guess this is standard QML/Qt-component that should be changed. This woulf solve the problem of what is shown in top-right corner (as the time would be readable in the clock itself.

foss4ever ( 2014-01-02 12:44:05 +0200 )edit

I also find it weired that when the alarm is white it is off and blue when it is turned on. Should it not be the other way around?

minnist ( 2014-01-05 23:43:39 +0200 )edit

+1 for that

cropas ( 2014-01-21 02:49:18 +0200 )edit