Ask / Submit
5

changing keyboard layout for external (bt) keyboard [answered]

asked 2015-03-12 12:51:35 +0200

mkie gravatar image

updated 2015-07-15 15:12:03 +0200

r0kk3rz gravatar image

I connected an external keyboard via Bluetooth. Worked just fine. :)

But this keyboard has a German layout which is not recognized: I only get the EN-equivalent characters when typing - no matter in which application (tried Notes and Terminal so far).

Any possibility to change this?

(My system language is set to English, Text input to German.)

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by heubergen
close date 2015-07-15 15:08:37.780763

Comments

I connected an external keyboard via USB. Worked just fine. :)

Really? Via USB? Was this a 'typo' or did you make some magic happen?

Yo ( 2015-03-13 14:51:14 +0200 )edit

Oops .. typo! I connected via Bluetooth of course.

mkie ( 2015-03-13 15:02:45 +0200 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2015-03-12 13:04:46 +0200

max gravatar image

BT keyboards support was added with 1.0.7.16, Saapunki and in the changelog you can find:

Unable to change the layout of the bluetooth enabled hardware keyboard (default is US layout)

https://together.jolla.com/question/45064/release-notes-software-version-10716-saapunki/#45064-known-issues

I think it is not fixed at the moment, there is a workaround https://together.jolla.com/question/46107/is-there-a-config-file-to-change-bt-keyboard-layout/?answer=67466#post-id-67466

edit flag offensive delete publish link more

Comments

2

Thanks for your fast answer and the link to the workaround!

Shame on me for not finding it before (had been searching for "terminal extrernal keyboard layout" or something like that).

mkie ( 2015-03-12 13:35:21 +0200 )edit

We all suffer sometimes from bad google-fu luck :)

max ( 2015-03-12 14:04:03 +0200 )edit
2

answered 2015-07-15 15:07:10 +0200

r0kk3rz gravatar image

Update on this bug/missing-feature

With upgrade 1.1.7 / Björnträsket we will now have option to set the layout of bluetooth keyboards

Possibility to choose different keyboard layouts for Bluetooth keyboards if paired with one for different languages via Settings > System > Text input > Active layout

edit flag offensive delete publish link more

Comments

Finally, but it does not work for me https://together.jolla.com/question/99076/bug-change-layout-on-bluetooth-keyboard-tohkbd-does-not-work/ Eventhough all settings are set, keyboard recognized, it still has wrong keyboard layout.

nick75 ( 2015-07-15 19:20:34 +0200 )edit

Same here. I just bought a Logitech k480 keyboard, primarily for the upcoming Jolla tablet, and everything works fine with my Jolla phone except the keyboard layout.

eson ( 2015-09-03 09:14:48 +0200 )edit

In 1.1.9.28 my Logitech k480 keyboard works fine also with skandinavian keyboard layouts.

eson ( 2015-09-10 07:53:04 +0200 )edit

Question tools

Follow
6 followers

Stats

Asked: 2015-03-12 12:51:35 +0200

Seen: 555 times

Last updated: Jul 15 '15