Ask / Submit

No media sound in Android apps. How to reset Android sound system?

asked 2015-03-21 12:57:35 +0200

Fuzzillogic gravatar image

updated 2017-01-11 00:01:33 +0200

Since some time I've no audio anymore in Android apps. E.g. Frozen Bubble is silent, there's no sound from video clips in Firefox for Android, et. Weird thing is, when I set voice guidance output in OsmAnd~ to use notification audio instead of media audio, it does work.

This might be the same as this bug, and I too tried muting/unmuting using Android apps, connecting to bluetooth audio, etc. but no change.

Now I reckon these parameters must be stored somewhere. But where? How to reset Android's audio routing and/or volumes?

[edit] I've used the pacmd cli command to dump some information while playing Android audio. The outputs of pacmd stat, pacmd info, pacmd dump, pacmd dump-volume and pacmd list-sinks are here.

[edit2] No change after updating to Not that I expected any change based on the changelog. The issue remains.

[edit 2015-07-15] Just updated to I was hoping that the audio got fixed with the update to PulseAudio 6, but unfortunately it didn't. Android notification sounds still get through (unless phone is set to silence, which makes sense) but normal sound is just silent.

There must be some audio routing for Alien Dalvik somewhere. But where? It's getting annoying :( But resetting the device is even more annoying.

[edit 2017-01-10] Problem still persists, even on 2.0.5.

I've grabbed a bit of logcat, when starting and pauzing an Android app that used to produce sound:

E/ALSADevice(  989): setFmVolume:: ! mIsFmEnabled
D/ACDB-LOADER(  989): ACDB -> send_audio_cal, acdb_id = 14, path =  0
D/ACDB-LOADER(  989): ACDB -> send_adm_topology
D/ACDB-LOADER(  989): ACDB -> send_audtable
D/ACDB-LOADER(  989): ACDB -> send_audvoltable
D/AudioStreamOutALSA(  989): standby
E/ALSADevice(  989): standby handle h 0x41f00db8
E/ALSADevice(  989): Number of modifiers 0
E/ALSADevice(  989): usecase_type is 0
D/AudioUsbALSA(  989): exitPlaybackThread, mproxypfdPlayback: -1
edit retag flag offensive close delete


If you have call recorder installed, stop the daemon and sound will work in all android apps. ;-)

tvicol ( 2015-07-15 20:03:41 +0200 )edit

Yes, I have call recorder installed and active. But disabling it doesn't help :( Tried restarting the device too, after disabling the daemon.

Fuzzillogic ( 2015-07-15 21:12:42 +0200 )edit

5 Answers

Sort by » oldest newest most voted

answered 2015-03-21 13:06:26 +0200

MikErk gravatar image

updated 2015-03-21 13:22:32 +0200

Do you have Sailfish Utilities from Jolla Store installed? Try to stop/restart the Android runtime. I am not an expert with this but I think this will also reset the audio stream from android to pulseaudio.

Eventually there is the possibility to reinstall the alien dalvik Android runtime, but in a quick search I haven't found anything yet, so you might have a look on this yourself.

edit flag offensive delete publish link more



Thanks, but tried that already. Restarting Android runtime or the entire device didn't help. Also, Jolla apps do play sound, and testing with csd doesn't indicate any problems. I did notice that when using a BT headset, the headset indicated there is a stream active when playing sounds through android apps, but it seems to be just silence.

Fuzzillogic ( 2015-03-21 13:16:16 +0200 )edit

answered 2015-03-21 13:22:44 +0200

MikErk gravatar image

Let's try something: Run an android app with sound, go to the shell and type

pacmd list-sinks

There you should get 4 available sinks, from which the second one (index 1) should be the droid sink. Please post the log from it. In my case when working f.e. spotify it shows:

*index: 1
state: RUNNING 
muted: no

If the app is closed it shows "SUSPENDED" as state. The same if the android runtime is killed.

edit flag offensive delete publish link more


Was working on that :) list-sinks is added to dumps. Seems to be OK...

Fuzzillogic ( 2015-03-21 13:36:57 +0200 )edit

hmm just had a look at your pacmd info log and it is pretty similar to mine, especially it shows that your sink is running. So it seems to be a problem on some higher level...

MikErk ( 2015-03-21 13:44:20 +0200 )edit

answered 2016-05-24 21:27:44 +0200

objectifnul gravatar image

updated 2016-05-25 10:09:58 +0200

Same issue here (SFOS Saimaa). Maybe an interesting observation:

I usually don't activate Aliendalvik (only on demand)

I have no audio output from any Android app, except (and only if) I "revive" Android audio within a proprietary app from my internet/phone/mobile/TV provider: TVeverywhere from

At startup, there is no audio within TVeverywhere (audio indicator is muted), no audio in any other Android app. TVeverywhere has a tappable button to activate audio. After having tapped, the audio output is back not only within TVeverywhere but also in all other Android apps using audio (even after having closed TVeverywhere).

If I disable/enable Aliendalvik, I must do this again.

Unless you are a Proximus subscriber, you can't check this of course. Additionally, you must be connected through their own network (in Belgium only).

So it would be interesting to investigate what TVeverywhere does exactly when the "unmute" button is tapped (obviously, there is some pulseaudio or pacmd command allowing to enable Android audio sources). Unfortunately I don't know how to do so.

BTW I have a pending ticket at Jolla Zendesk on this. No conclusive answer so far.

edit flag offensive delete publish link more


I think I got the same issue here: android-app-stops-playing-music-after-a-day

niv ( 2016-07-12 14:14:52 +0200 )edit

answered 2017-02-02 20:16:13 +0200

Fuzzillogic gravatar image

I've had partial success with SoundAbout. By forcing the Media output to Speaker, I got sound again! However... it's not very reproducible. Also, after restarting the Alien Dalvik service, the situation is back to silence.

I do suspect is has something to do with Alien Dalvik's audio routing, that is, the problem is more with Alien Dalvik than with Sailfish, I guess.

I might give up and clear all Android apps, and reinstall Android support all together. That would have been by far the quickest route, in hindsight.

edit flag offensive delete publish link more

answered 2017-11-01 19:15:46 +0200

Fuzzillogic gravatar image

Even on SFOS 2.1.3, after all updates, the problem persisted. It has to be something silly somewhere, but I gave up looking for it. Instead, I removed and re-installed Android support, which solved the problem immediately. Android apps now have sound again, woohoo!

Caveat: when removing Android Support, the android apps are kept, and will work after reinstalling, but all the Android app's data will be removed. So make sure your bitcoin wallets and other precious data is securely backed up ;)

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools



Asked: 2015-03-21 12:57:35 +0200

Seen: 7,312 times

Last updated: Nov 01 '17