Ask / Submit
8

All Android Apps won't start

asked 2015-03-26 12:31:29 +0300

Tuep gravatar image

updated 2015-03-26 17:21:36 +0300

Mariusmssj gravatar image

I am using Android Apps for a long time now and nearly all of them worked as supposed. But yesterday K9 crashed when loading mails. Since now i can not start any Android App. I tried to reinstall some Apps and I also reinstalled the Android support, restart the phone etc. but it stays like that. When I try to start one App, I see the loading circle for 10 or 15 seconds and then its away. No Error or something like that. Do i have to reset the phone?

edit retag flag offensive close delete

5 Answers

Sort by » oldest newest most voted
1

answered 2015-03-26 13:21:41 +0300

rudi gravatar image

updated 2015-03-26 13:48:43 +0300

did you check the hints from e.g.
https://together.jolla.com/question/78346/android-apps-dont-start/
https://together.jolla.com/question/13805/android-support-not-working-apps-not-loading/#post-id-14896
https://together.jolla.com/question/80210/android-apps-or-dalvik-logs-where-to-find/
...

edit flag offensive delete publish link more

Comments

I didnt saw this post. I tried to reinstall apkd but still the apps want start.

Tuep ( 2015-03-26 13:30:10 +0300 )edit

OK, first thank you for your links. But Second i have to warn you, i nearly bricked my phone. I wanted to use the script from this site http://talk.maemo.org/showpost.php?p=1406350&postcount=47 as supposed from you links. The Skript didnt worked so i started typing the commands manually. This (rm -rf /opt/alien/*) nearly bricked my phone. I was stucked in a boot loop afterwards, but i could reset to factory.

Maybe it worked if i would have deleted only the folders listed above the skript.

Tuep ( 2015-03-26 14:41:37 +0300 )edit
1

Weird, this happened , right now, to me as well. I tried almost everything including http://talk.maemo.org/showpost.php?p=1406350&postcount=47 After "rm -rf /opt/alien/*" phone freeze. At then rnd the phone entered in boot loop and now I'm recovering my phone from the factory.

tvicol ( 2015-03-26 15:48:01 +0300 )edit

I just began having the same problem since yesterday. None of the provided solutions seem to work, including restarting the phone. Strange coincidence me and tvicol are having the same issue at the same time. Date related? :)

spidernik84 ( 2015-03-27 09:14:17 +0300 )edit
1

answered 2016-01-12 13:09:36 +0300

Broekeman gravatar image

As of today (2016/01/12) I have the exact same problem as Tuep posted; with Sailfish OS version 2.0. I have tried everything to get it working again (reboot, restarting Android service etc.) but nothing works. When I tried to reinstall apkd it gave me this error message:

Fatal error: apkd-android-settings-0.7.5-110.24.2.jolla.armv7hl requires apkd = 0.7.5.1-10.24.2.jolla, but this requirement cannot be provided.

So... any thoughts or options?

edit flag offensive delete publish link more

Comments

1

Try schturman's Dalvik Cleanup for 2.0.0.10

J4ZZ ( 2016-01-14 00:49:08 +0300 )edit
1

answered 2016-01-17 13:52:37 +0300

groxxorg gravatar image

I had the same problem occurring on January 16th 2016. Weeks before I noticed, that almost all Android-Apps had problems on startup or were crashing. Some messengers didn't deliver messages for hours/days.

Like J4ZZ mentioned, I installed Dalvik Cleanup and reinstalled Android-Support from Jolla-Store. This solved the problem for me. You have to have in mind, that all your data stored under ~/.android will be lost. If needed, you need to copy your pictures etc. manually before reinstalling Android-Support.

edit flag offensive delete publish link more

Comments

This solved it for me also. Just make sure that the developer mode is activated and allow installations from non-Store source setting is on.

Downloaded the latest dalvikcleanup-0.3-8.armv7hl.rpm, plugged Jolla on my comp with a USB cable, copied that RPM in and File Browsed to tap it.

Personally my first thing was to get Telegram back on, so reinstalled Yandex Store, getting it quickly from there.

LinuxJollaIRC ( 2016-01-19 14:48:05 +0300 )edit
0

answered 2016-01-17 16:35:49 +0300

pawel gravatar image

updated 2016-02-27 09:55:50 +0300

had the same problem today. apps would not start. tried to stop dalvik. dalvik stopper said: alredy stopped. so appsseem not to start dalvik . strarted it manually, worked on second try. then apps were working as expected

few days later it started to work as usual. before that i did start alien dalvik manually would not reset phone ..

edit flag offensive delete publish link more
0

answered 2016-02-26 21:08:37 +0300

I had the same Problem since three months ago and today it came again. Last time I fixed it with a fully reset :(

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2015-03-26 12:31:29 +0300

Seen: 2,809 times

Last updated: Feb 27 '16