Ask / Submit
11

Jolla won't charge unless put into "Charge only" mode

Tracked by Jolla

asked 2015-03-26 15:50:30 +0300

If I plug my Jolla in to the PC or any computer for that matter, it will not charge unless I choose "Charge only" mode. This has happened many times where I plug the phone in too charge and it won't charge at all because I did not click on "Charge only" from the menu.

Is anyone else had this issue?

edit retag flag offensive close delete

Comments

2

I had the same experience a couple of times when USB current might have been too low. When I changed into another plug (e.g. from laptop to docking station) the phone started charging also in dev mode.

lakutalo ( 2015-03-26 15:54:27 +0300 )edit

Well my PC has plenty of power from USB 2.0 and 3.0 ports. In work I got a powered usb hub but if I don't click "Charge only" phone just won't charge

Mariusmssj ( 2015-03-26 17:20:31 +0300 )edit

Then I can only guess weak battery or faulty current/voltage measurement.

lakutalo ( 2015-03-26 17:44:27 +0300 )edit
2

I have the same issue

slmeyer ( 2015-03-26 23:13:58 +0300 )edit

I would say more: being plugged in "PC connection" mode it consumes even more power, even when PC is in sleep mode (about 70% were drained overnight)..

kandelabra ( 2016-03-02 10:10:50 +0300 )edit

3 Answers

Sort by » oldest newest most voted
3

answered 2016-09-05 23:52:32 +0300

ThGut gravatar image

My syncing/charging story

After installing Aurajoki 2.0.2.51 I have a problem with charging /syncing to my PC.

Setting to charging only works fine. Setting to PC connection gives the message “Oops, charging does not work…” and neither charging nor PC connection occurs.

I have used different cables, restarted Jolla, used different USB sockets, all with the same result.

Finally I restarted my PC (W10) and syncing/charging worked as it should.

Later on it failed again but after restarting it worked once more.

edit flag offensive delete publish link more
0

answered 2016-09-06 08:54:26 +0300

mirumger gravatar image

Have look at this, it looks like similar issue. link text

edit flag offensive delete publish link more
0

answered 2016-09-06 11:32:18 +0300

sifartech gravatar image

updated 2016-09-06 11:32:58 +0300

I don't know if this can be classified as a bug because it is supposed to be a feature. :)

Go to Settings > USB. If the 'Default USB mode' is set to 'Always Ask', then it will show you the pop-up menu that you mentioned and ask you whether you want to charge the phone or connect to the PC. You can set it to 'Charging Only' or 'PC Connection' mode if that is the default mode you prefer.

edit flag offensive delete publish link more

Comments

The result of setting the default to 'Charging Only' is that nothing happens on my Jolla C.

mirumger ( 2016-09-06 14:52:20 +0300 )edit

That is strange. My first thoughts are that something may be wrong with the usb cable or usb port. Have you tried with a different USB cable and a different computer? If yes, then it could be a bug.

sifartech ( 2016-09-06 19:16:17 +0300 )edit

Yes, other Computers work. I have the same issue with different chargers. Some of them work and some not. But all of them are working for Jolla 1. So I think It's an issue of Jolla C.

mirumger ( 2016-09-07 09:05:50 +0300 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2015-03-26 15:50:30 +0300

Seen: 371 times

Last updated: Sep 06 '16