Ask / Submit
5

facebook albums in gallery don't syncronice/update

asked 2015-03-26 22:50:49 +0200

luigitheluigi gravatar image

updated 2015-03-27 09:47:05 +0200

if i put a new album in facebook (on pc with browser) it doesn't update to jolla's gallery/facebook. the only way to update the gallery is to remove facebook account (on jolla) and then sign in again...the syncronice in pulley menu doesn't do nothing... is there a way to do it that i'm not aware of please share the knowledge :)

edit retag flag offensive close delete

Comments

I'll look into it, thanks for the report.

chris.adams ( 2015-03-27 10:41:02 +0200 )edit

I tried to reproduce this one today, and could not - new albums and new images were detected and synchronized correctly.

Are you able to help me debug what is happening on your device? Do you have developer mode enabled? If not, I'll just keep trying to reproduce internally, but if you do, these steps require developer mode:

1) ssh into device, and do:

systemctl --user stop msyncd
killall msyncd
MSYNCD_LOGGING_LEVEL=8 SOCIALD_LOGGING_LEVEL=3 devel-su -p msyncd

2) ssh into the device again on a different terminal, and do:

devel-su journalctl -af | grep facebook-images

3) trigger sync via Settings | Accounts | long-press Facebook -> Sync

4) send the logs (from the terminals) to chris dot adams at jolla dot com

Hopefully the logs will help me determine what is happening in your case.

Thanks, Chris.

chris.adams ( 2015-04-01 08:49:33 +0200 )edit

i did all that (and jihaa, everything went correct the first time, exept after the line killall msyncd -> msyncd: no process found...) and i suppose that you mean copy/paste from the terminal...well now it's sent.

luigitheluigi ( 2015-04-01 23:15:33 +0200 )edit

thanks for email. i did the thing that i planned already earlier, i deleted the facebook account. when i made new account the missing photos and folders appeard.jihaa. the only problem now is that in the gallery/facebook i have duplicate pictures...before there was 260 and now it says there are 520...am i right in the fact that those are just thumbnails and when you click on a picture it downloads it from facebook. in that case it would be simple to just remove the thumbnail folder and the facebook account and then start all over. after the removal the bar at the top flashed as it is supposed to when syncing, so the removal fixed the issue. so maybe a "how-to-do" guide with simple to understand instructions would be in place for those experiensing the same problem

hmm..just added a new folder to facebook (on pc) and then tried to sync... did not do it....no upper bar flashing (phone memory 7.7/13.7 , btrfs fi show in terminal 13.75/10.38)

luigitheluigi ( 2015-04-02 08:40:30 +0200 )edit

wtf, now it works again....put a test album to facebook and forced syncronisation and it worked.... i give up....

luigitheluigi ( 2015-04-07 20:57:13 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-03-27 09:35:47 +0200

Jomppeeee gravatar image

I think my question is really relevant to this one, someone smarter could look into that :)

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2015-03-26 22:50:49 +0200

Seen: 151 times

Last updated: Mar 27 '15