Ask / Submit
24

The Jolla phone may loose GSM signal

asked 2015-03-27 15:45:05 +0200

romu70 gravatar image

updated 2015-05-17 22:50:40 +0200

saturn gravatar image

It's not the first time this appears with my phone, just would like to know if other have the same issue. After a while the Jolla is up (let's 2 days, may be more, may be less, don't even know if the time is a "variable" here), the phone may loose the GSM signal even in areas where this is signal actually.

Of course, you can't call, receive calls, send or receive SMS, etc. In this case, you only get a "No network" message.

When this happens, the only way to recover the signal I've found is to restart the phone, this makes the signal back...until next time this bug will occur.

Any other?

edit retag flag offensive close delete

Comments

I have exactly the same problem, has been appearing only after update 11. Decided to give up using Jolla as my daily driver,I can't afford to miss client phonecalls. Will most likely return in 1-2 years, Sailfish seems to need some more time to mature.

Jaepis ( 2015-03-27 17:37:58 +0200 )edit
3

Do you have the "utilities" app installed? You find it in jolla store. It gives you a menu in the settings app, where you are able to restart all networking services. You can try if this helps next time this bug occours..

wanderer ( 2015-03-28 09:43:11 +0200 )edit

Thanks. Actually, I've Utilities installed but didn't use it for that, I will test thin, thanks a lot.

romu70 ( 2015-03-28 10:37:48 +0200 )edit

Yes, I have the same problem...

Tomáš Moravec ( 2015-04-19 10:50:26 +0200 )edit

Please convert to a comment (not an answer)

simo ( 2015-04-19 11:02:45 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-05-16 22:54:16 +0200

saturn gravatar image

This is not a real answer, but rather a workaround and maybe an indication, if other people confirm, of the problems source.

Following the comment from @flummi, I have changed the preference of the network to "prefer 3G".

It has been a week and no disconnection has happen since. Before that for the past year I had to reboot the device 2-3 times per week and have lost numerous calls.

edit flag offensive delete publish link more

Comments

My Provider only offers 3G, so the "Prefer 3G" is default for me, still got random disconnects. My solution is to go to Settings -> System -> Mobile Network and change the network mode (for example form "Prefer 3G" to "Prefer 4G"). My Jolla re-connects to the mobile network and I don't need to reboot. I've tried the "Restart network connections" in Utilities with no success. (1.1.2.16)

The signal loss occurs very rarely and feels random, but is annoying because I never know when it happened and how long I was offline.

Enyogyo ( 2015-05-20 03:25:02 +0200 )edit

Thanks for the trick @Enyogyo, I'll try that the next time my Jolla gets disconnected.

romu70 ( 2015-05-20 10:04:39 +0200 )edit

Just to update, I had to change provider and now I gave it a try again without forcing it to 3G, i.e. my current setting is back to prefer 4G.

It has been a month and no lost calls. Half the time was at OS 1.1.7 and the rest at 1.1.9. My problem of course was with a previous version and therefore cannot conclude if they have fixed it or if it is a provider-OS specific issue.

saturn ( 2015-10-15 01:18:12 +0200 )edit

I've to say I didn't had the issue in the recent past neither. So, I guess this should say it's fixed.

romu70 ( 2015-10-15 10:27:55 +0200 )edit
Login/Signup to Answer

Question tools

Follow
9 followers

Stats

Asked: 2015-03-27 15:45:05 +0200

Seen: 946 times

Last updated: May 16 '15