Ask / Submit
1

Adjust time in Sailfish Emulator

asked 2015-03-31 12:44:14 +0300

verydeep gravatar image

Hello,

I was trying to develop a small app which shows public transit timings. Time on the emulator is off by an hour (My laptop time is in CET, and the emulator adds one hour to CET time). I tried changing the device time by logging in as root to the VM, and issuing date command with new date. Although it updates time, it is not reflected in the device UI. Restarting lipstick process reverts time to CET+1. Is there any way to force emulator to use correct time?

Thanks

edit retag flag offensive close delete

Comments

Could this be related to https://together.jolla.com/question/88311/summertime-bug/ ?

Alex-S ( 2015-03-31 13:07:39 +0300 )edit

No. I have been seeing this problem 3 days before DST came into effect .Thats when I started using the emulator.

verydeep ( 2015-03-31 13:14:14 +0300 )edit

Its not just one app. System time in VM itself is off by an hour. Issuing date command shows that it is ahead by an hour compared to my laptop.

verydeep ( 2015-03-31 13:16:34 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-04-01 22:22:31 +0300

verydeep gravatar image

updated 2015-04-01 22:22:43 +0300

I was able to fix this issue in two steps: 1. Disable time synchronization in VirtualBox by referring to this link: http://superuser.com/questions/742924/is-it-possible-to-get-a-virtualbox-vm-always-start-from-same-time-if-so-how 2. Log in to VM root shell and set time manually using date command

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2015-03-31 12:44:14 +0300

Seen: 59 times

Last updated: Mar 31 '15