We have moved to a new Sailfish OS Forum. Please start new discussions there.
23

Mobile data connection even if disabled, v1.1.2.16

asked 2015-03-31 20:27:05 +0300

chaoaslady gravatar image

updated 2015-03-31 21:57:13 +0300

This is really annoying! We got a bill from our mobile network operator of about 150€ because of mobile data connections. WTF?!?

I bought the Jolla phone in February '15. As my old SIM card was too big for Jolla, I ordered a new microSIM from my wireless network operator. We started using the Jolla phone with the new card at the first of March. But as I don't have a contract with a mobile data contingent, I didn't activate mobile data connection in system -> mobile internet. Mobile connection was always switched off. I only activated WLAN at home to connect to the internet.

This month, my bill was the following:

WAP / Internet               152,6970€
Date       Time     Service   Units  Amount
01.03.2015 17:38:14 Internet 180 Min 13,6134€
02.03.2015 06:53:12 Internet 180 Min 13,6134€
02.03.2015 16:37:08 Internet 180 Min 13,6134€
04.03.2015 18:41:02 Internet 2 Min    0,1513€
04.03.2015 18:42:22 Internet 77 Min   5,8235€
13.03.2015 14:17:19 Internet 180 Min 13,6134€
14.03.2015 17:00:48 Internet 180 Min 13,6134€
16.03.2015 07:22:28 Internet 180 Min 13,6134€
16.03.2015 16:52:44 Internet 180 Min 13,6134€
21.03.2015 09:33:40 Internet 140 Min 10,5882€
21.03.2015 13:07:36 Internet 180 Min 13,6134€
23.03.2015 18:04:11 Internet 180 Min 13,6134€
24.03.2015 12:32:05 Internet 180 Min 13,6134€

This is a huuuuge amount of money. What else can I say? Where does it come from? I really, really did not activate mobile data connections. :-(

How can I permanently erase any mobile data connection access points? I can not find a possibility to do so...

Help would be very appreciated

edit retag flag offensive close delete

Comments

3

That's shocking!, it's happened to me but on a much smaller scale. Anyway, to edit settings for your data access point,, go to; Settings - System - Mobile Network - and long press on the Mobile Broadband connection and select edit - there you can only rename the access point, I just did this on mine; I usually use giffgaff.com as my access point but I changed it giffgaff.conand the connection is then refused. I tried deleting all data from the access point, but it doesn't work, oddly giffgaff.com is back again but without username and password and I'm still connected and using data.

Spam Hunter ( 2015-03-31 20:43:22 +0300 )edit
1

Thanks Markkyboy, As you stated above I long pressed on the Mobile Broadband connection in the Mobile Network section. There, I completely deleted the name and the access point. It seemed as it was gone after saving, because there was no symbol for mobile data connection at the top of Settings. But after a restart, interestingly, the access point is there again, but without a name, the same as you described. The symbol for mobile internet at the top of the Settings menu is still missing, though. But will it now really stay inactive? :-|

I want to mention, that I could never activate mobile data connection until today, even if the symbol was there in the Settings menu. It was greyed out. Only after activating "Prefer 3G" made that I could activate mobile data connection. I think this was related to this bug: https://together.jolla.com/question/46865/bug-phone-disables-mobile-network/

chaoaslady ( 2015-03-31 21:03:35 +0300 )edit
2

You're welcome, but I would advise to change the access point name if you can't make it stay deleted and remove username and password. I did try all I have described to you to make sure, it wasn't lip service or me guessing. :) So after I altered my access point name to .coN instead of .coM, I purposely tried to view web pages, Openrepos and Jolla Store, no connection could possibly be made, as giffgaff.coN does not exist. So to answer you question, it will stay inactive, it has to purely by an incorrect access point name or no name as you have . Try it, if you cannot access anything from the web, the problem should be solved, so to speak :)

Spam Hunter ( 2015-03-31 21:25:30 +0300 )edit
1

Thanks, I changed the the name of the access point, and it seems to stay, even after rebooting. (My username and password has been empty from the beginning). All in all, really annoying is the fact that the Jolla phone makes a connection in the background without letting me know. This is really a no-go, @Jolla people! :-(

Btw: The problem was there even from the very first day than we had our new Jolla phone. I had not installed any non-Jolla apps, other than the official Jolla ones!

chaoaslady ( 2015-03-31 21:56:37 +0300 )edit
1

Awful... This shouldn't happen! I hope you'll be contacted by Jolla for what you've experienced. Thanks for bringing such an important issue up - I think this one should be granted a new "serious-bug" tag, and that should be added to the yellow featured tags on the front page, to ensure new customers are more aware of this.

simo ( 2015-04-01 01:28:10 +0300 )edit

4 Answers

Sort by » oldest newest most voted
7

answered 2015-04-01 01:43:06 +0300

simo gravatar image

A bug possibly causing money loss to Jolla's customers should be informed fast and clearly to all customers via email, and kept on top / under featured tag "warnings" here at TJC until fixed. As a workaround (from comments under the question):

  • Go to settings > System > Mobile Network
  • Long hold on the mobile network > Select "Edit"
  • edit your access point name to a non working name, for example with changing the last letter
  • Tap on "accept" or flick left to accept the change

Please don't suggest this workaround as the correct answer, and please don't close this question until the bug is either fixed or confirmed non-existing by Jolla. Please inform your friends using Jolla about this. I hope no one will loose money because of this bug

edit flag offensive delete publish link more

Comments

1

Agreed @simo, about your comment regarding my 'workaround', which is why I only commented, rather than posting it as an answer. My intention was to at least stop any further financial loss for now until a fix is found.

I have already experienced a small loss of credit to the tune of only £10.00 with the same problem, but this was with an earlier version of SFOS and I haven't had the problem since. At the time, I blamed my provider, seeing it as an account problem, until I realised it was actually a problem with the phone.

Regards,

Spam Hunter ( 2015-04-01 02:39:39 +0300 )edit
5

answered 2015-05-10 11:51:58 +0300

chaoaslady gravatar image

updated 2015-05-10 13:55:10 +0300

Hi,

this is just an update for all interested Jolla users: After activating "Prefer 3G" in the mobile network settings menu, I could not reproduce the connection problems from my original post. Probably, the Jolla phone had a problem with the default setting "prefer 4G" because actually my mobile network operator (MNO) does not provide 4G.

A developer from Jolla showed me how to export connection log-files from my phone which I sent to him. Unfortunately, he couldn't find any hints of a connection started in the background. But again, these logs have been generated only _after_ the time where I switched from "prefer 4G" to "prefer 3G". Going back to 4G didn't result in reproducing the original problem either.

I don't know if this problem has been fixed in a newer version than v1.1.2.16 of SailfishOS. But I would advice everyone who does not have a mobile Internet flat rate and whose MNO does not provide 4G should activate "prefer 3G" in the connection settings.

chaoaslady

edit flag offensive delete publish link more
1

answered 2015-11-15 22:14:33 +0300

tsarajar gravatar image

Seems this problem occurs also with the latest 2.0 SFOS. We had this problem with a pre 2.0 SFOS, and it still continues after the update.

I haven't narrowed it down to being a 3G vs 4G issue, but the phone definitely connects to the internet even with mobile data disabled. We just received a 40€ phone bill due to the phone trying to access the internet (with the old SFOS). Recent logs from the phone company says "Transmitted 0.001 MB" several times a day, and we are now using SFOS 2.0. Whereas our Jolla still says 0 kb transmitted or received :(

Changing access point name now to see if there's any difference.

edit flag offensive delete publish link more

Comments

1

@tsarajar I've tried to reproduce this issue several times and never succeeded. Also no one has yet provided me the logs from where I could see what's the problem exactly.

tigeli ( 2015-11-16 08:23:28 +0300 )edit

@tigeli, @nauevg has also reproduced this behaviour under SFOS 2.0.0 (as @tsarajar did, above) and ultimately @Bart Sunder SFOS 2.2.0, still.
Though I personally have never seen any interfaces (e.g. rmnet_data0) being up (per ifconfig) other than lo ("loop-back") and wlan, while in WLAN. But it would take creating an a small debug facility to monitor this permanently (instead of a few samples by manually checking).

olf ( 2018-07-18 22:45:39 +0300 )edit
0

answered 2016-08-12 06:48:29 +0300

I just realized this summer that my Jolla is using mobile data even when mobile data is not enabled. I haven't been able to figure out why it does that. Right now I know that the phone has made a mobile data connection within the past 24 hours while mobile data has been disabled. The only open applications have been: settings, messaging and terminal. Could somebody tell me what log information I shoudl be looking for to figure out the cause of this problem. I am still using SailfishOS version 1.1.7.28.

edit flag offensive delete publish link more

Comments

My question is not really relevant to your question, but I will ask anyway - Why are you still on SFOS 1.1.7.28?

Spam Hunter ( 2016-08-12 10:45:24 +0300 )edit

this might also be a bug at your operator's side, I read about small data usage if a 4g network was used while roaming. It seems to happen with different phone models and operating systems. Maybe this is happening in the home network too and only becomes visible if no mobile data is used normally?

till ( 2016-08-12 11:29:48 +0300 )edit
1

I'm using 1.1.7.28 because I did not like the new user interface.

telefaksi ( 2016-08-12 12:07:23 +0300 )edit

You should update to the latest version, because you're now using a really old version that has countless bugs and big security holes which have been fixed in the latest version. You're only putting yourself at risk.

nthn ( 2016-08-13 22:20:13 +0300 )edit

Could be AGPS, try turning it off

slava ( 2016-08-26 11:21:06 +0300 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2015-03-31 20:27:05 +0300

Seen: 1,077 times

Last updated: Aug 12 '16