Ask / Submit
15

Time zone changes to Finland, Helsinki when enabling "Automatic update" while no SIM card is inserted

asked 2013-12-25 04:13:01 +0300

Behold gravatar image

updated 2013-12-25 18:09:01 +0300

When enabling "Automatic update" in "Time and date", the time zone changes from my current Sweden, Stockholm (UTC+1) to Finland, Helsinki (UTC+2) and the time skips ahead one hour. If I disable "Automatic update" the time zone changes back to Sweden, Stockholm again. I understand that "Automatic update" is supposed to automatically detect the time zone from the mobile network operator, but as I do not currently have a SIM card that I can use with the Jolla, this obviously fails. It would be nice if the current time zone was kept until new time zone data is received from the operator.

edit retag flag offensive close delete

Comments

Does this still happen?

nthn ( 2015-01-11 23:37:27 +0300 )edit
1

I have noticed the same problem at the end of December 2014.

Self-Perfection ( 2015-01-11 23:41:26 +0300 )edit

I get a similar problem here in Australia, the 4G network doesn't send time data, so 'automatic time' acts the same as if there is no SIM card, and sets the timezone to 'Australia/Melbourne' (even though my manual setting is for 'Australia/Perth'). If I switch to 3G, then 'Australia/Perth' is correctly set.

mattaustin ( 2015-02-12 11:25:13 +0300 )edit

Just noticed this on my new Jolla that I'm using on Wifi without a SIM whilst I get used to it.

mr_jrt ( 2015-03-02 03:53:07 +0300 )edit

F#ck you Jolla! I wake up due to this bug in inappropriate time. Sailfish OS version is 1.1.2.16 Yliaabanlampi and issue can be repeated without sim. Will the same happen with the Jolla tablet too? Haven't been fixed in last 2 years? Where is the source of changing time zone manually? These little annoying issues turn the image and reputation of Jolla.

llg179 ( 2015-03-18 06:04:35 +0300 )edit

6 Answers

Sort by » oldest newest most voted
4

answered 2013-12-25 13:48:38 +0300

thwint gravatar image

I have the same issue. Currently I have no SIM card inserted. Then It changes back to Helsinki timezone. Also in Switzerland.

When inserting the SIM card it automatically changes to Zurich, Switzerland

edit flag offensive delete publish link more

Comments

1

Ah, yes, I forgot that I currently don't have a SIM card inserted, so that would explain it. I still wish that the phone would just keep the current time zone.

Behold ( 2013-12-25 14:41:34 +0300 )edit

Also just saw the no-SIM card bit. FWIW this is also the behaviour in the current Nemo so may be quite low down the stack

steph ( 2013-12-25 21:20:57 +0300 )edit

Seeing this problem too. I have no SIM card yet either. Looks like something along the stack takes the timezone from what the cell towers tell it, defaulting to something built-in instead of keeping the user defined setting.

bilog ( 2013-12-26 12:33:30 +0300 )edit
4

answered 2013-12-28 23:34:29 +0300

bilog gravatar image

updated 2015-01-11 23:36:40 +0300

nthn gravatar image

A possible workaround I've found is the following, to be input in the terminal (might require developer mode to be active).

  • stop the timed-qt5 daemon:

    $ systemctl --user stop timed-qt5.service

  • edit the file /home/nemo/.timed/settings.data, changing the timezone specified in cellular_zone to the one set in manual_zone

  • restart the timed-qt5 daemon:

    $ systemctl --user start timed-qt5.service

Now you can enable automatic updates and the time zone will be the correct one.

edit flag offensive delete publish link more

Comments

1

This worked for me too, thanks. Forgive me for not accepting your answer as correct, though, since to me a workaround is not the same as a proper solution. I guess the expected behaviour would be something like updating cellular_zone whenever manual_zone is changed.

Behold ( 2013-12-28 23:52:32 +0300 )edit
1

Actually I think they just expected users to have a SIM card (and thus they would be able to get the correct time zone from the cellular network always). And BTW I agree with you, this workaround should not be considered a ‘correct answer’ because the ‘correct answer’ would be for Jolla to fix this in Sailfish OS ;-)

bilog ( 2013-12-29 08:42:33 +0300 )edit

Unfortunately this doesn't work for my slight variation on the issue (where 4G does not provide network time data, but 2/3G does). Every time I start timed-qt5.service, my cellular_zone is set back to 'Australia/Melbourne', even though manual_zone is set to 'Australia/Perth' (and the network is not providing time data). Switching to 3G fixes it, and I can switch back to 4G fixes until the next boot.

mattaustin ( 2015-02-17 04:46:43 +0300 )edit
1

answered 2013-12-25 11:32:15 +0300

juergbi gravatar image

This works fine here in Switzerland. I assume that the time zone information is retrieved from the mobile network operator. Assuming you're connected to a Swedish network, it may be a provider-specific issue.

A possible alternative may be to setup NTP, however, it doesn't appear to be installed by default.

edit flag offensive delete publish link more

Comments

well, it uses ntp or timed to get the correct time.

when I specify Automatic update, I want automatic update of the time, not the time zone. I'd like to control what time zone manually. especially while I use my SIM card in a different phone :-p

so... the workaround is to turn on automatic update for a couple of minutes every other day. still better than Android, which has no way of setting the time from the network.

kjetilho ( 2015-03-08 01:03:45 +0300 )edit
1

answered 2013-12-28 02:12:25 +0300

thwint gravatar image

With the update to 1.0.2.5 the problem seems to be resolved. At least on my device it now shows the Switzerland timezone even without SIM card

edit flag offensive delete publish link more

Comments

1

Unfortunately, I still have the same problem: http://i.imgur.com/36n8EwN.pnghttp://i.imgur.com/g8gBvZU.pnghttp://i.imgur.com/HELTmQS.png

Behold ( 2013-12-28 14:48:15 +0300 )edit
1

I too have the same problem with 1.0.2.5 without a SIM card.

axaq ( 2013-12-28 19:12:31 +0300 )edit
1

answered 2015-07-26 23:50:50 +0300

shmerl gravatar image

I have the same problem (Sailfish on Nexus 5). There should be a way to set explicit timezone even for automatic updates mode.

edit flag offensive delete publish link more
0

answered 2013-12-25 13:40:38 +0300

steph gravatar image

Unable to reproduce in the UK. Automatic update is set and the correct TZ is shown, unticking Automatic update and the TZ changes to Helsinki, but can be manually altered to London. Either way, ticking Automatic update returns the TZ to London for me.

edit flag offensive delete publish link more

Comments

Isn't London and Helsinki in the same timezone?

llg179 ( 2015-03-18 06:02:12 +0300 )edit
Login/Signup to Answer

Question tools

Follow
6 followers

Stats

Asked: 2013-12-25 04:13:01 +0300

Seen: 1,147 times

Last updated: Jul 26 '15