Ask / Submit
14

[Bug] Contact with short phone number isn't recognized in call log or messages

asked 2014-01-02 19:39:32 +0300

mer2os gravatar image

updated 2014-08-13 10:19:31 +0300

jiit gravatar image

Hi, When I receive a phone call from a contact which is stored in my phonebook, the name doesn't show up. It only shows the number. I live in Lebanon and all my contacts are stored with their country codes since I travel a lot. I already reset the phone several times. This doesn't fix the problem. I had the same problem with a Nokia phone I had, since I bought it abroad and it was made for Asians countries. So I had to flash it and install the firmware specific to my region. I hope this is not the case with Jolla, or else it would be really sad. Nowadays smartphones don't have this issue at all. Please try to work on a fix for the next update, or if you already have a solution for this please let me know. Regards,

EDIT:

Sorry replying late. Thanks for your comments.

My phone is up to date with latest Sailfish version 1.0.3.8

Status:

All phone numbers are stored with the international and country code ex: +44... for UK +33... for France For Lebanon, country code is +961... for example +9613492501

Problem:

When I get a phone call the stored name doesn't appear, I get 03492501 instead of the name of the person which this number is assigned to. fed-up with this problem, every time I received a call I stored the number without the country code. So contact has same number with and without country code. But the problem is still there, even after doing this (which for me is not a solution at all) contact names still don't appear, just the number.

What I noticed:

In Lebanon, number start as follow: - 03999999 - 01999999 - 05999999 - 70999999 - 71999999 - 76999999 .... the problem occurs only with numbers starting with a zero (03... or 01....). Phone only takes into account the 1st 8 digits (from right to left) and thus omits the zero so the number becomes 3999999 and is 7 digits instead of 8 digits. Example: 03999999 is 7 digits since it starts with zero (name doesn't appear, only number). 70999999 is 8 digits since it starts with seven (no problem, contact name appears).

Initially:

Updated my phone to latest version 1.0.2.5

I synced my contacts from my N9 via Bluetooth. Discovered problem. Used for a few days. Reset phone. Update phone again to 1.0.2.5.

Synced my contacts from N9 via Bluetooth. Did not create other accounts like Google and Facebook. Problem still there. Used for a few days. Reset phone. Update phone again to 1.0.2.5.

On N9 exported contact on .vcf file with N9QT. Copied file on Jolla. Imported contacts from file. Better synchronisation than via Bluetooth (with Bluetooth had some contacts missing). Problem still there. Using the phone right now with this problem. Hoping for a fix via software update.

So what shall I do, as this is very annoying. I hope this explains well the problem...

Edit: Seems to happen for all interactions with a contact with a phone number with 7 digits (8 including leading "0") or fewer and still in 1.0.8.19: https://together.jolla.com/question/50976/contact-with-a-short-phone-number-is-not-recognized-properly-in-calling-screen-phone-history-nor-in-messages/

edit retag flag offensive close delete

Comments

In which account contacts this happened? (Contacts from all accounts are mixed together n the People view)

simo ( 2014-01-02 21:30:56 +0300 )edit

we had a similar issue. on the second call the number got resolved into the name properly.

Low ( 2014-01-02 23:33:06 +0300 )edit

@mer2os: this issue is probably related to the way that the data is stored for the contact. Does the contact have first and last names, or just a nickname? Can you show how the number appeared from the operator, and how it is stored in the contact?

MattVogt ( 2014-01-02 23:57:48 +0300 )edit

@MattVogt: My contacts are stored by First Name and Last Name. Anyway the issue doesn't come from that, it rather comes from the description I just gave earlier.

mer2os ( 2014-01-06 19:00:25 +0300 )edit

@mer2os: thanks for the information. Yes, the problem is that the numbers are being compared with 8 minimal digits, and you're only getting 7 matching minimal digits. We will need to allow you set the matching value down to 7 digits. If you add the local form to your contact, though - then it should match exactly. Are you sure that it still fails to show the right contact, after saving the local number form to the contact?

MattVogt ( 2014-01-06 23:11:38 +0300 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2014-01-15 18:25:38 +0300

Stefanix gravatar image

Best practise is to have all contact's phone numbers in international format (+cc). Unfortunately the CLI (Calling Line ID) is often sent in national format without country code and this is out of users control. Making the matching length shorter so that the national escape code (often "0") is excluded raises the change of having multiple matches, but I think the chances are low. It should be easy to have this configurable. Of course this is not a SF problem, but a general one.

The configurable matching length could be hard to understand for the average user.

I see 2 other solutions :

1) If the CLI is NOT in international format, ignore the leading digit, as it is often the national escape code preventing the match, and allow a match with the remaining digits, even if shorter than 8 digits.

2) If the CLI is not in international format, convert it into international format. Based on the current cell ID, the country can be determined by the mobile country code. Cut the first digit of the CLI and add the E.164 county code with help of a translation table. As some countries don't use national escape codes, a bit more complicated modification rules might be necessary, plus this rule set must be regularly maintained for numbering plan changes. So it might not be feasible.

edit flag offensive delete publish link more

Comments

I do not get why you think that configurable matching length could be hard to understand for the average user. This is not a rocket science. And it could be the easiest solution.

Silwer ( 2014-02-25 08:48:26 +0300 )edit
1

Hi there,

Since update 6 and 7 are being worked on, I would like to reopen this bug. I'm saying bug because nowadays all phones don't have these problems any more. People around me own iPhones, Windows phones and Android phones and none of this happens.

Myself having owned a N900 and N9 didn't have this problem. Now with my Jolla, all my contacts must have the same number twice. One with the international code, and one without. If I don't have the +cc with the number, when I get a text message it doesn't show the name of the contact. And If I don't have the number without the international code, then when receiving a call the name won't appear.

This is only the issue with numbers of 7 digits max. Like 01222222 or 03222222. Therefore I have to save them like this: 01222222 +cc1222222

I don't know if I'm explaining this well. But I can explain it again and again until I get answered with a solution.

Hope someone at Jolla understands my concern...

mer2os ( 2014-05-21 12:26:55 +0300 )edit
0

answered 2015-07-29 09:01:27 +0300

This issue can be solved by using the following steps. I am using Lenovo K3 note with android 5.0 go to contacts then go to more features and settings then go to more display features. and select number match bits and change it to 7 from 11. Courtesy my friend Salem Khan who found this.

edit flag offensive delete publish link more

Comments

Are you sure that works for Jolla ???

mlwn ( 2015-08-03 01:37:38 +0300 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2014-01-02 19:39:32 +0300

Seen: 3,940 times

Last updated: Jul 29 '15